Issues with running Apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Issues with running Apache

Postby martynball » 08. May 2013 17:33

I have had XAMPP installed before, but it stopped working. So What I have done is uninstall it and then install a newer version.

I noticed though that the "mysql" service was pointing to the wrong path, it was pointing to "c:/xampp..." when it should be "c:/xampp2..." so I went into regedit and changed it. I'm still having issues though, MySQL seems to be running find, but apache will not work at all, here is the error:

Code: Select all
05:27:15 PM  [Apache]    Attempting to start Apache app...
05:27:15 PM  [Apache]    Status change detected: running
05:27:16 PM  [Apache]    Status change detected: stopped
05:27:16 PM  [Apache]    Error: Apache shutdown unexpectedly.
05:27:16 PM  [Apache]    This may be due to a blocked port, missing dependencies,
05:27:16 PM  [Apache]    improper privileges, a crash, or a shutdown by another method.
05:27:16 PM  [Apache]    Check the "/xampp/apache/logs/error.log" file
05:27:16 PM  [Apache]    and the Windows Event Viewer for more clues


Weird though as there are no errors, there isn't even an error.log file!
martynball
 
Posts: 4
Joined: 08. May 2013 17:29
Operating System: Windows 7 64-bit

Re: Issues with running Apache

Postby Altrea » 08. May 2013 17:40

We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Issues with running Apache

Postby martynball » 08. May 2013 17:43

Yes
martynball
 
Posts: 4
Joined: 08. May 2013 17:29
Operating System: Windows 7 64-bit

Re: Issues with running Apache

Postby Altrea » 08. May 2013 18:04

start apache_start.bat in Windows command line
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Issues with running Apache

Postby martynball » 08. May 2013 18:14

It isn't in English :S

Code: Select all
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted.  : AH00072: make_sock: could not bind to address 0.0.0.0:
80
AH00451: no listening sockets available, shutting down
AH00015: Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .
martynball
 
Posts: 4
Joined: 08. May 2013 17:29
Operating System: Windows 7 64-bit

Re: Issues with running Apache

Postby martynball » 08. May 2013 18:17

Ah, port 80...

I closed Skype and it works now, thanks :)
martynball
 
Posts: 4
Joined: 08. May 2013 17:29
Operating System: Windows 7 64-bit

Re: Issues with running Apache

Postby Altrea » 08. May 2013 18:54

You are welcome :)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests