XAMPP Portable Lite 1.8.1

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP Portable Lite 1.8.1

Postby mbuckler01 » 29. April 2013 22:29

Windows XP, installing to g:/xampp. I have installed this at least 5 times in the last few weeks, hoping it just needed a bug fix. I have the Visual C++ runtimes installed, confirmed in Control Panel. The .EXE installer crashes as soon as it hits the call to PHP. It freezes the whole computer, requiring a hard shut down. Control Panel will start up Apache after reboot, but will not stop it, nor can Localhost be accessed. MySQL will not start, just freezes. I have been using this product a couple of years, teach a few courses using it, and need to get an installable version ready for my classes next week. Any suggestions?
mbuckler01
 
Posts: 8
Joined: 29. April 2013 22:21
Operating System: Windows XP

XAMPP freezes the whole computer

Postby mbuckler01 » 29. April 2013 23:58

Windows XP, installing to g:/xampp. I have installed this at least 5 times in the last few weeks, hoping it just needed a bug fix. I have the Visual C++ runtimes installed, confirmed in Control Panel. The .EXE installer crashes as soon as it hits the call to PHP. It freezes the whole computer, requiring a hard shut down. Control Panel will start up Apache after reboot, but will not stop it, nor can Localhost be accessed. MySQL will not start, just freezes. I have been using this product a couple of years, teach a few courses using it, and need to get an installable version ready for my classes next week. Any suggestions?

[edit by Altrea: splitted from original thread because announcements and sticky posts are not meant to be for support requests]
mbuckler01
 
Posts: 8
Joined: 29. April 2013 22:21
Operating System: Windows XP

Re: XAMPP Portable Lite 1.8.1

Postby hackattack142 » 30. April 2013 00:46

Hello,

Do you have the correct version of VC++ runtimes installed? (you need this version: http://www.microsoft.com/en-us/download ... px?id=5582 as other versions and other architectures will not work).

Is there a reason you need the lite version?

You can also get the non-installer version and extract to the location you want. You will need to run 'setup_xampp.bat' after extracting.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: XAMPP Portable Lite 1.8.1

Postby mbuckler01 » 30. April 2013 21:29

Installed right from your link. I need the light version because the university I teach at will not allow servers to be installed on their hard drives in the labs and their security will not allow path or registry changes. They do allow USB thumb drives, however. So Lite is perfect for me teaching AJAX for those students that do not have their own portables. What is the difference if I manually extract it or use the self-extractor? Still have to run PHP to get to the pages, but I will see if there is any difference.
mbuckler01
 
Posts: 8
Joined: 29. April 2013 22:21
Operating System: Windows XP

Re: XAMPP Portable Lite 1.8.1

Postby hackattack142 » 01. May 2013 01:05

You can also use the full version on a USB stick if you use the non-installer version. You can extract it to the location you want and run the setup batch file as I said. This does not require any path/registry changes. You can run all modules standalone (red 'X' under service). The only real downside to this is if the drive letter on the USB stick maps to different drive letter each time, you will need to run the setup batch file again to correct the paths.

Out of curiosity, how did you install the runtimes if you are not allowed to make registry changes (could be an issue)?
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: XAMPP Portable Lite 1.8.1

Postby mbuckler01 » 01. May 2013 03:18

Far as I know, the whole point of Lite is that it doesn't need to make any registry changes. No problem installing to a stick in the last 2 years until this current download. Doesn't even put a shortcut on the desktop, just go to e.g. g:\xampp and run control.exe. They tell you specifically not to run the setup...bat files with Lite. Makes absolutely no difference what drive letter is assigned, plug it in, run the .exe and off you go. That's the point. I believe the problem is whatever they did weird to need to mess with the C++ runtime. This is nothing, getting Eclipse onto those University computers for my Java classes was almost a lifetime project. Never mind the Web plugin updates. It's so bad that Google and Firefox are not even allowed to update themselves. Oh, well, teaching state of the art with rotting software. I would really like to know what this problem is, though. Teaching MySQL next term and will once again need stick downloads for, would you believe, CS majors without their own portables.
mbuckler01
 
Posts: 8
Joined: 29. April 2013 22:21
Operating System: Windows XP

Re: XAMPP Portable Lite 1.8.1

Postby mbuckler01 » 01. May 2013 16:31

Hah, some progress. Doesn't matter if install to USB from .exe or .zip. File that fails is the setup batch file when it calls PHP.exe. Running test_php.bat produces results that C++ runtime is correct, then it fails on running php.exe. If I change the bat file test_php.bat to run the php.exe on my older C:\ drive full installation, everything is fine. Next move, later, will be to change the setup batch file to use the c drive installtion php.exe, set the runtime, to usb, and see if there is any change. I expect it will work for the bat file, then fail on running the usb drive version of php. We shall see.
mbuckler01
 
Posts: 8
Joined: 29. April 2013 22:21
Operating System: Windows XP

Re: XAMPP Portable Lite 1.8.1

Postby hackattack142 » 01. May 2013 22:16

Hello,

If you were using versions prior to XAMPP 1.7.4, there were compiled with VC6 which does not require installing extra runtimes.

This could also be the case with the version of PHP you have installed locally (you could test by opening a command prompt at the location of your local PHP and running "php -i > output.txt" and check the Compiler value at the top).

Version after 1.7.4 but prior to 1.8.0 required VC9 which needs to be installed manually (may have been installed by other software though).

Versions including and after 1.8.0 have Apache compiled with VC10 and PHP compiled with VC9. Only the VC9 runtimes are required to be installed manually though.

You can test what the problem is by trying to manually launch Apache from your portable XAMPP (apache_start.bat) and looking at the error it is providing.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: XAMPP Portable Lite 1.8.1

Postby mbuckler01 » 01. May 2013 22:32

Launching Apache works and has always worked in this scenario. Problems occur if you try to run Admin on it in XAMPP Control Panel or get to localhost from a browser. So it isn't Apache, it is PHP. On the .bat files, it fails on the php.exe call, but the tests show that the runtime is installed, correct and VC9. It seems like it would be that runtime causing the problem, but there is nothing apparent wrong with it. I just put that stick into one of my university lab computers and it came right up, so now I have it localized to php.exe running only on my laptop which fails and only the version from 1.8.1 install. not the 1.7.x which runs fine. ???????
mbuckler01
 
Posts: 8
Joined: 29. April 2013 22:21
Operating System: Windows XP

Re: XAMPP Portable Lite 1.8.1

Postby hackattack142 » 02. May 2013 00:21

Okay, a bit more information is needed before I can really say much more.

1. Do all 1.7.x versions work including 1.7.7 (PHP is different in version 1.7.5 and 1.7.7 than prior versions)?
2. What test is showing the runtime is installed?
3. Is PHP providing any error messages (please post it if it is)?
4. What happens if you try to run the following command from a command prompt (Start > Run > cmd): "g:\xampp\php\php.exe -i"?
5. Are there any errors in the PHP error log file (/xampp/php/logs/php_error_log)?
6. Are there any errors in your Apache error log file (/xampp/apache/logs/error.log)?
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: XAMPP Portable Lite 1.8.1

Postby mbuckler01 » 02. May 2013 15:57

1. PHP from hard drive that works fine on full install "php -I > output.txt" produces:
phpinfo()
PHP Version => 5.4.7

System => Windows NT D720XZ81 5.1 build 2600 (Windows XP Home Edition Service Pack 3) i586
Build Date => Sep 12 2012 23:44:56
Compiler => MSVC9 (Visual C++ 2008)
Architecture => x86
Configure Command => cscript /nologo configure.js "--enable-snapshot-build" "--disable-isapi" "--enable-debug-pack" "--without-mssql" "--without-pdo-mssql" "--without-pi3web" "--with-pdo-oci=C:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8=C:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8-11g=C:\php-sdk\oracle\instantclient11\sdk,shared" "--enable-object-out-dir=../obj/" "--enable-com-dotnet=shared" "--with-mcrypt=static" "--disable-static-analyze" "--with-pgo"
Server API => Command Line Interface
Virtual Directory Support => enabled
Configuration File (php.ini) Path => C:\WINDOWS
Loaded Configuration File => C:\xampp\php\php.ini
Scan this dir for additional .ini files => (none)
Additional .ini files parsed => (none)
PHP API => 20100412
PHP Extension => 20100525
Zend Extension => 220100525
Zend Extension Build => API220100525,TS,VC9
PHP Extension Build => API20100525,TS,VC9
Debug Build => no
Thread Safety => enabled
Zend Signal Handling => disabled
Zend Memory Manager => enabled
Zend Multibyte Support => provided by mbstring
IPv6 Support => enabled
DTrace Support => disabled

Registered PHP Streams => php, file, glob, data, http, ftp, zip, compress.zlib, compress.bzip2, phar
Registered Stream Socket Transports => tcp, udp
Registered Stream Filters => convert.iconv.*, mcrypt.*, mdecrypt.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, zlib.*, bzip2.*

This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies

2. test_php.bat produces success message on proper runtime installed, then croaks on the php execution. Windows Control Panel shows both "Microsoft Visual C++ Redistributable - x86 9.0.30729.17" and "Microsoft Visual C++ Redistributable - x86 9.0.30729.6161" installed. Think the second one is the security update that came from Microsoft yesterday.
3. PHP never returns from execution, so no error messages.
4. g:\xampp\php\php.exe - i executes and never returns, no messages, total freeze. Back at you with rest few minutes have to hard boot from that one.
mbuckler01
 
Posts: 8
Joined: 29. April 2013 22:21
Operating System: Windows XP

Re: XAMPP Portable Lite 1.8.1

Postby mbuckler01 » 02. May 2013 16:31

Thank you very much for your time and help. And by the way, great new XAMPP Control Panel. I am ok for my classes because the version on stick runs on my lab computers and my students' will run as well. Just have to copy my prep work, done in my full install, to the htdocs on the stick. But I really want to know why my computer won't run that version of php because it is obviously symptomatic of something which really bothers me.

Also, every time PHP crashes like that, when I reboot it shows that my McAfee AntiVirus Plus real-time virus scanning has been turned off. I have multiply scanned the computer with that, Advanced SystemCare Pro and Malwareytes and found nothing.

5. Php\logs\ has log with one entry:
[01-May-2013 19:45:02 UTC] PHP Warning: file_get_contents(lang.tmp): failed to open stream: No such file or directory in F:\xampp\htdocs\xampp\index.php on line 2
Think this is from call to browser sent to localhost after I started Apache after one of the php crashes. That would have tried to run PHP on the default page in htdocs, but it certainly is going to a wrong drive letter. Maybe because setup_xampp.bat never completes to set the relative path. Still, any call to stick based php crashes the system
6. Apache error.log:
Wed May 01 12:43:52.406979 2013] [ssl:warn] [pid 2672:tid 244] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed May 01 12:43:54.955234 2013] [mpm_winnt:notice] [pid 2672:tid 244] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Wed May 01 12:43:54.956234 2013] [mpm_winnt:notice] [pid 2672:tid 244] AH00456: Server built: Aug 18 2012 12:41:37
[Wed May 01 12:43:54.956234 2013] [core:notice] [pid 2672:tid 244] AH00094: Command line: 'f:\\xampp\\apache\\bin\\httpd.exe -d F:/xampp/apache'
[Wed May 01 12:43:54.993238 2013] [mpm_winnt:notice] [pid 2672:tid 244] AH00418: Parent: Created child process 2536
[Wed May 01 12:44:03.485087 2013] [ssl:warn] [pid 2536:tid 256] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed May 01 12:44:03.991137 2013] [mpm_winnt:notice] [pid 2536:tid 256] AH00354: Child: Starting 150 worker threads.
[Wed May 01 13:25:47.678481 2013] [core:warn] [pid 4952:tid 244] AH00098: pid file F:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed May 01 13:25:48.619575 2013] [ssl:warn] [pid 4952:tid 244] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed May 01 13:25:49.214635 2013] [mpm_winnt:notice] [pid 4952:tid 244] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Wed May 01 13:25:49.214635 2013] [mpm_winnt:notice] [pid 4952:tid 244] AH00456: Server built: Aug 18 2012 12:41:37
[Wed May 01 13:25:49.214635 2013] [core:notice] [pid 4952:tid 244] AH00094: Command line: 'f:\\xampp\\apache\\bin\\httpd.exe -d F:/xampp/apache'
[Wed May 01 13:25:49.233637 2013] [mpm_winnt:notice] [pid 4952:tid 244] AH00418: Parent: Created child process 4632
[Wed May 01 13:29:26.505362 2013] [core:warn] [pid 4520:tid 244] AH00098: pid file F:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed May 01 13:29:27.895501 2013] [ssl:warn] [pid 4520:tid 244] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed May 01 13:29:29.710682 2013] [mpm_winnt:notice] [pid 4520:tid 244] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Wed May 01 13:29:29.711682 2013] [mpm_winnt:notice] [pid 4520:tid 244] AH00456: Server built: Aug 18 2012 12:41:37
[Wed May 01 13:29:29.711682 2013] [core:notice] [pid 4520:tid 244] AH00094: Command line: 'f:\\xampp\\apache\\bin\\httpd.exe -d F:/xampp/apache'
[Wed May 01 13:29:29.732684 2013] [mpm_winnt:notice] [pid 4520:tid 244] AH00418: Parent: Created child process 1492
[Wed May 01 13:29:38.091520 2013] [ssl:warn] [pid 1492:tid 256] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed May 01 13:29:39.783689 2013] [mpm_winnt:notice] [pid 1492:tid 256] AH00354: Child: Starting 150 worker threads.
mbuckler01
 
Posts: 8
Joined: 29. April 2013 22:21
Operating System: Windows XP


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 102 guests