XAMPP 1.8.1 - Apache didn't started.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP 1.8.1 - Apache didn't started.

Postby xeNium » 24. April 2013 14:07

Apache didn't started.
In a panic mind, I can't think anything so I re-install XAMPP 1.8.1 in C:/xampp
Nothing happened, Apache didn't started, Using XAMPP Control Panel? XAMPP Control Panel crashes everytime I am trying to start Apache.

So, I am uninstall the XAMPP 1.8.1 without backuping first so I lose MySQL Database! Because I think XAMPP will ask, Remove the MySQL Database? Unfrontnanently, XAMPP do not ask it, hiks! They keep removing and asking, Remove the htdocs folder? What the?!
Then, I am reinstalling XAMPP.

Thank God, Apache now can starting but with a error, I can't open localhost/xampp It says.

Code: Select all
Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.
Error 500
IP Address <= Modified, for safety reason.
Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7


error.log
Code: Select all
20:00 <User> [Wed Apr 24 19:49:17.212189 2013] [ssl:warn] [pid 3680:tid 372] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Apr 24 19:49:17.414201 2013] [mpm_winnt:notice] [pid 3680:tid 372] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Wed Apr 24 19:49:17.414201 2013] [mpm_winnt:notice] [pid 3680:tid 372] AH00456: Server built: Aug 18 2012 12:41:37
[Wed Apr 24 19:49:17.414201 2013] [core:notice] [pid 3680:tid 372] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Apr 24 19:49:17.417201 2013] [mpm_winnt:notice] [pid 3680:tid 372] AH00418: Parent: Created child process 1392
[Wed Apr 24 19:49:20.126356 2013] [ssl:warn] [pid 1392:tid 272] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Apr 24 19:49:20.241362 2013] [mpm_winnt:notice] [pid 1392:tid 272] AH00354: Child: Starting 150 worker threads.
[Wed Apr 24 19:51:51.090991 2013] [core:alert] [pid 1392:tid 1764] [client 114.79.13.78:37227] C:/xampp/htdocs/xampp/.htaccess: Invalid file path C:C:\\xampp\\security\\xampp.users
[Wed Apr 24 19:51:59.127450 2013] [core:alert] [pid 1392:tid 1772] [client 114.79.13.78:37570] C:/xampp/htdocs/xampp/.htaccess: Invalid file path C:C:\\xampp\\security\\xampp.users
[Wed Apr 24 19:52:04.706769 2013] [core:alert] [pid 1392:tid 1660] [client 114.79.13.78:37799] C:/xampp/htdocs/xampp/.htaccess: Invalid file path C:C:\\xampp\\security\\xampp.users
[Wed Apr 24 19:52:11.587163 2013] [access_compat:error] [pid 1392:tid 1768] [client 114.79.13.78:38076] AH01797: client denied by server configuration: C:/xampp/phpmyadmin/
[Wed Apr 24 19:52:47.120195 2013] [core:alert] [pid 1392:tid 1772] [client 114.79.13.78:39225] C:/xampp/htdocs/xampp/.htaccess: Invalid file path C:C:\\xampp\\security\\xampp.users
[Wed Apr 24 19:53:21.426157 2013] [core:alert] [pid 1392:tid 1772] [client 114.79.13.78:40872] C:/xampp/htdocs/xampp/.htaccess: Invalid file path C:C:\\xampp\\security\\xampp.users
[Wed Apr 24 19:53:25.183372 2013] [core:alert] [pid 1392:tid 1752] [client 114.79.13.78:40892] C:/xampp/htdocs/xampp/.htaccess: Invalid file path C:C:\\xampp\\security\\xampp.users
[Wed Apr 24 19:53:33.766863 2013] [core:alert] [pid 1392:tid 1776] [client 127.0.0.1:49295] C:/xampp/htdocs/xampp/.htaccess: Invalid file path C:C:\\xampp\\security\\xampp.users
[Wed Apr 24 19:53:44.413472 2013] [mpm_winnt:notice] [pid 3680:tid 372] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Wed Apr 24 19:54:14.414188 2013] [mpm_winnt:notice] [pid 3680:tid 372] AH00431: Parent: Forcing termination of child process 234
[Wed Apr 24 19:55:21.720038 2013] [ssl:warn] [pid 1980:tid 372] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Apr 24 19:55:21.820044 2013] [mpm_winnt:notice] [pid 1980:tid 372] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Wed Apr 24 19:55:21.820044 2013] [mpm_winnt:notice] [pid 1980:tid 372] AH00456: Server built: Aug 18 2012 12:41:37
[Wed Apr 24 19:55:21.820044 2013] [core:notice] [pid 1980:tid 372] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Apr 24 19:55:21.822044 2013] [mpm_winnt:notice] [pid 1980:tid 372] AH00418: Parent: Created child process 2184
[Wed Apr 24 19:55:24.544199 2013] [ssl:warn] [pid 2184:tid 272] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Apr 24 19:55:24.589202 2013] [mpm_winnt:notice] [pid 2184:tid 272] AH00354: Child: Starting 150 worker threads.
[Wed Apr 24 19:56:23.218555 2013] [core:alert] [pid 2184:tid 1708] [client ::1:49318] C:/xampp/htdocs/xampp/.htaccess: Invalid file path C:C:\\xampp\\security\\xampp.users


I am so sad, my project was gone forever, hiks!
At least, I hope I can start a new project so please help me.

I am using xampp-control from http://community.apachefriends.org/f/viewtopic.php?f=16&t=48932 (The problem occured before I am using that, I am just using that xampp-control panel because it's more stable for me 'It do not 'Not responding' when I am trying to start Apache anymore', I have test it, same results)
xeNium
 
Posts: 7
Joined: 13. August 2012 15:46
XAMPP Version: 1.8.2-3
Operating System: Windows Server 2008 R2 Enterpr

Re: XAMPP 1.8.1 - Apache didn't started.

Postby xeNium » 25. April 2013 13:06

What happen, do you know? Please.
xeNium
 
Posts: 7
Joined: 13. August 2012 15:46
XAMPP Version: 1.8.2-3
Operating System: Windows Server 2008 R2 Enterpr

Re: XAMPP 1.8.1 - Apache didn't started.

Postby hackattack142 » 26. April 2013 00:33

Hello,

I suspect you can open the problem file (C:/xampp/htdocs/xampp/.htaccess) and fix the patch from (C:C:\\xampp\\security\\xampp.users) to (C:\\xampp\\security\\xampp.users) assuming that is your only issue.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 37 guests