ISSUE STARTING MYSQL XAMPP 1.8.1

Problems with the Windows version of XAMPP, questions, comments, and anything related.

ISSUE STARTING MYSQL XAMPP 1.8.1

Postby sakamboh » 11. April 2013 10:20

Dear All,

My xampp installation was working, i need to install an application that uses innodb, for that i tried configuring innodb on xampp in 'C:\xampp\mysql\bin\my.ini' file. Previously the configuration was as below.

Code: Select all
# Comment the following if you are using InnoDB tables
#skip-innodb
innodb_data_home_dir = "C:/xampp/mysql/data"
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = "C:/xampp/mysql/data"
#innodb_log_arch_dir = "C:/xampp/mysql/data"
## You can set .._buffer_pool_size up to 50 - 80 %
## of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 16M
innodb_additional_mem_pool_size = 2M
## Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50


I have change it to as below.

Code: Select all
# Comment the following if you are using InnoDB tables
skip-innodb
innodb_data_home_dir = "C:/xampp/mysql/data"
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = "C:/xampp/mysql/data"
#innodb_log_arch_dir = "C:/xampp/mysql/data"
## You can set .._buffer_pool_size up to 50 - 80 %
## of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 16M
innodb_additional_mem_pool_size = 2M
## Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50



Now when i am trying to start mysql it gives me below erros.

Code: Select all
130411  1:19:40 [Note] Plugin 'FEDERATED' is disabled.
130411  1:19:40 [Note] Plugin 'InnoDB' is disabled.
130411  1:19:40 [ERROR] Unknown/unsupported storage engine: InnoDB
130411  1:19:40 [ERROR] Aborting

130411  1:19:40 [Note] c:\xampp\mysql\bin\mysqld.exe: Shutdown complete


Please help me out in resolving this issue.
sakamboh
 
Posts: 1
Joined: 11. April 2013 10:12
XAMPP Version: 5.6.3
Operating System: WINDOWS 7 32bit

Re: ISSUE STARTING MYSQL XAMPP 1.8.1

Postby Altrea » 11. April 2013 13:07

Hi sakamboh,

sakamboh wrote:i need to install an application that uses innodb
...
I have change it to as below.

Code: Select all
skip-innodb

Why do you disable InnoDB if you want to use it?

Best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6828
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: JJ_Tagy and 66 guests