Curl not working on Xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Curl not working on Xampp

Postby noeldesigns » 29. March 2013 23:58

I am having problems getting curl to work on xampp. I am running Windows7, Xampp 1.7.7. It has been working well except now I need curl to work. I went into the php.ini-development and php.ini-production files and uncommented the extension for curl.

restarted xampp and checked and the curl module is not showing up under phpinfo()

Been working on this for two days so I really need help on figuring out how to enable/start curl.

Help please.

Thanks

noel
noeldesigns
 
Posts: 2
Joined: 29. March 2013 23:50
XAMPP Version: 5.6.3
Operating System: windows 7

Re: Curl not working on Xampp

Postby Altrea » 30. March 2013 01:03

Hi noel,

Please start new threads with the words "Hi" or "Hello". A short salutation is an act of politeness. Even if the internet is an virtual area, there is always a human being behind the screen. A polite beginning is the first positive impression you can leave here and helps to get polite answers too. Please keep that in mind if you start a new thread in any community board. Thank you.

noeldesigns wrote:I went into the php.ini-development and php.ini-production files and uncommented the extension for curl.

These two files are just templates for example php.ini configurations. Changes there don't take any effect.
You need to uncomment curl in your \xampp\php\php.ini file.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6491
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Curl not working on Xampp

Postby noeldesigns » 30. March 2013 01:47

Thank you Altrea, and Hi. Thanks for the reply. I uninstalled Xampp and re-installed it and there is no php.ini file. There are only the two files mentioned. This was a clean install so not sure why the file would not be there.

Also, when I run the phpinfo(), the heading section for curl does not show up at all. Is this because of the missing php.ini file.

Where can I get this file since it is not being loaded on a new xampp install.

Thanks,

Grant
noeldesigns
 
Posts: 2
Joined: 29. March 2013 23:50
XAMPP Version: 5.6.3
Operating System: windows 7

Re: Curl not working on Xampp

Postby Altrea » 30. March 2013 01:54

Have you hidden known file extensions in your Windows Explorer?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6491
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests