PRoblem starting Tomcat

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PRoblem starting Tomcat

Postby Francis2B » 02. March 2013 13:51

Hello everyone,
just set up locally XAMPP 1.8.1 and got a small problem trying to run Tomcat through the control panel: The directory xampp\tmp\tomcat was not found by the program.
When checking my directories it appears their was a path problem, the tomcat folder was under the root /xampp, so I put it under the right path and it seems working..
Don't know if you guys get the same problem?
Thanks
Francis
Francis2B
 
Posts: 1
Joined: 02. March 2013 13:40
XAMPP Version: 5.6.3
Operating System: Windows

Re: PRoblem starting Tomcat

Postby cosimonudo » 04. March 2013 07:48

same here!
cosimonudo
 
Posts: 4
Joined: 04. March 2013 07:45
XAMPP Version: 5.6.3
Operating System: winxp

Re: PRoblem starting Tomcat

Postby cosimonudo » 04. March 2013 13:47

into details
When I start xampp I get this window
Image

then start Tomcat, while xampp gives this window

Image

comand prompt gives this error

Image

then when you press any botton xampp gives

Image

so JDK and JRE are fully installed and logs folder in tomcat is empty.
What looks strange is, as Francis2B said, that there is a wrong path in comand prompt, there is no tomcat folder in tmp folder.
So I've copied the tomcat folder in tmp and this is the first window in xampp

Image

windows firewall pop up to unlock the port, done. Then xampp gives see something new. It says that Tomcat can't start cause the port 8080 is in use but if you start Tomcat xampp returns the green underground and the numeber of ports logged, looks it's running

Image

unfortunately comand prompt is still open with new lines

Image

and when you close it, xampp returns this

Image

Tried to change the tomcat port from xampp config: what i had is that i don't have the opening error in xampp but still it doesn't work. Comand prompt doesn't auto-close and when i did it gives me the same error.
Hope I've made myself clear
cosimonudo
 
Posts: 4
Joined: 04. March 2013 07:45
XAMPP Version: 5.6.3
Operating System: winxp

Re: PRoblem starting Tomcat

Postby hackattack142 » 04. March 2013 14:32

Hello,

It might be a bad path in your XAMPP Control Panel shortcut.

Right click your shortcut, go to Properties, go to the 'Shortcut' tab, look at the 'Start In' path. If there is a '\tmp' at the end of the path, remove it.

If that doesn't work, here is a thread with more troubleshooting tips and workarounds: viewtopic.php?f=16&t=51780
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: PRoblem starting Tomcat

Postby cosimonudo » 05. March 2013 11:41

thanks for your reply,
changed the 'start in' path but as result i've the same error i had when i copied the tomcat folder into tmp.
Uninstalled and installed again xampp, first start all fine, could log tomcat and get ports when logged in, but comand prompt didn't auto close.
Code: Select all
"TASKLIST" non è riconosciuto come comando interno o esterno,
 un programma eseguibile o un file batch.

[XAMPP]: Searching for JDK or JRE HOME with reg query ...

! REG.EXE VERSION 3.0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit
    CurrentVersion      REG_SZ  1.7

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit\1.7
    JavaHome    REG_SZ  C:\Programmi\Java\jdk1.7.0_15
    MicroVersion        REG_SZ  0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit\1.7.0_15
    JavaHome    REG_SZ  C:\Programmi\Java\jdk1.7.0_15
    MicroVersion        REG_SZ  0

[XAMPP]: Using JDK

[XAMPP]: Seems fine!
[XAMPP]: Set JAVA_HOME : C:\Programmi\Java\jdk1.7.0_15
[XAMPP]: Set CATALINA_HOME : c:\xampp\tomcat

Using CATALINA_BASE:   "c:\xampp\tomcat"
Using CATALINA_HOME:   "c:\xampp\tomcat"
Using CATALINA_TMPDIR: "c:\xampp\tomcat\temp"
Using JRE_HOME:        "C:\Programmi\Java\jdk1.7.0_15"
Using CLASSPATH:       "c:\xampp\tomcat\bin\bootstrap.jar;c:\xampp\tomcat\bin\to
mcat-juli.jar"
mar 05, 2013 6:07:38 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performanc
e in production environments was not found on the java.library.path: C:\Programm
i\Java\jdk1.7.0_15\bin;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:
\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Programmi\File comuni\U
lead Systems\MPEG;.
mar 05, 2013 6:07:40 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-8080"]
mar 05, 2013 6:07:40 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["ajp-bio-8009"]
mar 05, 2013 6:07:40 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 2490 ms
mar 05, 2013 6:07:40 AM org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
mar 05, 2013 6:07:40 AM org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.30
mar 05, 2013 6:07:40 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\docs
mar 05, 2013 6:07:41 AM org.apache.catalina.util.SessionIdGenerator createSecure
Random
INFO: Creation of SecureRandom instance for session ID generation using [SHA1PRN
G] took [250] milliseconds.
mar 05, 2013 6:07:41 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\examples
mar 05, 2013 6:07:42 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\host-manager
mar 05, 2013 6:07:42 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\manager
mar 05, 2013 6:07:42 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\ROOT
mar 05, 2013 6:07:42 AM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8080"]
mar 05, 2013 6:07:43 AM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["ajp-bio-8009"]
mar 05, 2013 6:07:43 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 2857 ms


is that normal? did you always have comand prompt open while working?
Image
I've closed and it get me error while shutdown unexpectedly like in the last post.
So i've closed xampp and started again, it tolds me some conflict with tomcat port as shown before and from comand prompt i could see that destination is back to tmp folder.
Changed again to c:xampp but here i am back at the begining of this loop
cosimonudo
 
Posts: 4
Joined: 04. March 2013 07:45
XAMPP Version: 5.6.3
Operating System: winxp

Re: PRoblem starting Tomcat

Postby hackattack142 » 05. March 2013 14:47

Hello,

The command window staying open is normal, that is how the console (non-service) version of Tomcat works.

If you get it working correctly (green status on the control panel like your screenshot), you can configure the control panel to hide that window (go to the upper-right 'Config' and uncheck 'Tomcat output window visible')
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: PRoblem starting Tomcat

Postby cosimonudo » 05. March 2013 21:37

Thank you so much hackattack142,
done! if it's normal I consider this issue solved.
cosimonudo
 
Posts: 4
Joined: 04. March 2013 07:45
XAMPP Version: 5.6.3
Operating System: winxp


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests