Page 1 of 1

lost database [Solved]

PostPosted: 27. February 2013 09:19
by pitbull10

I am at uni and have created 12 databases in phpmyadmin
everything was fine until last night all of a sudden I cannot get into my database.
when I open phpmyadmin a signin box comes up , I type root and no password I get into control panel but there is only
information scheme and Test my database s are missing .
my tables are in the recent tables but cannot open them.
Can some please help this is very important to me, I need access to them asap
I have tried restore, reinstall of xampp over the top, when I did it says UAC is deactivated ??????


Re: lost database

PostPosted: 27. February 2013 14:50
by JonB
I guess it goes without saying you don't do backups, right?

I have to ask - What possessed you to re-install XAMPP before asking for help? (you may have erased them, depending on how you re-installed)

And what do you mean 'restore' - Windows System Restore?

For now, go to the mysql\data folder under XAMPP and get a directory listing. There should be folders with the same names as your user-created databases - check and see if there are files in each folder.

Let us know what happens


Re: lost database

PostPosted: 27. February 2013 18:57
by pitbull10
Hello JonB

Yes I backed up the database. they would not import/export or do anything. xampp was locked to any user.
Yes I tired windows system restore. restored back 6 hours as I make sure a restore is created ever 6 hours.
I didn't erase them the were still in the MySQL data file. So copied them, uninstalled the lot and re-installed pasted database back into MySQL data file, it works perfectly.
my forms all write to each table.

This may help anyone else who is faced with being locked out of phpmyadmin with no warning / or reason why.