phpMyAdmin Access Denied [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpMyAdmin Access Denied [Solved]

Postby phppenguin » 14. February 2013 18:13

Hi I installed XAMPP v1.8.1 on Windows 7 Professional 32-bit. When I clicked on phpMyAdmin on Tools on localhost/xampp/splash.php screen I receive a Access Denied warning or alert. See image attachment. How do I fix this issue to set up a database for an open-source ecommerce application I wish to install and new user for phpMyAdmin since I have not set a password for root user. Thanks.

11:13:40 AM [main] Windows Version: Windows 7 Professional 32-bit
11:13:40 AM [main] XAMPP Version: 1.8.1
11:13:40 AM [main] Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
11:13:40 AM [main] Running with Administrator rights - good!
11:13:40 AM [main] XAMPP Installation Directory: "c:\xampp\"
11:13:40 AM [main] Checking for prerequisites
11:13:40 AM [main] All prerequisites found
11:13:40 AM [main] Initializing Modules
11:13:40 AM [Apache] XAMPP Apache is already running on port 80
11:13:40 AM [Apache] XAMPP Apache is already running on port 443
11:13:40 AM [main] Starting Check-Timer
11:13:40 AM [main] Control Panel Ready
11:43:38 AM [mysql] Attempting to start MySQL app...
11:43:39 AM [mysql] Status change detected: running


Image
phppenguin
 
Posts: 11
Joined: 21. January 2013 03:17
Operating System: Windows 7 Pro 32-bit PC

Re: phpMyAdmin Access Denied

Postby Altrea » 14. February 2013 18:28

Hi phppenguin,

There are dozen of threads here about the #2002 mysql error.

Two things that are helping to get rid of it are the following:

  • add in your C:\Windows\system32\drivers\etc\HOSTS the line
    Code: Select all
    127.0.0.1   localhost

  • enable by removing the leading #-sign the following line in your \xampp\mysql\bin\my.ini
    Code: Select all
    # bind-address="127.0.0.1"
    and restart your MySQL

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: phpMyAdmin Access Denied

Postby phppenguin » 14. February 2013 18:39

Which program do I choose to open the C:\Windows\System32\drivers\etc\hosts file? A window pops open giving me choices of programs to chose to open the hosts file but I don't specifically know which one I'm suppose to select. I'm a complete newbie XAMPP and cmd prompts. :oops:
phppenguin
 
Posts: 11
Joined: 21. January 2013 03:17
Operating System: Windows 7 Pro 32-bit PC

Re: phpMyAdmin Access Denied

Postby Altrea » 14. February 2013 18:54

phppenguin wrote:Which program do I choose to open the C:\Windows\System32\drivers\etc\hosts file?

I am using one of my favorite code editors Notepad++, but you can use the plaintext editor of your choice (for example Windows Notepad, but NOT Microsoft Word).
But the HOSTS file is protected by the User Account Control (UAC). So you need to start your editor with enhanced Administrator permissions (rightclick -> run as Administrator) to be able to save the file after changing.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: phpMyAdmin Access Denied

Postby phppenguin » 14. February 2013 18:55

Altrea wrote:Hi phppenguin,

There are dozen of threads here about the #2002 mysql error.

Two things that are helping to get rid of it are the following:

  • add in your C:\Windows\system32\drivers\etc\HOSTS the line
    Code: Select all
    127.0.0.1   localhost

  • enable by removing the leading #-sign the following line in your \xampp\mysql\bin\my.ini
    Code: Select all
    # bind-address="127.0.0.1"
    and restart your MySQL

best wishes,
Altrea


Ok I deleted the #-sign in \xampp\mysql\bin\my.ini using Notepad, clicked Save and refreshed the Firefox browser and am now able to access phpMyAdmin page. :D

Update when I checked hosts file the 127.0.0.1 localhost was already there appear after CS5 activator or something another worded to that effect.
phppenguin
 
Posts: 11
Joined: 21. January 2013 03:17
Operating System: Windows 7 Pro 32-bit PC


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests