Apache will not react to starting button

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache will not react to starting button

Postby Tsen » 25. January 2013 00:31

Hello,

I'm new here and in the world of XAMPP and Apache (steppingstone to PHP). I'm a student informatics so I do have some knowledge of my computer and cmd ect.

We will be working with XAMPP for our PHP lessons. We got the task to download XAMPP and to activate MySQL and Apache.
Now, MySQL works perfectly (i can see it running in my process and get a PID for it) but Apache will not.

I tried a lot of troubleshooting like shutting every other program using port 80, i also changed the listen to several other ports (as 1234, 79, 81, ect.) but none gave me a good reaction (the starting reaction).

I also shutdown my Firewall and restarted my computer several time.
I do have to let you know that the version I use is the "ApacheFriends XAMPP Version 1.8.1".

If you have any idea how to resolver this problem it would be more than grateful!

(I do apologize for my English, I speak French and Dutch and English is only for movies)
XAMPP Version 1.8.1 from school.
User avatar
Tsen
 
Posts: 3
Joined: 25. January 2013 00:15
Location: Belgium - Gent
Operating System: Win7

Re: Apache will not react to starting button

Postby Altrea » 25. January 2013 05:40

Hi Tsen and welcome to our forum :D ,

Tsen wrote:I tried a lot of troubleshooting like shutting every other program using port 80, i also changed the listen to several other ports (as 1234, 79, 81, ect.) but none gave me a good reaction (the starting reaction).

If not already done please redo your changes to the default setting so that we have an environment which is knowable enough for us remote helpers.

After that please try to start Apache in the xampp control panel again and please post us the following information:
  • full contents of the XAMPP control status window
  • contents of your \xampp\apache\logs\error.log

Try also to start Apache with the \xampp\apache_start.bat script and post the response of the command line too

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8297
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache will not react to starting button

Postby Tsen » 25. January 2013 14:11

Code: Select all
14:04:50  [main]    Initializing Control Panel
14:04:50  [main]    Windows Version: Windows 7 Home Premium SP1 64-bit
14:04:50  [main]    XAMPP Version: 1.8.1
14:04:50  [main]    Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
14:04:50  [main]    You are not running with administrator rights! This will work for
14:04:50  [main]    most application stuff but whenever you do something with services
14:04:50  [main]    there will be a security dialogue or things will break! So think
14:04:50  [main]    about running this application with administrator rights!
14:04:50  [main]    XAMPP Installation Directory: "c:\users\**\artevelde\2012-13\vakken\semester 2\pj in\xampp\"
14:04:50  [main]    WARNING: Your install directory contains spaces.  This may break programs/scripts
14:04:50  [main]    Checking for prerequisites
14:04:51  [main]    All prerequisites found
14:04:51  [main]    Initializing Modules
14:04:51  [main]    Starting Check-Timer
14:04:51  [main]    Control Panel Ready
14:05:23  [Apache]    Attempting to start Apache app...


This is the code I get when started and trying to start Apache...
I also went to the log files of Apache but found no file there with the name you gave me or other file. (the map is empty)
The default setting are back on (port 80 in the file i changed).

I use the Apache_start.bat file and the picture bellow is the code i got (with again no reaction from Apache...).

Image

After the bat-file I did have a reaction from Apache:

Code: Select all
14:04:50  [main]    Initializing Control Panel
14:04:50  [main]    Windows Version: Windows 7 Home Premium SP1 64-bit
14:04:50  [main]    XAMPP Version: 1.8.1
14:04:50  [main]    Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
14:04:50  [main]    You are not running with administrator rights! This will work for
14:04:50  [main]    most application stuff but whenever you do something with services
14:04:50  [main]    there will be a security dialogue or things will break! So think
14:04:50  [main]    about running this application with administrator rights!
14:04:50  [main]    XAMPP Installation Directory: "c:\users\**\artevelde\2012-13\vakken\semester 2\pj in\xampp\"
14:04:50  [main]    WARNING: Your install directory contains spaces.  This may break programs/scripts
14:04:50  [main]    Checking for prerequisites
14:04:51  [main]    All prerequisites found
14:04:51  [main]    Initializing Modules
14:04:51  [main]    Starting Check-Timer
14:04:51  [main]    Control Panel Ready
14:05:23  [Apache]    Attempting to start Apache app...
14:08:33  [Apache]    Status change detected: running
14:08:34  [Apache]    Status change detected: stopped
14:08:34  [Apache]    Error: Apache shutdown unexpectedly.
14:08:34  [Apache]    This may be due to a blocked port, missing dependencies,
14:08:34  [Apache]    improper privileges, a crash, or a shutdown by another method.
14:08:34  [Apache]    Check the "/xampp/apache/logs/error.log" file
14:08:34  [Apache]    and the Windows Event Viewer for more clues
Last edited by Tsen on 19. February 2013 18:09, edited 2 times in total.
XAMPP Version 1.8.1 from school.
User avatar
Tsen
 
Posts: 3
Joined: 25. January 2013 00:15
Location: Belgium - Gent
Operating System: Win7

Re: Apache will not react to starting button

Postby Altrea » 25. January 2013 17:12

Code: Select all
14:04:50  [main]    XAMPP Installation Directory: "c:\users\jérémie degrave\artevelde\2012-13\vakken\semester 2\pj in\xampp\"

Don't use whitespaces, accented letters, umlauts and other special chars in your installation path. It is highly recommend to install XAMPP directly to C:\xampp\
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8297
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache will not react to starting button

Postby Tsen » 25. January 2013 18:39

Ok, indeed, I reinstalled the whole thing and now they both work great!

Thank you very much!
XAMPP Version 1.8.1 from school.
User avatar
Tsen
 
Posts: 3
Joined: 25. January 2013 00:15
Location: Belgium - Gent
Operating System: Win7

Re: Apache will not react to starting button

Postby Altrea » 25. January 2013 19:07

You are welcome.

Have fun with XAMPP and all that stuff 8)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8297
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests