XAMPP status deactivated - works only on https !!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP status deactivated - works only on https !!

Postby stevaaa » 09. January 2013 16:57

I've installed xampp 1.7.7 version in my windows 7 32 bit PC. XAMPP Control panel version:2.5.
When I start Apache and mysql, it works like charm without any errors.

1. When I try to acces http:\\localhost I get an error "The webpage cannot be found"
2. But when I tried https:\\localhost, It worked :(
3. In the xampp status except "HTTPS (SSL)" all other components are deactivated.

I want to access the localhost using the url http://localhost, How can I make the component activated? Is there any windows settings need to be modified ??

Please help me solve this problem.
stevaaa
 
Posts: 4
Joined: 09. January 2013 16:30
XAMPP Version: 1.8.3
Operating System: Windows 7

Re: XAMPP status deactivated - works only on https !!

Postby hackattack142 » 10. January 2013 03:50

Hello,

Could you grab the latest control panel from the link in my signature.

Next, you need to make a small config change after starting it. Go to the Config, go to Service and Port Settings, and change the service name for Apache from "Apache2.4" to "Apache2.2", Save

Next, restart the control, right-click in the log window, select all, copy and post it here.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: XAMPP status deactivated - works only on https !!

Postby stevaaa » 10. January 2013 10:29

The log you asked for :

3:00:25 PM [main] Initializing Control Panel
3:00:25 PM [main] Windows Version: Windows 7 Enterprise 32-bit
3:00:25 PM [main] XAMPP Version: 1.7.7
3:00:25 PM [main] Control Panel Version: 3.1.0 Beta 7 [ Compiled: October 5th 2012 ]
3:00:25 PM [main] Running with Administrator rights - good!
3:00:25 PM [main] XAMPP Installation Directory: "d:\xampp\"
3:00:25 PM [main] Checking for prerequisites
3:00:25 PM [main] All prerequisites found
3:00:25 PM [main] Initializing Modules
3:00:25 PM [Apache] Problem detected!
[color=#FF0000]3:00:25 PM [Apache] Port 80 in use by "system"!

3:00:25 PM [Apache] Apache WILL NOT start without the configured ports free!
3:00:25 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
3:00:25 PM [Apache] or reconfigure Apache to listen on a different port
3:00:25 PM [main] Starting Check-Timer
3:00:25 PM [main] Control Panel Ready[/color]

Actually I changed the httpd.conf file Listen address as 8181 previously and thought it would run in the port I have assigned.... But after I changed the port setting in the dialog it worked in 8181 port....

FYI Success Log:
3:05:08 PM [main] Initializing Control Panel
3:05:08 PM [main] Windows Version: Windows 7 Enterprise 32-bit
3:05:08 PM [main] XAMPP Version: 1.7.7
3:05:08 PM [main] Control Panel Version: 3.1.0 Beta 7 [ Compiled: October 5th 2012 ]
3:05:08 PM [main] Running with Administrator rights - good!
3:05:08 PM [main] XAMPP Installation Directory: "d:\xampp\"
3:05:08 PM [main] Checking for prerequisites
3:05:08 PM [main] All prerequisites found
3:05:08 PM [main] Initializing Modules
3:05:08 PM [main] Starting Check-Timer
3:05:08 PM [main] Control Panel Ready

Thank you so much hackattack142 :lol: It worked now... all are in activated mode...... :) thanks again :D
stevaaa
 
Posts: 4
Joined: 09. January 2013 16:30
XAMPP Version: 1.8.3
Operating System: Windows 7

Re: XAMPP status deactivated - works only on https !!

Postby stevaaa » 10. January 2013 14:32

Hi hackattack142, One more problem :(

Now I can access localhost webpage with the URL like http://localhost:8181/xampp/ http://localhost:8181/testphp/

How can I change the URL access to http://localhost/ only? [without port number]

If I want to access from a differnt PC in LAN network, it's not working [] :(
I gave the address [http://[computername]/[foldername]]

Please help.. thanks
stevaaa
 
Posts: 4
Joined: 09. January 2013 16:30
XAMPP Version: 1.8.3
Operating System: Windows 7

Re: XAMPP status deactivated - works only on https !!

Postby WilliL » 10. January 2013 14:43

stevaaa wrote:How can I change the URL access to http://localhost/ only? [without port number]

Hi,
http://localhost/ means http://localhost:80/

if you want to use http://localhost/ you must kill the process which uses Port 80
Willi
WilliL
 
Posts: 622
Joined: 08. January 2010 10:54
XAMPP Version: 5.5.19
Operating System: Win7Home Prem 64 SP1

Re: XAMPP status deactivated - works only on https !!

Postby hackattack142 » 10. January 2013 23:41

Hello,

As WilliL stated, you will need to find what is blocking that port if you want to use it without specifying a port. Web browsers default to port 80 when no port is specified.

When it says 'System' is using that port, that typically means that a Windows Service is blocking the port. One common one on Windows 7 is the World Wide Publishing service. This is a component of IIS and you can disable it if it is blocking.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: XAMPP status deactivated - works only on https !!

Postby stevaaa » 07. August 2013 08:19

Somehow, I've blocked the port 80 service and now it is working properly.
stevaaa
 
Posts: 4
Joined: 09. January 2013 16:30
XAMPP Version: 1.8.3
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 80 guests