UPDATE: apache/sql errors on Windows 7 x64

Problems with the Windows version of XAMPP, questions, comments, and anything related.

UPDATE: apache/sql errors on Windows 7 x64

Postby cateleb » 07. January 2013 04:07

UPDATE. I have reinstalled Apache 1.8.1 using the "installer". The following errors have occurred. Can you help with this:

9:36:38 AM [main] Initializing Control Panel
9:36:38 AM [main] Windows Version: Windows 7 Professional SP1 64-bit
9:36:38 AM [main] XAMPP Version: 1.8.1
9:36:38 AM [main] Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
9:36:38 AM [main] Running with Administrator rights - good!
9:36:38 AM [main] XAMPP Installation Directory: "c:\xampp\"
9:36:38 AM [main] Checking for prerequisites
9:36:39 AM [main] All prerequisites found
9:36:39 AM [main] Initializing Modules
9:36:39 AM [Apache] Apache Service detected with wrong path
9:36:39 AM [Apache] Change XAMPP Apache settings or
9:36:39 AM [Apache] Uninstall/disable the other service manually first
9:36:39 AM [Apache] Found Path: "C:\xampp-win32-1.8.1-vc9\xampp\apache\bin\httpd.exe" -k runservice
9:36:39 AM [Apache] Expected Path: "c:\xampp\apache\bin\httpd.exe" -k runservice
9:36:39 AM [mysql] MySQL Service detected with wrong path
9:36:39 AM [mysql] Change XAMPP MySQL settings or
9:36:39 AM [mysql] Uninstall/disable the other service manually first
9:36:39 AM [mysql] Found Path: C:\xampp-win32-1.8.1-vc9\xampp\mysql\bin\mysqld.exe --defaults-file=c:\xampp-win32-1.8.1-vc9\xampp\mysql\bin\my.ini mysql
9:36:39 AM [mysql] Expected Path: c:\xampp\mysql\bin\mysqld.exe --defaults-file=c:\xampp\mysql\bin\my.ini mysql
9:36:39 AM [filezilla] FileZilla Service detected with wrong path
9:36:39 AM [filezilla] Change XAMPP FileZilla settings or
9:36:39 AM [filezilla] Uninstall/disable the other service manually first
9:36:39 AM [filezilla] Found Path: "C:\xampp-win32-1.8.1-vc9\xampp\filezillaftp\filezillaserver.exe"
9:36:39 AM [filezilla] Expected Path: "c:\xampp\FileZillaFTP\filezillaserver.exe"
9:36:39 AM [main] Starting Check-Timer
9:36:39 AM [main] Control Panel Ready

I am learning Wordpress, HTML5 & CSS3 - hence requiring a localhost.
Any help whatsoever would be greatly appreciated as this is beyond me.
__________________________________________________________
Hi, I am running Windows 7 x64 (vcredist_x64 & x 86 installed)

When executing "apache_start.bat" the following error appears:
httpd.exe: Syntax error on line 35 of C:/xampp-win32-1.8.1-VC9/xampp/apache/conf/httpd.conf: ServerRoot must be a valid directory

When executing "mysql_start.bat" the following error appears:
130107 13:58:11 [ERROR] Can't find messagefile 'C:/xampp/mysql/share/errmsg.sys'
130107 13:58:11 [Warning] Can't create test file /xampp/mysql/data/my-PC.lower-test
130107 13:58:11 [Warning] Can't create test file /xampp/mysql/data/my-PC.lower-test
mysql/bin/mysqld: Can't change dir to 'xampp/mysql/data/' (errcode: 2)
130107 13:58:11 [ERROR] Aborting

The only "green light" running is FileZilla.

Your help would be greatly appreciated.
cateleb
 
Posts: 4
Joined: 07. January 2013 02:50
Operating System: Windows 7 x64

Re: UPDATE: apache/sql errors on Windows 7 x64

Postby hackattack142 » 08. January 2013 03:05

Hello,

C:/xampp-win32-1.8.1-VC9/xampp/

I would not recommend having any special characters in your path.

It looks like you might need to run 'setup_xampp.bat' in the /xampp directory
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: UPDATE: apache/sql errors on Windows 7 x64

Postby cateleb » 08. January 2013 07:52

Have reinstalled yet again.

All firewalls turned off
IIS is off
Registry is clean and rebooted (cleared all paths to C:/xampp-win32-1.8.1-VC9/xampp/)

XAMPP Control Panel v3.1.0.3.1.0
5:42:19 PM [main] Initializing Control Panel
5:42:19 PM [main] Windows Version: Windows 7 Professional SP1 64-bit
5:42:19 PM [main] XAMPP Version: 1.8.1
5:42:19 PM [main] Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
5:42:19 PM [main] Running with Administrator rights - good!
5:42:19 PM [main] XAMPP Installation Directory: "c:\xampp\"
5:42:19 PM [main] Checking for prerequisites
5:42:19 PM [main] All prerequisites found
5:42:19 PM [main] Initializing Modules
5:42:19 PM [main] Starting Check-Timer
5:42:19 PM [main] Control Panel Ready
5:45:28 PM [mysql] Attempting to start MySQL service...
5:45:37 PM [filezilla] Attempting to start FileZilla service...

When trying to start Apache the following error appears:
[EXCEPTION] System Error. Code: 3
The system cannot find the path specified
[EXCEPTION] Access violation at address 005ABEFE in module 'xampp-control.exe'. Read of address 00000042

Don't know what else to check
cateleb
 
Posts: 4
Joined: 07. January 2013 02:50
Operating System: Windows 7 x64

Re: UPDATE: apache/sql errors on Windows 7 x64

Postby hackattack142 » 08. January 2013 14:26

Hello,

Could you first grab the latest control panel from my signature link.

Next, could you try running the modules standalone (Make them a red X under the Service column in the Control Panel).
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: UPDATE: apache/sql errors on Windows 7 x64

Postby cateleb » 08. January 2013 23:14

Hi hackattack142,

Still no luck. I have uploaded CPv3.1.0_Beta7.7z. Please see the following:

9:10:08 AM [main] Initializing Control Panel
9:10:08 AM [main] Windows Version: Windows 7 Professional SP1 64-bit
9:10:08 AM [main] XAMPP Version: 1.8.1
9:10:08 AM [main] Control Panel Version: 3.1.0 Beta 7 [ Compiled: October 5th 2012 ]
9:10:08 AM [main] Running with Administrator rights - good!
9:10:08 AM [main] XAMPP Installation Directory: "c:\xampp\"
9:10:08 AM [main] Checking for prerequisites
9:10:08 AM [main] All prerequisites found
9:10:08 AM [main] Initializing Modules
9:10:08 AM [main] Starting Check-Timer
9:10:08 AM [main] Control Panel Ready
9:10:13 AM [Apache] Attempting to start Apache service...

9:11:10 AM [main] Initializing Control Panel
9:11:10 AM [main] Windows Version: Windows 7 Professional SP1 64-bit
9:11:10 AM [main] XAMPP Version: 1.8.1
9:11:10 AM [main] Control Panel Version: 3.1.0 Beta 7 [ Compiled: October 5th 2012 ]
9:11:10 AM [main] Running with Administrator rights - good!
9:11:10 AM [main] XAMPP Installation Directory: "c:\xampp\"
9:11:10 AM [main] Checking for prerequisites
9:11:10 AM [main] All prerequisites found
9:11:10 AM [main] Initializing Modules
9:11:10 AM [main] Starting Check-Timer
9:11:10 AM [main] Control Panel Ready
9:11:13 AM [mysql] Attempting to start MySQL service...

9:11:32 AM [main] Initializing Control Panel
9:11:32 AM [main] Windows Version: Windows 7 Professional SP1 64-bit
9:11:32 AM [main] XAMPP Version: 1.8.1
9:11:32 AM [main] Control Panel Version: 3.1.0 Beta 7 [ Compiled: October 5th 2012 ]
9:11:32 AM [main] Running with Administrator rights - good!
9:11:32 AM [main] XAMPP Installation Directory: "c:\xampp\"
9:11:32 AM [main] Checking for prerequisites
9:11:32 AM [main] All prerequisites found
9:11:32 AM [main] Initializing Modules
9:11:32 AM [main] Starting Check-Timer
9:11:32 AM [main] Control Panel Ready
9:11:34 AM [filezilla] Attempting to start FileZilla service...

I'm not getting the Apache error as per previous post.

Is there anything else I can do? Thanks heaps
cateleb
 
Posts: 4
Joined: 07. January 2013 02:50
Operating System: Windows 7 x64

Re: UPDATE: apache/sql errors on Windows 7 x64

Postby hackattack142 » 09. January 2013 03:14

Okay, so Apache is working as expected now?

I do not see any error messages for anything now. What exactly is not working now and what error messages are you getting?

Also, do they work standalone (not as a service I.E. red X in the Service column in the XAMPP Control Panel)?
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: UPDATE: apache/sql errors on Windows 7 x64

Postby cateleb » 09. January 2013 04:25

Hi hackattack142, my sincerest thanks, all up and running. Wishing you the very best and a wonderful 2013
cateleb
 
Posts: 4
Joined: 07. January 2013 02:50
Operating System: Windows 7 x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests