Unable to start MySQL

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Unable to start MySQL

Postby jon_e_cache » 06. January 2013 13:39

I am unable to start MySQL Services. I am running with Admin rights. The error line indicates that I have the wrong file path, but I cannot find the file that contains the wrong path string. My.ini has no such file path string. I am thinking it is somewhere in the Windows Registry, but cannot find it.

9:32:49 PM [main] Initializing Control Panel
9:32:49 PM [main] Windows Version: 32-bit
9:32:49 PM [main] XAMPP Version: 1.8.1
9:32:49 PM [main] Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
9:32:49 PM [main] Running with Administrator rights - good!
9:32:49 PM [main] XAMPP Installation Directory: "h:\xampp\"
9:32:49 PM [main] Checking for prerequisites
9:32:50 PM [main] All prerequisites found
9:32:50 PM [main] Initializing Modules
9:32:50 PM [Apache] XAMPP Apache is already running on port 80
9:32:50 PM [Apache] XAMPP Apache is already running on port 443
9:32:50 PM [mysql] MySQL Service detected with wrong path
9:32:50 PM [mysql] Change XAMPP MySQL settings or
9:32:50 PM [mysql] Uninstall/disable the other service manually first
9:32:50 PM [mysql] Found Path: "F:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld" --defaults-file="F:\Program Files\MySQL\MySQL Server 5.1\my.ini" MySQL
9:32:50 PM [mysql] Expected Path: h:\xampp\mysql\bin\mysqld.exe --defaults-file=h:\xampp\mysql\bin\my.ini mysql
9:32:50 PM [main] Enabling autostart for module "Apache"
9:32:50 PM [main] Enabling autostart for module "MySQL"
9:32:50 PM [main] Starting Check-Timer
9:32:50 PM [main] Control Panel Ready
9:32:51 PM [Apache] Autostart aborted: Apache is already running
9:32:51 PM [mysql] Autostart active: starting...
9:32:51 PM [mysql] Attempting to start MySQL service...
9:33:02 PM [mysql] Attempting to start MySQL service...
jon_e_cache
 
Posts: 2
Joined: 06. January 2013 04:13
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Unable to start MySQL

Postby jon_e_cache » 06. January 2013 13:55

Problem solved!! Found the errors in the registry. Fixed them. Everything now works fine!
jon_e_cache
 
Posts: 2
Joined: 06. January 2013 04:13
XAMPP Version: 5.6.3
Operating System: Windows 8


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests