Localhost not found??

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Localhost not found??

Postby d_aj » 01. January 2013 14:32

I'm having a terrible time tryin to get this xampp to work. So far I have deleted all my sql related programs. I have uninstalled xampp. I have run a registry cleaner.I reboot the PC. I have reinstalled xampp. I have configured Apache to run on port 90. I have done this about 7 times. Each time I get a different control panel display.
I dont know how, but finally I think I have it running

The control panel loads with Apache and mysql showing green ticks's and the buttons showing the Stop click event.
Filezilla has a green tick and shows a Start button click event.
Murcury has a blank box and a Start button click event.
Tomcat has a red X and a start button click event.

the log says
13:25:33 [main] Initializing Control Panel
13:25:33 [main] Windows Version: Windows 7 Ultimate SP1 32-bit
13:25:33 [main] XAMPP Version: 1.8.1
13:25:33 [main] Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
13:25:33 [main] Running with Administrator rights - good!
13:25:33 [main] XAMPP Installation Directory: "c:\xampp\"
13:25:33 [main] Checking for prerequisites
13:25:33 [main] All prerequisites found
13:25:33 [main] Initializing Modules
13:25:33 [Apache] Problem detected!
13:25:33 [Apache] Port 80 in use by "system"!
13:25:33 [Apache] Apache WILL NOT start without the configured ports free!
13:25:33 [Apache] You need to uninstall/disable/reconfigure the blocking application
13:25:33 [Apache] or reconfigure Apache to listen on a different port
13:25:33 [Apache] XAMPP Apache Service is already running on port 443
13:25:33 [mysql] XAMPP MySQL Service is already running on port 3306
13:25:33 [filezilla] FileZilla Service detected with wrong path
13:25:33 [filezilla] Change XAMPP FileZilla settings or
13:25:33 [filezilla] Uninstall/disable the other service manually first
13:25:33 [filezilla] Found Path: "C:\server\filezillaftp\filezillaserver.exe"
13:25:33 [filezilla] Expected Path: "c:\xampp\FileZillaFTP\filezillaserver.exe"
13:25:33 [main] Starting Check-Timer
13:25:33 [main] Control Panel Ready

I'm now at the stage where I need to load the localhost, unfortunately, all I get is
HTTP 404 not found.

I have spent over three days of my life trying to get this to work.

CAN ANYBODY HELP PLEASE???

Thanks
AJ
Honest Babe! That's never happened before!!
d_aj
 
Posts: 7
Joined: 29. December 2012 14:20
XAMPP Version: 5.6.3
Operating System: win7 ultimate

Re: Localhost not found??

Postby hackattack142 » 01. January 2013 16:17

13:25:33 [Apache] Problem detected!
13:25:33 [Apache] Port 80 in use by "system"!
13:25:33 [Apache] Apache WILL NOT start without the configured ports free!
13:25:33 [Apache] You need to uninstall/disable/reconfigure the blocking application
13:25:33 [Apache] or reconfigure Apache to listen on a different port

You should resolve this issue first. "system" typically means that a Windows Service is taking that port. This is typically a component of IIS. One common one that gets enabled is World Wide Publishing service. If you have that service or another part of IIS running, you should stop/disable them or reconfigure Apache (and the control panel) to listen on a different port.

If you reconfigure Apache to use a different port, you need to also tell the XAMPP Control Panel to look for a different Apache port (Config > Service and Port Settings). You will also need to specify the port in your URL (eg: http://localhost:90 )

13:25:33 [filezilla] FileZilla Service detected with wrong path
13:25:33 [filezilla] Change XAMPP FileZilla settings or
13:25:33 [filezilla] Uninstall/disable the other service manually first
13:25:33 [filezilla] Found Path: "C:\server\filezillaftp\filezillaserver.exe"
13:25:33 [filezilla] Expected Path: "c:\xampp\FileZillaFTP\filezillaserver.exe

This is from not completely removing the service from a previous installation. You might just be able to uncheck the Service box by FileZilla in the XAMPP Control Panel and recheck it to remove this error otherwise you will have to remove it manually and recheck it.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Localhost not found??

Postby d_aj » 02. January 2013 12:50

Hey hackattack142. Thank you very much.
I have managed to get into localhost (90). The un-checking/ checking worked for Filezilla and the port settings in the control panel did the job. Thanks again.

However I am still unable to launch Tomcat.
The run time log ( if that's the right terminology?) says this:

11:38:11 [Tomcat] Attempting to start Tomcat app...
11:48:43 [Tomcat] Tomcat Started/Stopped with errors, return code: -1073741510
11:48:43 [Tomcat] Make sure you have Java JDK or JRE installed and the required ports are free
11:48:43 [Tomcat] Check the "/xampp/tomcat/logs" folder for more information

A command prompt window then displays this.


[XAMPP]: Searching for JDK or JRE HOME with reg query ...
ERROR: The system was unable to find the specified registry key or value.
. [XAMPP]: Could not find 32 bit or 64 bit JDK
. [XAMPP]: Looking for 32 bit JDK on 64 bit machine
ERROR: The system was unable to find the specified registry key or value.
. [XAMPP]: Could not find 32 bit JDK
. [XAMPP]: Looking for 32 bit or 64 bit JRE

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment
Java6FamilyVersion REG_SZ 1.6.0_37
CurrentVersion REG_SZ 1.7
sponsorsoffered REG_SZ SP14;
BrowserJavaVersion REG_SZ 10.10.2
Java7FamilyVersion REG_SZ 1.7.0_10

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.6
JavaHome REG_SZ C:\Program Files\Java\jre6
RuntimeLib REG_SZ C:\Program Files\Java\jre6\bin\client\jvm.dll
MicroVersion REG_SZ 0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.6.0_37
JavaHome REG_SZ C:\Program Files\Java\jre6
MicroVersion REG_SZ 0
RuntimeLib REG_SZ C:\Program Files\Java\jre6\bin\client\jvm.dll

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.6.0_37\MSI
JU REG_SZ 1
OEMUPDATE REG_SZ
MODE REG_SZ U
JQS REG_SZ
FROMVERSION REG_SZ 1.6.0_35
FROMVERSIONFULL REG_SZ 1.6.0_35-b10
KERNEL REG_SZ
PRODUCTVERSION REG_SZ 6.0.370
INSTALLDIR REG_SZ C:\Program Files\Java\jre6\
SYSTRAY REG_SZ 1
EULA REG_SZ 0
IEXPLORER REG_SZ 1
MOZILLA REG_SZ 1
JAVAUPDATE REG_SZ 1
AUTOUPDATECHECK REG_SZ 1
AUTOUPDATEDELAY REG_SZ
ImageCkSum REG_SZ 1743784835
FullVersion REG_SZ 1.6.0_37-b06

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.7
JavaHome REG_SZ C:\Program Files\Java\jre7
RuntimeLib REG_SZ C:\Program Files\Java\jre7\bin\client\jvm.dll
MicroVersion REG_SZ 0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.7.0_10
JavaHome REG_SZ C:\Program Files\Java\jre7
MicroVersion REG_SZ 0
RuntimeLib REG_SZ C:\Program Files\Java\jre7\bin\client\jvm.dll

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.7.0_10\MSI
JU REG_SZ 1
OEMUPDATE REG_SZ
MODE REG_SZ C
JQS REG_SZ
FROMVERSION REG_SZ
FROMVERSIONFULL REG_SZ
PRODUCTVERSION REG_SZ 7.0.100
INSTALLDIR REG_SZ C:\Program Files\Java\jre7\
PATCHDIR REG_SZ
WEB_JAVA_SECURITY_LEVEL REG_SZ
WEB_JAVA REG_SZ
EULA REG_SZ 0
IEXPLORER REG_SZ 1
MOZILLA REG_SZ 1
JAVAUPDATE REG_SZ 1
AUTOUPDATECHECK REG_SZ 1
AUTOUPDATEDELAY REG_SZ
ImageCkSum REG_SZ 417737078
FullVersion REG_SZ 1.7.0_10-b18


[XAMPP]: Using JRE

[XAMPP]: Seems fine!
[XAMPP]: Set JRE_HOME : C:\Program Files\Java\jre7
[XAMPP]: Set CATALINA_HOME : c:\xampp\tmp\tomcat

The system cannot find the path specified.
The system cannot find the path specified.
done.
Press any key to continue . . .

Any ideas please.
very many thanks
AJ
Honest Babe! That's never happened before!!
d_aj
 
Posts: 7
Joined: 29. December 2012 14:20
XAMPP Version: 5.6.3
Operating System: win7 ultimate

Re: Localhost not found??

Postby hackattack142 » 02. January 2013 17:37

Hello,

I am still not sure why those bat files have that behavior and I cannot replicate it.

Could you open 'catalina_start.bat', 'catalina_service.bat', and 'catalina_stop.bat' in the /xampp directory and change the following lines
Code: Select all
set "CURRENT_DIR=%cd%"
set "CATALINA_HOME=%CURRENT_DIR%\tomcat"

to
Code: Select all
set "CURRENT_DIR=%~dp0"
set "CATALINA_HOME=%CURRENT_DIR%tomcat"


There should be 2 instances in each file and see if that fixes it.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Localhost not found??

Postby d_aj » 02. January 2013 18:55

Hi again
I ran with the new settings.
I now have all the module names in green, green ticks in Apache, MySQL and FileZilla. Blank box for Mercury and a Red X for Tomcat.
All the action buttons are showing the Stop button click event.

The catalina_start.bat log command prompt window now displays this.

[XAMPP]: Searching for JDK or JRE HOME with reg query ...
ERROR: The system was unable to find the specified registry key or value.
. [XAMPP]: Could not find 32 bit or 64 bit JDK
. [XAMPP]: Looking for 32 bit JDK on 64 bit machine
ERROR: The system was unable to find the specified registry key or value.
. [XAMPP]: Could not find 32 bit JDK
. [XAMPP]: Looking for 32 bit or 64 bit JRE

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment
Java6FamilyVersion REG_SZ 1.6.0_37
CurrentVersion REG_SZ 1.7
sponsorsoffered REG_SZ SP14;
BrowserJavaVersion REG_SZ 10.10.2
Java7FamilyVersion REG_SZ 1.7.0_10

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.6
JavaHome REG_SZ C:\Program Files\Java\jre6
RuntimeLib REG_SZ C:\Program Files\Java\jre6\bin\client\jvm.dll
MicroVersion REG_SZ 0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.6.0_37
JavaHome REG_SZ C:\Program Files\Java\jre6
MicroVersion REG_SZ 0
RuntimeLib REG_SZ C:\Program Files\Java\jre6\bin\client\jvm.dll

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.6.0_37\MSI
JU REG_SZ 1
OEMUPDATE REG_SZ
MODE REG_SZ U
JQS REG_SZ
FROMVERSION REG_SZ 1.6.0_35
FROMVERSIONFULL REG_SZ 1.6.0_35-b10
KERNEL REG_SZ
PRODUCTVERSION REG_SZ 6.0.370
INSTALLDIR REG_SZ C:\Program Files\Java\jre6\
SYSTRAY REG_SZ 1
EULA REG_SZ 0
IEXPLORER REG_SZ 1
MOZILLA REG_SZ 1
JAVAUPDATE REG_SZ 1
AUTOUPDATECHECK REG_SZ 1
AUTOUPDATEDELAY REG_SZ
ImageCkSum REG_SZ 1743784835
FullVersion REG_SZ 1.6.0_37-b06

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.7
JavaHome REG_SZ C:\Program Files\Java\jre7
RuntimeLib REG_SZ C:\Program Files\Java\jre7\bin\client\jvm.dll
MicroVersion REG_SZ 0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.7.0_10
JavaHome REG_SZ C:\Program Files\Java\jre7
MicroVersion REG_SZ 0
RuntimeLib REG_SZ C:\Program Files\Java\jre7\bin\client\jvm.dll

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.7.0_10\MSI
JU REG_SZ 1
OEMUPDATE REG_SZ
MODE REG_SZ C
JQS REG_SZ
FROMVERSION REG_SZ
FROMVERSIONFULL REG_SZ
PRODUCTVERSION REG_SZ 7.0.100
INSTALLDIR REG_SZ C:\Program Files\Java\jre7\
PATCHDIR REG_SZ
WEB_JAVA_SECURITY_LEVEL REG_SZ
WEB_JAVA REG_SZ
EULA REG_SZ 0
IEXPLORER REG_SZ 1
MOZILLA REG_SZ 1
JAVAUPDATE REG_SZ 1
AUTOUPDATECHECK REG_SZ 1
AUTOUPDATEDELAY REG_SZ
ImageCkSum REG_SZ 417737078
FullVersion REG_SZ 1.7.0_10-b18


[XAMPP]: Using JRE

[XAMPP]: Seems fine!
[XAMPP]: Set JRE_HOME : C:\Program Files\Java\jre7
[XAMPP]: Set CATALINA_HOME : c:\xampp\tomcat

The system cannot find the path specified.
Using CATALINA_BASE: "c:\xampp\tomcat"
Using CATALINA_HOME: "c:\xampp\tomcat"
Using CATALINA_TMPDIR: "c:\xampp\tomcat\temp"
Using JRE_HOME: "C:\Program Files\Java\jre7"
Using CLASSPATH: "c:\xampp\tomcat\bin\bootstrap.jar;c:\xampp\tomcat\bin\to
mcat-juli.jar"
Jan 02, 2013 5:52:14 PM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performanc
e in production environments was not found on the java.library.path: C:\Program
Files\Java\jre7\bin;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Pr
ogram Files\Common Files\Microsoft Shared\Windows Live;C:\Windows\system32;C:\Wi
ndows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Pr
ogram Files\Common Files\Roxio Shared\10.0\DLLShared\;C:\Program Files\Windows L
ive\Shared;C:\Program Files\QuickTime\QTSystem\;E:\Program Files\MySQL\MySQL Ser
ver 5.5\bin;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Fil
es\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files\Microsoft ASP.NET\ASP.NET
Web Pages\v1.0\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Progra
m Files\Microsoft\Web Platform Installer\;C:\Program Files\FreeArc\bin;.
Jan 02, 2013 5:52:14 PM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-8080"]
Jan 02, 2013 5:52:14 PM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["ajp-bio-8009"]
Jan 02, 2013 5:52:14 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 380 ms
Jan 02, 2013 5:52:14 PM org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
Jan 02, 2013 5:52:15 PM org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.30
Jan 02, 2013 5:52:15 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\docs
Jan 02, 2013 5:52:15 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\examples
Jan 02, 2013 5:52:15 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\host-manager
Jan 02, 2013 5:52:15 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\manager
Jan 02, 2013 5:52:15 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\ROOT
Jan 02, 2013 5:52:15 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8080"]
Jan 02, 2013 5:52:15 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["ajp-bio-8009"]
Jan 02, 2013 5:52:15 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 457 ms

Are we there yet? :-)
Seriously, thanks for you guidance on this. I would be lost otherwise.

AJ
Honest Babe! That's never happened before!!
d_aj
 
Posts: 7
Joined: 29. December 2012 14:20
XAMPP Version: 5.6.3
Operating System: win7 ultimate

Re: Localhost not found??

Postby hackattack142 » 02. January 2013 20:25

Hello, I am glad that fix worked. I will fix it in future versions of those batch files.

It looks like it started up correctly. You can hide that command window for Tomcat by going to the Control Panel config and unchecking "Enable tomcat output window"

You can also test Tomcat by going to http://localhost:8080
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Localhost not found??

Postby d_aj » 02. January 2013 21:14

Looks as though you did it.
I don't want to go over the top but really, you have been a great help. I was ready to give up. Owing to what you have done I have learned quite a bit, something I wouldn't have- if it had been a smooth install.

Going to try for the joomla install now. Fingers crossed.

THANK YOU.

Kind regards
AJ

Have a fortunate 2013.
Honest Babe! That's never happened before!!
d_aj
 
Posts: 7
Joined: 29. December 2012 14:20
XAMPP Version: 5.6.3
Operating System: win7 ultimate


Return to XAMPP for Windows

Who is online

Users browsing this forum: sunrisecc and 51 guests