mySql not responding

Problems with the Windows version of XAMPP, questions, comments, and anything related.

mySql not responding

Postby rumbleeye » 16. December 2012 20:27

I reinstalled Xampp so I now use the latest version.

when I press on the Apache "start" it goes green but when I press start for mySql, nothing happens.

it just beep, and writes:
"Attempting to start MySQL app..."
But nothing happens.

the "mysql_error.log" file is empty


can anyone help me please?
rumbleeye
 
Posts: 9
Joined: 16. December 2012 20:19
XAMPP Version: 5.6.3
Operating System: windows 7

Re: mySql not responding

Postby JonB » 16. December 2012 20:42

I reinstalled Xampp so I now use the latest version.


Please define re-installed...

Did you 100% remove XAMPP and all its services before re-installing?
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: mySql not responding

Postby rumbleeye » 16. December 2012 20:50

no, I reinstalled - simply installed the program again.
(I assumed it will over write the existing version I had - the reason I reinstalled is because there - the mysql did work but the apache didn't and now its the oposit)

I didnt remove the files hoping it will leave the settings of a certain db that I had there.
rumbleeye
 
Posts: 9
Joined: 16. December 2012 20:19
XAMPP Version: 5.6.3
Operating System: windows 7

Re: mySql not responding

Postby JonB » 17. December 2012 01:50

Well - that is what I suspected. And the answer is 'that does not work'.

viewtopic.php?f=16&t=50988

And that is why its a sticky up at the top. :wink:

You should unistall/remove - then start fresh

Good Luck
:D
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: mySql not responding

Postby rumbleeye » 18. December 2012 21:57

YEY!
thanx, that was really helpful! indeed, I had to redo it all.

But now, I cant import my data.
it's 3 files with the extension: .sql
the new gui only allows to import gzip, bzip2, zip...
(i tried to zip my 3 files but it didn't work)
rumbleeye
 
Posts: 9
Joined: 16. December 2012 20:19
XAMPP Version: 5.6.3
Operating System: windows 7

Re: mySql not responding

Postby rumbleeye » 20. December 2012 11:32

anyone?

I can't import the data (.sql) files
rumbleeye
 
Posts: 9
Joined: 16. December 2012 20:19
XAMPP Version: 5.6.3
Operating System: windows 7

Re: mySql not responding

Postby Nobbie » 20. December 2012 11:43

rumbleeye wrote:the new gui only allows to import gzip, bzip2, zip...


Which "gui" do you mean? Phpmyadmin?

I have Xampp 1.8.1 with Phpmyadmin running on Windows7 64 Ultimate and there is no restriction to imported files. Can you show a screenshot of the import Screen with explanation and/or error message why you "cannot" import SQL Files?
Nobbie
 
Posts: 6921
Joined: 09. March 2008 13:04

Re: mySql not responding

Postby JonB » 20. December 2012 11:44

Answer -

If the .SQL files were exports, you can paste them into the Query window.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: mySql not responding

Postby rumbleeye » 20. December 2012 19:51

huh? I can't upload pics here?
rumbleeye
 
Posts: 9
Joined: 16. December 2012 20:19
XAMPP Version: 5.6.3
Operating System: windows 7

Re: mySql not responding

Postby rumbleeye » 20. December 2012 20:07

well, I cant prtscr - so I'l copy the error msg:

in the cmd line I type:
Code: Select all
C:\xampp\mysql\bin>mysql -u root db < users.sql



and I get:
Code: Select all
mysql: Unknown OS character set 'cp862'.
mysql: Switching to the default character set 'latin1'.
ERROR 2006 (HY000) at line 51: MySQL server has gone away



the database representation now appears in phpMyAdmin but it is empty

(Im running windows 7 32 bit)
rumbleeye
 
Posts: 9
Joined: 16. December 2012 20:19
XAMPP Version: 5.6.3
Operating System: windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests