Apache starts and immediately shuts down

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache starts and immediately shuts down

Postby bruceaj » 15. December 2012 17:48

My operating systems is Windows 8
XAMPP version is: 1.8.1

Using XAMPP, I start Apache and get the following message

Attempting to start Apache app...
Status change detected: running
Status change detected: stopped
Error: Apache shutdown unexpectedly.
This may be due to a blocked port, missing dependencies,
improper privileges, a crash, or a shutdown by another method.
Check the "/xampp/apache/logs/error.log" file
and the Windows Event Viewer for more clues


/xammp/apache/logs/error.log is empty

I don't know how to get the Windows Event Viewer.

I am "guessing" this a "Port" problem. What ports should I change in Apaches httpd.conf file?

Thanks for the help.
bruceaj
 
Posts: 22
Joined: 15. December 2012 17:37
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Apache starts and immediately shuts down

Postby amereservant » 16. December 2012 03:13

The main issue with ports is something using port 80, which 90% of the time in the past, it was Skype that was the culprit. Skype by default chooses port 80 and the workaround is simple ... shutdown Skype, start Apache, then re-launch Skype and Skype will choose a different port automatically.

The other issue could be with Windows Firewall blocking it, Windows User Account Control, etc., which it should alert you saying that an application is trying to access it and allow you to accept or deny it, depending on your settings. So if the first part doesn't work (Skype), then troubleshoot these two areas.
For great video and written tutorials and guides on creating your own web server and installing things such as forums, blogs, etc., visit http://myownhomeserver.com
User avatar
amereservant
 
Posts: 16
Joined: 16. December 2012 00:37
Location: Columbus, MS
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache starts and immediately shuts down

Postby bruceaj » 17. December 2012 19:53

I don't have Skype installed, at least it doesn't appear in my list of installed programs.

I turned the Firewall off. No help.
UAC messages does not appear.

When I use the XAMPP control panel to start Apache, a PID appars briefly, then I get the error message that I posted in my original message.
Attempting to start Apache app...
Status change detected: running
Status change detected: stopped
Error: Apache shutdown unexpectedly.
This may be due to a blocked port, missing dependencies,
improper privileges, a crash, or a shutdown by another method.
Check the "/xampp/apache/logs/error.log" file
and the Windows Event Viewer for more clues

In httpd.conf, I have "LISTEN 80". Can you suggest any other configuration control statements I should be looking at?

Again, thanks for the help.

Bruce
bruceaj
 
Posts: 22
Joined: 15. December 2012 17:37
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Apache starts and immediately shuts down

Postby amereservant » 18. December 2012 02:35

I just installed XAMPP 1.8.1 on Windows 8 and even left the UAC on and had no problems whatsoever...

What you might try is changing the
Code: Select all
LISTEN 80
to
Code: Select all
LISTEN 8080
, save it, then try starting Apache again. If it starts, then yeap, it's a port issue.
For great video and written tutorials and guides on creating your own web server and installing things such as forums, blogs, etc., visit http://myownhomeserver.com
User avatar
amereservant
 
Posts: 16
Joined: 16. December 2012 00:37
Location: Columbus, MS
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache starts and immediately shuts down

Postby bruceaj » 18. December 2012 02:56

I changed to LISTEN 8080. Didn't help. I couldn't find"CODE:SELECT ALL" in the config file. I added to see if it would help. No Joy!!

I'm going to uninstall and reinstall XAMMP.

Let's hope!!

Thanks for the help.

Bruce
bruceaj
 
Posts: 22
Joined: 15. December 2012 17:37
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Apache starts and immediately shuts down

Postby amereservant » 18. December 2012 03:07

Hehe, CODE: SELECT ALL is not part of the config file ... it's just formatting on the forums. The actual part is the LISTEN 80 part. Re-installing it probably won't help, but it won't hurt either, so give it a try.
For great video and written tutorials and guides on creating your own web server and installing things such as forums, blogs, etc., visit http://myownhomeserver.com
User avatar
amereservant
 
Posts: 16
Joined: 16. December 2012 00:37
Location: Columbus, MS
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache starts and immediately shuts down

Postby bruceaj » 18. December 2012 03:25

localhost displays the XAMMP proper install html page. So, reinstall worked.

Apache is now displaying the ports of 80 and 443.

All is good.

Thanks much for your help. I really aporeciate it.

Bruce
bruceaj
 
Posts: 22
Joined: 15. December 2012 17:37
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Apache starts and immediately shuts down

Postby bruceaj » 18. December 2012 05:37

Okay. I think I have found the root of the problem. If I restart Apache from the XAMPP Control panel displayed on the monitor, it seems to start another copy of Apache. This, after a few restarts, confuses Apache because of the mulitple copies. If I stop and restart Apache from the task bar icon, all seems to be good. I did 5 or 6 restarts this way and never got the error.

This problem seems to be solved.

Now, I have alias_module problem which I'll open a new Post with.

Thanks..

Bruce
bruceaj
 
Posts: 22
Joined: 15. December 2012 17:37
XAMPP Version: 5.6.3
Operating System: Windows 8


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests