MySql Service won't start automaticaly

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySql Service won't start automaticaly

Postby Draelis » 11. December 2012 11:03

Hi,

I've got an issue with the MySQL base in Xampp. I've installed it on a w2008R2, to host a little web-based maintenance ticket program (OsTicket) and it works very well.

Juste one problem ! My MySQL database won't start automaticaly when my server boot. The Service won't start, to be exact. I can launch the base in command line with a "mysql\bin\mysqld --defaults-file=mysql\bin\my.ini --standalone --console" but when he tries to boot alone, i have an error message :

"mysqld: unknown option '-d'"

I don't understand that, i've searched for this "-d" command and don't find it. When i try to start the service manually, in the SCV, windows can't launch it and show an error 1067.

i can't launch MySQL in the xampp control panel when the service was installed, but i can when he doesn't. I wonder why ? oO
Draelis
 
Posts: 9
Joined: 11. December 2012 10:16
Operating System: 2008 R2

Re: MySql Service won't start automaticaly

Postby Draelis » 17. December 2012 09:39

Err, nobody can help me ? ^^b

I'am really... Confused! And can't find the answer by myself :(
Draelis
 
Posts: 9
Joined: 11. December 2012 10:16
Operating System: 2008 R2

Re: MySql Service won't start automaticaly

Postby hackattack142 » 20. December 2012 02:33

Are you using the XAMPP control panel?

If so, could you post the entire log of it after starting it and trying to start MySQL?
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: MySql Service won't start automaticaly

Postby Draelis » 20. December 2012 11:06

Yes i'am using the xampp control panel.

MySql launched normaly before the service was installed. After installation, it doesn't anymore and I have the following message when I try to run it:

121220 11:04:41 InnoDB: The InnoDB memory heap is disabled
121220 11:04:41 InnoDB: Mutexes and rw_locks use Windows interlocked functions
121220 11:04:41 InnoDB: Compressed tables use zlib 1.2.3
121220 11:04:41 InnoDB: Initializing buffer pool, size = 16.0M
121220 11:04:41 InnoDB: Completed initialization of buffer pool
121220 11:04:41 InnoDB: highest supported file format is Barracuda.
121220 11:04:41 InnoDB: Waiting for the background threads to start
121220 11:04:42 InnoDB: 1.1.8 started; log sequence number 1595675
121220 11:04:42 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
121220 11:04:42 [Note] - '0.0.0.0' resolves to '0.0.0.0';
121220 11:04:42 [Note] Server socket created on IP: '0.0.0.0'.
121220 11:04:42 [Note] Event Scheduler: Loaded 0 events
121220 11:04:42 [Note] d:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.25a' socket: '' port: 3306 MySQL Community Server (GPL)
Draelis
 
Posts: 9
Joined: 11. December 2012 10:16
Operating System: 2008 R2

Re: MySql Service won't start automaticaly

Postby hackattack142 » 20. December 2012 15:59

There are no errors in that log.

Could you open your services (Start > Run > services.msc), go to the mysql service, right-click > properties > copy the entire "Path to Executable" here
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: MySql Service won't start automaticaly

Postby Draelis » 20. December 2012 16:14

D:\xampp\mysql\bin\mysqld.exe --defaults-file=d:\xampp\mysql\bin\my.ini mysql


Here!
Draelis
 
Posts: 9
Joined: 11. December 2012 10:16
Operating System: 2008 R2

Re: MySql Service won't start automaticaly

Postby hackattack142 » 20. December 2012 16:52

hmm could you post the contents of you my.ini file
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: MySql Service won't start automaticaly

Postby Draelis » 20. December 2012 17:05

# Example MySQL config file for small systems.
#
# This is for a system with little memory (<= 64M) where MySQL is only used
# from time to time and it's important that the mysqld daemon
# doesn't use much resources.
#
# You can copy this file to
# /xampp/mysql/bin/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is /xampp/mysql/data) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
# password = your_password
port = 3306
socket = "/xampp/mysql/mysql.sock"

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port= 3306
socket = "/xampp/mysql/mysql.sock"
basedir = "/xampp/mysql"
tmpdir = "/xampp/tmp"
datadir = "/xampp/mysql/data"
pid_file = "mysql.pid"
skip-external-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M
log_error = "mysql_error.log"

#bind-address="127.0.0.1"

# Where do all the plugins live
plugin_dir = "/xampp/mysql/data/lib/plugin/"

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
#
# commented in by lampp security
#skip-networking
federated

# Replication Master Server (default)
# binary logging is required for replication
# log-bin deactivated by default since XAMPP 1.4.11
#log-bin=mysql-bin

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id = 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
# the syntax is:
#
# CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
# MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
# where you replace <host>, <user>, <password> by quoted strings and
# <port> by the master's port number (3306 by default).
#
# Example:
#
# CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
# MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
# start replication for the first time (even unsuccessfully, for example
# if you mistyped the password in master-password and the slave fails to
# connect), the slave will create a master.info file, and any later
# change in this file to the variables' values below will be ignored and
# overridden by the content of the master.info file, unless you shutdown
# the slave server, delete master.info and restart the slaver server.
# For that reason, you may want to leave the lines below untouched
# (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id = 2
#
# The replication master for this slave - required
#master-host = <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user = <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password = <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port = <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin


# Point the following paths to different dedicated disks
#tmpdir = "/xampp/tmp"
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#bdb_cache_size = 4M
#bdb_max_lock = 10000

# Comment the following if you are using InnoDB tables
#skip-innodb
innodb_data_home_dir = "/xampp/mysql/data"
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = "/xampp/mysql/data"
#innodb_log_arch_dir = "/xampp/mysql/data"
## You can set .._buffer_pool_size up to 50 - 80 %
## of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 16M
innodb_additional_mem_pool_size = 2M
## Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

## UTF 8 Settings
#init-connect=\'SET NAMES utf8\'
#collation_server=utf8_unicode_ci
#character_set_server=utf8
#skip-character-set-client-handshake
#character_sets-dir="/xampp/mysql/share/charsets"

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout


Thanks for your help ^^b
Draelis
 
Posts: 9
Joined: 11. December 2012 10:16
Operating System: 2008 R2

Re: MySql Service won't start automaticaly

Postby hackattack142 » 20. December 2012 18:59

It looks like you need to run the "setup-xampp.bat" in the root /xampp directory to correct the paths.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: MySql Service won't start automaticaly

Postby Draelis » 21. December 2012 08:04

Sorryb but ... nothing to do!


Hem :o!
Draelis
 
Posts: 9
Joined: 11. December 2012 10:16
Operating System: 2008 R2

Re: MySql Service won't start automaticaly

Postby hackattack142 » 22. December 2012 05:02

Could you open the XAMPP Control Panel, go to 'Config' in the upper right corner, check 'Show debug information', Save, restart the control panel, and post the entire control panel log here to give me a bit more information about your environment.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: MySql Service won't start automaticaly

Postby Draelis » 08. January 2013 08:06

I'am sorry but i don't find where the control panel logs was saved !
Draelis
 
Posts: 9
Joined: 11. December 2012 10:16
Operating System: 2008 R2

Re: MySql Service won't start automaticaly

Postby hackattack142 » 08. January 2013 14:27

The log window is the large window at the bottom of the XAMPP Control Panel. You can simply select all and copy it to here after starting the control panel with debug info as stated above.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: MySql Service won't start automaticaly

Postby Draelis » 08. January 2013 14:42

... Okey. <stupid>

14:46:32 [main] Initializing Control Panel
14:46:32 [main] Windows Version: Windows Server 2008 R2 SP1 64-bit
14:46:32 [main] XAMPP Version: 1.8.0
14:46:32 [main] Control Panel Version: 3.0.12 [ Compiled: June 24th 2012 ]
14:46:32 [main] Running with Administrator rights - good!
14:46:32 [main] XAMPP Installation Directory: "d:\xampp\"
14:46:32 [main] Initializing Modules
14:46:32 [apache] Initializing module...
14:46:32 [apache] Checking for service (name="apache2.4"): Service installed
14:46:32 [apache] Service Path: "D:\xampp\apache\bin\httpd.exe" -k runservice
14:46:32 [apache] Checking default ports...
14:46:32 [apache] XAMPP Apache Service is already running on port 81
14:46:32 [apache] XAMPP Apache Service is already running on port 1337
14:46:32 [mysql] Initializing module...
14:46:32 [mysql] Checking for service (name="mysql"): Service not installed
14:46:32 [mysql] Service Path: Service Not Installed
14:46:32 [mysql] Checking default ports...
14:46:32 [mysql] XAMPP MySQL is already running on port 3306
14:46:32 [filezilla] Initializing module...
14:46:32 [filezilla] Checking for service (name="FileZillaServer"): Service not installed
14:46:32 [filezilla] Service Path: Service Not Installed
14:46:32 [filezilla] Checking default ports...
14:46:32 [mercury] Initializing module...
14:46:32 [mercury] Checking default ports...
14:46:32 [tomcat] Initializing module...
14:46:32 [tomcat] Checking for service (name="Tomcat7"): Service not installed
14:46:32 [tomcat] Service Path: Service Not Installed
14:46:32 [tomcat] Checking default ports...
14:46:32 [main] Enabling autostart for module "apache"
14:46:32 [main] Enabling autostart for module "mysql"
14:46:32 [main] Starting Check-Timer
14:46:32 [main] Control Panel Ready
14:46:33 [apache] Autostart active: module is already running - aborted
14:46:33 [mysql] Autostart active: module is already running - aborted


so there it is
Draelis
 
Posts: 9
Joined: 11. December 2012 10:16
Operating System: 2008 R2

Re: MySql Service won't start automaticaly

Postby hackattack142 » 08. January 2013 15:01

Okay, a couple things.

Could you try getting the latest control panel from the link in my signature first.

Next, could you try installing the MySQL service via the Control Panel again and post the log if things are not working correctly still.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests