Problem with Xampp 1.8.1 on window 8 and Magento!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem with Xampp 1.8.1 on window 8 and Magento!

Postby svouras88 » 10. December 2012 23:49

Hello,
I have Xampp 1.8.1 on Windows 8! Firstly, I am trying to install magento, so I moved magento folder inside Xampp's htdocs! Then when I go to 127.0.0.1\magento and I start the installation I have a problem on Configuration step! It says "Database connection error." Why is tha t happening? How can I solve the problem?
Furthermore, when I am trying to import a Sample dada from Magento in phpmyadmin after I have made a new database a have an error:
"No data was received to import. Either no file name was submitted, or the file size exceeded the maximum size permitted by your PHP configuration. See FAQ 1.16[/a]."

What can I do?
Thanks!!
svouras88
 
Posts: 2
Joined: 05. December 2012 17:05
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Problem with Xampp 1.8.1 on window 8 and Magento!

Postby JonB » 11. December 2012 01:46

Well - does phpmyadmin work?
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Problem with Xampp 1.8.1 on window 8 and Magento!

Postby svouras88 » 11. December 2012 01:59

Well, I am not an expert on these stuff but I asume that phpmyadmin works as I can see some other databases already created by default and as I created one of my own in my effort to inport the sample! I created the database just fine and when I tryied to inport the sample in that database there was the error above! So I think phpmyadmin works! :/
svouras88
 
Posts: 2
Joined: 05. December 2012 17:05
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Problem with Xampp 1.8.1 on window 8 and Magento!

Postby JonB » 11. December 2012 03:18

OK - "then" - the problem likely is with your understanding of magneto installation and configuration. If you can get into MySQL via phpMyAdmin, then MySQL is correctly configured (and that is why I asked).

Therefore - While its possible a magneto expert will wander by with a solution, your best resource would be a forum or wiki aimed at magneto support. We do all we can to make a large number of apps/servers work on multiple platforms, but we can't know everything.

or you could Google : database connection error. magento as I just did and get hundreds of links! :shock:

Good Luck
:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Problem with Xampp 1.8.1 on window 8 and Magento!

Postby Altrea » 11. December 2012 06:19

Hi svouras88,

If i read the Magento requirements correctly, there is no support for Apache 2.4.x or PHP 5.4.x yet.
It may work, but if i were you i would stick with an Apache 2.2.x/PHP 5.3.x webserver stack.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6626
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests