Page 1 of 1

xampp keeps crashing [Solved]

PostPosted: 02. December 2012 18:54
by av6330
xampp keeps crashing, windows 7

it's not skype, i unchecked the "use port 80 as an alternative." i even changed the port in xampp to listen:8888, that is port 8888.

i am not using IIS= internet information services.

now i open xampp,

then i try to start mysql and its fine, then when i try to start apache, it always crashes then says,

system error. code 5. access is denied.

access violation at address 005A in module "xampp-control.exe" read of address 00000042 access violation at address 005A in module "xampp-control.exe" read of address 00000042

Re: xampp keeps crashing

PostPosted: 03. December 2012 05:37
by hackattack142
Are you running the control panel as admin?

Re: xampp keeps crashing

PostPosted: 09. December 2012 19:12
by frizi
Hi, working on Win 8 64 bit, the Skype used the same 80 port so there was an apache conflict as I try to stop and start the apache service. Later I've try to change the ports to 81, 444 and 3307 which caused a memory load failure ( xampp access violation at address 005abefe ).

Quitting Skype and reset the ports to the original ones: 80 apache, 443 ssl, 3306 Mysql solved my problems.

Re: xampp keeps crashing [Solved]

PostPosted: 29. March 2013 21:26
by djferano
Hi Guys,

I have had the same problems.
Turned out I had to change httpd.conf and httpd-ssl.conf:

I commented Listen 443 and changed #Listen to
# Note: Configurations that use IPv6 but not IPv4-mapped addresses need two
# Listen directives: "Listen [::]:443" and "Listen"
#Listen [::]:443
#Listen 443

I commented Listen 80 and changed #Listen to
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses.
#Listen [::]:80
#Listen 80

Also if you have skype, disable it or uncheck use port 80 and 443 as alternative...