Apache Keeps Crashing

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Keeps Crashing

Postby Like_A_BossHD » 14. November 2012 14:55

I always get this error every time I start Apache
21:46:08 [Apache] Error: Apache shutdown unexpectedly.
21:46:08 [Apache] This may be due to a blocked port, missing dependencies,
21:46:08 [Apache] improper privileges, a crash, or a shutdown by another method.
21:46:08 [Apache] Check the "/xampp/apache/logs/error.log" file
21:46:08 [Apache] and the Windows Event Viewer for more clues
I changed my port from 80 to 554. It works for at least a week then I tried to start it today, the error shows up. Plz help. I'm hoping to fix the problem before I put my Minecraft server on public. :)

Apache Version 1.8.1
Like_A_BossHD
 
Posts: 4
Joined: 14. November 2012 14:47
Operating System: Windows 8

Re: Apache Keeps Crashing

Postby Perad » 14. November 2012 21:41

I am getting the same problem and also require assistance.

20:37:14 [Apache] Error: Apache shutdown unexpectedly.
20:37:14 [Apache] This may be due to a blocked port, missing dependencies,
20:37:14 [Apache] improper privileges, a crash, or a shutdown by another method.
20:37:14 [Apache] Check the "/xampp/apache/logs/error.log" file
20:37:14 [Apache] and the Windows Event Viewer for more clues


/xampp/apache/logs/error.log is empty

Tried changing the main port to 554 and 1001. No luck there either. Have the latest version of XAMPP which has Apache 2.4

I upgraded to Windows 8 today. Was working find before the update. Have reinstalled XAMPP. Still not working.

Windows8 doesn't have an Event Viewer.
Perad
 
Posts: 14
Joined: 19. August 2008 13:15

Re: Apache Keeps Crashing

Postby Perad » 14. November 2012 21:45

Update.

I ran the XAMPP control panel as an administrator and got a new error.

20:43:24 [Apache] Problem detected!
20:43:24 [Apache] Port 80 in use by "system"!
20:43:24 [Apache] Apache WILL NOT start without the configured ports free!
20:43:24 [Apache] You need to uninstall/disable/reconfigure the blocking application
20:43:24 [Apache] or reconfigure Apache to listen on a different port


I then changed the port to main port for Apache from 80 to 554. I then pressed Start. The console then hung like this.

20:44:14 [Apache] Attempting to start Apache app...


Restarted again.. and it goes back to the original error. I guess this suggests the port isn't the issue? As if it was this port error would show up every time?
Perad
 
Posts: 14
Joined: 19. August 2008 13:15

Re: Apache Keeps Crashing

Postby Perad » 14. November 2012 22:03

Last update.

I installed Apache as a service. Restarted my computer. Then got the following error.

21:01:08 [Apache] Apache Service detected with wrong path
21:01:08 [Apache] Change XAMPP Apache settings or
21:01:08 [Apache] Uninstall/disable the other service manually first
21:01:08 [Apache] Found Path: ERROR: Not Able To Open Service Manager
21:01:08 [Apache] Expected Path: "e:\xampp\apache\bin\httpd.exe" -k runservice


This path is correct. e:\xampp\apache\bin\httpd.exe

I hope something here is relevant to the problem. Also I hope I haven't hijacked this thread. It looked like we both had the same problem so I tried to provide additional information.
Perad
 
Posts: 14
Joined: 19. August 2008 13:15

Re: Apache Keeps Crashing

Postby Like_A_BossHD » 15. November 2012 08:22

I changed the port to 161 and still dosent work :/ I might use the older version of xampp

xampp version 1.8.1 Windows 8
Like_A_BossHD
 
Posts: 4
Joined: 14. November 2012 14:47
Operating System: Windows 8

Re: Apache Keeps Crashing

Postby Perad » 15. November 2012 09:24

I got mine to work.

I completely removed the xampp folder and everything in it. I disabled ISS. I installed xampp again. This fixed the problem. I still get blocked port issues though if say I launch skype before xampp. This didn't happen on Windows7 but its fine.
Perad
 
Posts: 14
Joined: 19. August 2008 13:15

Re: Apache Keeps Crashing

Postby Like_A_BossHD » 15. November 2012 11:26

Whats ISS?
I re installed mine like 5 times. Also delete the xampp folder. and its not working D:
Like_A_BossHD
 
Posts: 4
Joined: 14. November 2012 14:47
Operating System: Windows 8

Re: Apache Keeps Crashing

Postby JJ_Tagy » 15. November 2012 13:54

IIS = Internet Information Services

It is Microsoft's web server. It may be installed as a windows component (includes a service) which is utilizing port 80 (and probably 443).
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: Apache Keeps Crashing

Postby Like_A_BossHD » 15. November 2012 14:14

did you disable yours?
Like_A_BossHD
 
Posts: 4
Joined: 14. November 2012 14:47
Operating System: Windows 8

Re: Apache Keeps Crashing

Postby Perad » 15. November 2012 15:15

I disabled mine.

Open XAMPP control panel. Click on services. Find "World Wide Web Publishing Service". Disable it. Restart.
Perad
 
Posts: 14
Joined: 19. August 2008 13:15

Re: Apache Keeps Crashing

Postby johnnyjosep » 14. May 2013 11:59

Hi,

Try this:

1.- Open Task manager
2.- Search Pando Media Booster
3.- Kill task

In my computer worked, because Pando Media Booster was also using port 443.
johnnyjosep
 
Posts: 1
Joined: 14. May 2013 11:52
Operating System: Windows 8


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 40 guests