startup errors [solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

startup errors [solved]

Postby jimlongo » 08. November 2012 23:43

Hi, I just installed XAMPP 1.8.1 on a new installation of Windows 7 with all the updates. Also installed the Visual Basic C++

When I start the control panel 3.1.0 I get the following startup errors

5:30:52 PM [main] Initializing Control Panel
5:30:52 PM [main] Windows Version: Windows 7 Ultimate SP1 32-bit
5:30:52 PM [main] XAMPP Version: 1.8.1
5:30:52 PM [main] Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
5:30:52 PM [main] You are not running with administrator rights! This will work for
5:30:52 PM [main] most application stuff but whenever you do something with services
5:30:52 PM [main] there will be a security dialogue or things will break! So think
5:30:52 PM [main] about running this application with administrator rights!

5:30:52 PM [main] XAMPP Installation Directory: "c:\xampp\"
5:30:52 PM [main] Checking for prerequisites
5:30:52 PM [main] All prerequisites found
5:30:52 PM [main] Initializing Modules
5:30:52 PM [Apache] Apache Service detected with wrong path
5:30:52 PM [Apache] Change XAMPP Apache settings or
5:30:52 PM [Apache] Uninstall/disable the other service manually first
5:30:52 PM [Apache] Found Path: ERROR: Not Able To Open Service Manager
5:30:52 PM [Apache] Expected Path: "c:\xampp\apache\bin\httpd.exe" -k runservice
5:30:52 PM [Apache] Problem detected!
5:30:52 PM [Apache] Port 8888 in use by "httpd.exe"!
5:30:52 PM [Apache] Apache WILL NOT start without the configured ports free!
5:30:52 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:30:52 PM [Apache] or reconfigure Apache to listen on a different port
5:30:52 PM [Apache] Problem detected!
5:30:52 PM [Apache] Port 443 in use by "httpd.exe"!
5:30:52 PM [Apache] Apache WILL NOT start without the configured ports free!
5:30:52 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:30:52 PM [Apache] or reconfigure Apache to listen on a different port
5:30:52 PM [mysql] MySQL Service detected with wrong path
5:30:52 PM [mysql] Change XAMPP MySQL settings or
5:30:52 PM [mysql] Uninstall/disable the other service manually first
5:30:52 PM [mysql] Found Path: ERROR: Not Able To Open Service Manager
5:30:52 PM [mysql] Expected Path: c:\xampp\mysql\bin\mysqld.exe --defaults-file=c:\xampp\mysql\bin\my.ini mysql
5:30:52 PM [mysql] Problem detected!
5:30:52 PM [mysql] Port 3306 in use by "mysqld.exe"!
5:30:52 PM [mysql] MySQL WILL NOT start without the configured ports free!
5:30:52 PM [mysql] You need to uninstall/disable/reconfigure the blocking application
5:30:52 PM [mysql] or reconfigure MySQL to listen on a different port

5:30:52 PM [main] Enabling autostart for module "Apache"
5:30:52 PM [main] Enabling autostart for module "MySQL"
5:30:52 PM [main] Starting Check-Timer
5:30:52 PM [main] Control Panel Ready
5:30:52 PM [Apache] Autostart aborted: Apache is already running
5:30:52 PM [mysql] Autostart aborted: MySQL is already running

I am not very familiar with Windows (this installation is on a Mac where i run MAMP), but this installation is in a Windows boot volume (no virtualization).

Can someone tell me about the administration privileges, how to enable that, and also about the error messages.

Thanks so much for any help,
jim
XAMPP 1.8.1 / Windows 7 / Netbeans / SQL Server 2008
jimlongo
 
Posts: 2
Joined: 08. November 2012 23:34
Location: tdot
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: startup errors

Postby jimlongo » 09. November 2012 00:24

Okay I uninstalled and reinstalled, changed port 80 and everything "seems" okay for now.

Don't worry, I'm sure I'll have more questions soon.
XAMPP 1.8.1 / Windows 7 / Netbeans / SQL Server 2008
jimlongo
 
Posts: 2
Joined: 08. November 2012 23:34
Location: tdot
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: startup errors [solved]

Postby soul_sucker » 04. February 2013 06:42

Just be reminded when you uninstall XAMPP, please backup your database first.
soul_sucker
 
Posts: 1
Joined: 04. February 2013 06:40
XAMPP Version: 5.6.3
Operating System: windows 7

Re: startup errors [solved]

Postby hackattack142 » 04. February 2013 16:02

Hello,

Grab the latest version of the control panel from the link in my signature. The beta you are using uses an experimental service control method that was not quite ready yet.

As for Admin privileges, they are required to install/uninstall Windows services. You can typically right click an application and run-as Administrator.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests