Default connection

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Default connection

Postby xistyle » 06. November 2012 06:18

Hi,

I've recently encountered this problem. I would like to set which connection does apache/php use to connect remote servers (via curl, smtp... etc).

Here's my situation, I have 2 connections on the XAMPP machine, one of them is local connection with no outgoing blockages, the other is external connection with outgoing blockages. When I try to send mail via pear mail (connecting to port 465), when both connection is on, it is blocked. When I disable the external connection which has outgoing blockages, it works, via the first connection.

I know that this could be a minor issue, and could be solved easily by opening a port, port 465. However, I'm not the admin of the network, so I can't do any tweaks. So is there a way to tell apache/php which connection to use for remote connections?
xistyle
 
Posts: 1
Joined: 06. November 2012 06:07
XAMPP Version: 5.6.3
Operating System: Windows Server 2008 R2

Re: Default connection

Postby Nobbie » 06. November 2012 09:52

xistyle wrote:So is there a way to tell apache/php which connection to use for remote connections?


There is no "unique" port or similar for outgoing connections, the port must be specified by the actual php script. Either in a fsockopen() function call or similar. Some functions or addons (like pear) may use default ports, but there should always be an option to pass another port. Mostly the port is specified as parameter in a function call.
Nobbie
 
Posts: 6799
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 38 guests