Apache won't run - shut down unexpectantly [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't run - shut down unexpectantly [Solved]

Postby Fergal » 01. November 2012 21:00

Edit: Resolved, as per details in post #2.

I installed XAMPP today and I have also installed Microsoft Visual C++ 2008 SP1 Redistributable Package (x86).

Operating System: Windows XP Version 5.1
xampp version: 1.8.1

When I try to run Apache I get the error below;

19:43:30 [Apache] Error: Apache shutdown unexpectedly.
19:43:30 [Apache] This may be due to a blocked port, missing dependencies,
19:43:30 [Apache] improper privileges, a crash, or a shutdown by another method.
19:43:30 [Apache] Check the "/xampp/apache/logs/error.log" file
19:43:30 [Apache] and the Windows Event Viewer for more clues


Service Settings
Service Name: Apache2.4
Main Port: 80
SSL Port: 443

When I click "Netstat" in the CP I get the following info re Ports;
Port: 80
PID: 2584
Name: inetinfo.exe

Port: 443
PID: 2584
Name: inetinfo.exe
(There is other port info, but that seems the most relevant).


All I see at the "/xampp/apache/logs/error.log" is an empty / blank file.

  1. How can I get Apache running?
  2. If I need to change the Service Settings port info, can you please tell me what port numbers I should put in there?
  3. If I need to uninstall another program, can you please tell me which program I need to uninstall?

Many thanks for your help!


Edit
I got the info below from Windows Event Viewer, not sure if it helps;

The Apache service named reported the following error:
>>> apache.exe: Could not open configuration file C:/xampp/apache/conf/httpd.conf: The system cannot find the path specified.
Last edited by Fergal on 02. November 2012 09:59, edited 1 time in total.
Fergal
 
Posts: 2
Joined: 01. November 2012 20:36
Location: Ireland
XAMPP Version: 5.6.3
Operating System: Windows XP Version 5.1

Re: Apache won't run - shut down unexpectantly

Postby Fergal » 02. November 2012 09:59

I have resolved this issue using the suggestions in the "Stop the process blocking port 80" section of this webpage - https://sites.google.com/site/anashkb/port-80-in-use - I have no affiliation with that site, just found it via Google.
Fergal
 
Posts: 2
Joined: 01. November 2012 20:36
Location: Ireland
XAMPP Version: 5.6.3
Operating System: Windows XP Version 5.1


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests