XAMPP 1.8.1 Virtual Hosts

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP 1.8.1 Virtual Hosts

Postby Cipi-Cips » 25. October 2012 19:34

Hello

I really dont know what to do, so I finally find this forum, probably someone can help ?
Problem is I cant create virtual hosts in this new version of XAMPP.

I have red many forums, and threads about making virtual hosts but it seams it is all for older version of XAMPP.

So this is my problem :

I wanna make virtual server called mojdrcina.com, so when I type in my browser mojdrcina.com it should open my web site from my folder.

This is the set up in my HOSTS file in WINDOWS/SYSYTE32/drivers/etc

127.0.0.1 localhost
::1 localhost
127.0.0.1 mojdrcina.com (so I added this line in hosts file)

Now I go configure httpd-vhosts file in my D:/xampp/apache/conf/extra

and at the end of the line I added this

listen 127.0.0.1:80 (I have tried with this line, and without it, same thing)

<VirtualHost *:80>
DocumentRoot D:/xampp/htdocs/
ServerName localhost
</VirtualHost>

<VirtualHost *:80>
ServerName mojdrcina.com
ServerAlias mojdrcina.com
ServerAdmin user@mojdrcina.dev
DocumentRoot D:/xampp/htdocs/ivan
<Directory D:/xampp/htdocs/ivan>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
Require all granted
</Directory>
</VirtualHost>

Then I start XAMPP_control center, and press START on APACHE
Module becomes green and I get msg that apache is working.

now I go to firefox and enter in browser mojdrcina.com I get this: SERVER NOT FOUND
when I enter localhost it opens XAMPP page where I chose language and ect
this is the error log from apache:

[Thu Oct 25 20:15:57.464328 2012] [ssl:warn] [pid 2636:tid 236] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Oct 25 20:15:57.534328 2012] [mpm_winnt:notice] [pid 2636:tid 236] AH00354: Child: Starting 150 worker threads.
Cipi-Cips
 
Posts: 2
Joined: 25. October 2012 19:02
XAMPP Version: 5.6.3
Operating System: win 7

Re: XAMPP 1.8.1 Virtual Hosts

Postby Cipi-Cips » 27. October 2012 13:56

Well thx anyway, but I have managed to solve a problem, it seams HOSTS file in WINDOWS didnt work correctly, so I restore that fail back to original, and just add again hosts file.

thx
Cipi-Cips
 
Posts: 2
Joined: 25. October 2012 19:02
XAMPP Version: 5.6.3
Operating System: win 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 32 guests