MySql port is Free but MySql not running

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySql port is Free but MySql not running

Postby fraka » 22. October 2012 07:51

I have xampp installed in my Windows 7, it has been working well for quite long. Last week Apache and Mysql stopped working and everytime I started them a dialogue of whether to allow or not popped up, something which was not there before. I dicided to put my Xampp in a startup folder to make it run automatically when I start the system, this time Apache started running but not mysql. When I start it, says Mysql has started... but does not show it to be running and does not work. Surprisingly when I check its port(3306) is free.
I am so stack, help plz.
fraka
 
Posts: 2
Joined: 22. October 2012 07:45
XAMPP Version: 1.8.3-1
Operating System: Windows 7

Re: MySql port is Free but MySql not running

Postby Altrea » 22. October 2012 15:32

Hi fraka (there is ALWAYS time for a short salutation, especially if you are asking for help on a volunteer community board and expecting polite replies on your request),

Please try to start the control panel with full administrator rights (rightclick on the control panel icon -> run as administrator). That try to start mysql there.
If this will be successful, you probably have a local user permission issue or Windows 7 UAC issue.

It would be very helpful too to see what is in your \xampp\mysql\data\mysql_error.log.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6474
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: MySql port is Free but MySql not running

Postby fraka » 23. October 2012 10:04

Hi Altrea!!
I have tried to start a control panel with administrative privileges but still bring the same problem. Shows Mysql started but not running.
I am stack, my systems cannot run
fraka
 
Posts: 2
Joined: 22. October 2012 07:45
XAMPP Version: 1.8.3-1
Operating System: Windows 7

Re: MySql port is Free but MySql not running

Postby Altrea » 23. October 2012 16:09

And the contents of the mysql_error.log?
Or should i ask my crystal ball what the problem of your installation is? :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6474
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: MySql port is Free but MySql not running

Postby 1171gurlz » 25. October 2012 07:51

same situation with me:

121025 13:57:43 [Note] Plugin 'FEDERATED' is disabled.
121025 13:57:43 InnoDB: The InnoDB memory heap is disabled
121025 13:57:43 InnoDB: Mutexes and rw_locks use Windows interlocked functions
121025 13:57:43 InnoDB: Compressed tables use zlib 1.2.3
121025 13:57:43 InnoDB: Initializing buffer pool, size = 16.0M
121025 13:57:43 InnoDB: Completed initialization of buffer pool
InnoDB: The first specified data file C:\xampp\mysql\data\ibdata1 did not exist:
InnoDB: a new database to be created!
121025 13:57:43 InnoDB: Setting file C:\xampp\mysql\data\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
121025 13:57:44 InnoDB: Log file C:\xampp\mysql\data\ib_logfile0 did not exist: new to be created
InnoDB: Setting log file C:\xampp\mysql\data\ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
121025 13:57:44 InnoDB: Log file C:\xampp\mysql\data\ib_logfile1 did not exist: new to be created
InnoDB: Setting log file C:\xampp\mysql\data\ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: 127 rollback segment(s) active.
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
121025 13:57:46 InnoDB: Waiting for the background threads to start
121025 13:57:47 InnoDB: 1.1.8 started; log sequence number 0
121025 13:57:53 [Note] Event Scheduler: Loaded 0 events
121025 13:57:53 [Note] c:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.16' socket: '' port: 3306 MySQL Community Server (GPL)
121025 14:02:45 [Note] c:\xampp\mysql\bin\mysqld.exe: Normal shutdown

121025 14:02:47 [Note] Event Scheduler: Purging the queue. 0 events
121025 14:02:52 InnoDB: Starting shutdown...
121025 14:02:57 InnoDB: Shutdown completed; log sequence number 1595675
121025 14:02:57 [Note] c:\xampp\mysql\bin\mysqld.exe: Shutdown complete

121025 14:04:32 [Note] Plugin 'FEDERATED' is disabled.
121025 14:04:32 InnoDB: The InnoDB memory heap is disabled
121025 14:04:32 InnoDB: Mutexes and rw_locks use Windows interlocked functions
121025 14:04:32 InnoDB: Compressed tables use zlib 1.2.3
121025 14:04:32 InnoDB: Initializing buffer pool, size = 16.0M
121025 14:04:32 InnoDB: Completed initialization of buffer pool
121025 14:04:32 InnoDB: highest supported file format is Barracuda.
121025 14:04:33 InnoDB: Waiting for the background threads to start
121025 14:04:34 InnoDB: 1.1.8 started; log sequence number 1595675
121025 14:04:34 [Note] Event Scheduler: Loaded 0 events
121025 14:04:34 [Note] c:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.16' socket: '' port: 3306 MySQL Community Server (GPL)
1171gurlz
 
Posts: 2
Joined: 25. October 2012 07:46
XAMPP Version: 5.6.3
Operating System: windows 7

Re: MySql port is Free but MySql not running

Postby 1171gurlz » 25. October 2012 07:52

how to solve this problem??
1171gurlz
 
Posts: 2
Joined: 25. October 2012 07:46
XAMPP Version: 5.6.3
Operating System: windows 7

Re: MySql port is Free but MySql not running

Postby hackattack142 » 26. October 2012 00:03

@1171gurlz
It looks like your MySQL is running so you will need to be more specific as to what you are trying to do and any error messages you are getting while trying to do that.

@OP
What did you put in the startup folder
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 701
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests