error during installation

Problems with the Windows version of XAMPP, questions, comments, and anything related.

error during installation

Postby cianolu » 19. October 2012 22:39

hello,
in trying to installate the 1.8.1 version of XAMPP I get the following message of error: "error opening for writing C:\filezillaFTP\Filezillaserver.exe". If I ignore the message I can still going on with the installation, but at the end I've got all these messages:
23:34:58 [main] Initializing Control Panel
23:34:58 [main] Windows Version: Windows 7 Home Premium 64-bit
23:34:58 [main] XAMPP Version: 1.8.1
23:34:58 [main] Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
23:34:58 [main] Running with Administrator rights - good!
23:34:58 [main] XAMPP Installation Directory: "c:\xampp\"
23:34:58 [main] Checking for prerequisites
23:34:58 [main] All prerequisites found
23:34:58 [main] Initializing Modules
23:34:58 [Apache] Problem detected!
23:34:58 [Apache] Port 80 in use by "system"!
23:34:58 [Apache] Apache WILL NOT start without the configured ports free!
23:34:58 [Apache] You need to uninstall/disable/reconfigure the blocking application
23:34:58 [Apache] or reconfigure Apache to listen on a different port
23:34:58 [mysql] Problem detected!
23:34:58 [mysql] Port 3306 in use by "c:\apache\mysql\bin\mysqld.exe"!
23:34:58 [mysql] MySQL WILL NOT start without the configured ports free!
23:34:58 [mysql] You need to uninstall/disable/reconfigure the blocking application
23:34:58 [mysql] or reconfigure MySQL to listen on a different port
23:34:58 [filezilla] Problem detected!
23:34:58 [filezilla] Port 21 in use by "filezillaserver.exe"!
23:34:58 [filezilla] FileZilla WILL NOT start without the configured ports free!
23:34:58 [filezilla] You need to uninstall/disable/reconfigure the blocking application
23:34:58 [filezilla] or reconfigure FileZilla to listen on a different port
23:34:58 [filezilla] Problem detected!
23:34:58 [filezilla] Port 14147 in use by "filezillaserver.exe"!
23:34:58 [filezilla] FileZilla WILL NOT start without the configured ports free!
23:34:58 [filezilla] You need to uninstall/disable/reconfigure the blocking application
23:34:58 [filezilla] or reconfigure FileZilla to listen on a different port
23:34:58 [main] The Mercury module is disabled
23:34:58 [main] The Tomcat module is disabled
23:34:58 [main] Starting Check-Timer
23:34:58 [main] Control Panel Ready

Any ideas how may i solve the problem?

Thanks a lot

Luciano
cianolu
 
Posts: 3
Joined: 19. October 2012 22:27
XAMPP Version: 5.6.3
Operating System: windows 7

Re: error during installation

Postby tracysmorton » 20. October 2012 08:17

Try rebooting and then making Google your default browser before you launch XAMPP.

I had similar errors when I had Mozilla as my default browser. I uninstalled and reinstalled thinking that was the problem. When I changed the default browser, it worked. I hope this works for you.
tracysmorton
 
Posts: 1
Joined: 20. October 2012 08:11
XAMPP Version: 5.6.3
Operating System: vista 32 bit

Re: error during installation

Postby cianolu » 20. October 2012 23:27

I've got already Chrome as default browser, so maybe this is not the cause.
Thanks
luciano
cianolu
 
Posts: 3
Joined: 19. October 2012 22:27
XAMPP Version: 5.6.3
Operating System: windows 7

Re: error during installation

Postby cianolu » 21. October 2012 00:10

It continue to give such an error:

Problem detected!
01:04:47 [Apache] Port 80 in use by "system"!
01:04:47 [Apache] Apache WILL NOT start without the configured ports free!
01:04:47 [Apache] You need to uninstall/disable/reconfigure the blocking application
01:04:47 [Apache] or reconfigure Apache to listen on a different port

I don't know how to do it.

good night (for me it's 01:10 a.m)
cianolu
 
Posts: 3
Joined: 19. October 2012 22:27
XAMPP Version: 5.6.3
Operating System: windows 7

Re: error during installation

Postby Altrea » 21. October 2012 01:42

Hi cianolu,

Two things:
You need to clear your Port 80 issue.
In many cases this port would be blocked by a Windows service called world-wide-web publishing (or WWW-publishing) or a part of the IIS Webserver component.
So try to find and stop that windows service and/or uninstall IIS in the windows components dialog, if you don't need it.

second thing: why is MySQL started from C:\apache\ and your XAMPP install path is C:\xampp\? Have you moved something?
Maybe it is needed to execute the setup_xampp.bat file again to change the paths of the components to the current path.

best wishes,
Altrea

P.S.:
@tracysmorton:
tracysmorton wrote:Try rebooting and then making Google your default browser before you launch XAMPP.

That would in no way effect any blocked ports, so how should that solve that issue?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6834
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests