XAMPP 1.7.7 how to load local php.ini

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP 1.7.7 how to load local php.ini

Postby MonReveur » 18. October 2012 03:32

I have a website that is hosted on a Linux server running Apache 2.2 and PHP 5.2.17 as CGI and has a local php.ini file. For the life of me, I cannot get XAMPP 1.7.7 to load the local php.ini on my Windows 7 computer. I downloaded mod_fcgid-2.3.7-win32.zip and extracted the appropriate file into the C:/XAMPP/Apache/Modules folder. I added these lines to httpd.conf:

Code: Select all
LoadModule fcgid_module modules/mod_fcgid.so
<IfModule mod_fcgid>
   FcgidInitialEnv PHPRC "c:/xampp/php"
   FcgidInitialEnv PATH "c:/xampp/php;C:/Windows/system32;C:/Windows;C:/Windows/system32/wbem;C:/Windows/System32/WindowsPowerShell/v1.0;C:/Ruby193/bin"
   FcgidInitialEnv SystemRoot "C:/Windows"
   FcgidInitialEnv SystemDrive "C:"
   FcgidInitialEnv TEMP "C:/Users/Ed/AppData/Local/Temp"
   FcgidInitialEnv TMP "C:/Users/Ed/AppData/Local/Temp"
   FcgidInitialEnv windir "C:/Windows"
   FcgidInitialEnv PHP_FCGI_MAX_REQUESTS 500
   FcgidMaxProcesses 15
   FcgidIOTimeout 64
   FcgidIdleTimeout 64
   FcgidConnectTimeout 16
   FcgidMaxRequestsPerProcess 500
   <Files ~ "\.php$">
      AddHandler fcgid-script .php
      FcgidWrapper "c:/xampp/php/php-cgi.exe" .php

phpinfo() says it's still running as Apache but mod_fcgid is loaded. Yet it didn't load the local php.ini file. Then I found a post that mentioned commenting out the following lines from httpd-xampp.conf:

Code: Select all
#LoadFile "C:/xampp/php/php5ts.dll"
#LoadModule php5_module "C:/xampp/php/php5apache2_2.dll"

But now I get the following error when I click on the "Admin" button after restarting Apache: "Something is wrong with the XAMPP installation :-("
Posts: 4
Joined: 21. September 2012 02:26
XAMPP Version: 5.6.3
Operating System: Windows 7

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 82 guests