Problem Apache HTTP Server has stopped working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem Apache HTTP Server has stopped working

Postby Mosiah16 » 12. October 2012 00:22

Hello, I have this problem when I try to post a new topic in my forum Board IP version, when I click on post new topic, Apache Server stops working on my server.

Here the error.log

Code: Select all
 [Thu Oct 11 20:17:19 2012] [notice] Digest: generating secret for digest authentication ...
[Thu Oct 11 20:17:19 2012] [notice] Digest: done
[Thu Oct 11 20:17:20 2012] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9 configured -- resuming normal operations
[Thu Oct 11 20:17:20 2012] [notice] Server built: Dec 10 2008 00:10:06
[Thu Oct 11 20:17:20 2012] [notice] Parent: Created child process 4720
[Thu Oct 11 20:17:21 2012] [notice] Digest: generating secret for digest authentication ...
[Thu Oct 11 20:17:21 2012] [notice] Digest: done
[Thu Oct 11 20:17:22 2012] [notice] Child 4720: Child process is running
[Thu Oct 11 20:17:22 2012] [notice] Child 4720: Acquired the start mutex.
[Thu Oct 11 20:17:22 2012] [notice] Child 4720: Starting 250 worker threads.
[Thu Oct 11 20:17:22 2012] [notice] Child 4720: Starting thread to listen on port 443.
[Thu Oct 11 20:17:22 2012] [notice] Child 4720: Starting thread to listen on port 80.
[Thu Oct 11 20:17:22 2012] [warn] (OS 64)El nombre de red especificado ya no está disponible.  : winnt_accept: Asynchronous AcceptEx failed.
[Thu Oct 11 20:17:22 2012] [error] [client 188.99.178.170] File does not exist: C:/xampp/htdocs/template/default/images/nav_bg.jpg, referer: http://www.muhordesofchaos.com/index.php?page_id=login
[Thu Oct 11 20:17:22 2012] [error] [client 188.99.178.170] File does not exist: C:/xampp/htdocs/template/default/images/nav_hover_bg.gif, referer: http://www.muhordesofchaos.com/index.php?page_id=login
[Thu Oct 11 20:17:23 2012] [error] [client 188.99.178.170] File does not exist: C:/xampp/htdocs/template/default/images/nav_bg.jpg, referer: http://www.muhordesofchaos.com/index.php?page_id=user_cp&panel=unstuck_character
[Thu Oct 11 20:17:24 2012] [error] [client 188.99.178.170] File does not exist: C:/xampp/htdocs/template/default/images/nav_hover_bg.gif, referer: http://www.muhordesofchaos.com/index.php?page_id=user_cp&panel=unstuck_character
[Thu Oct 11 20:17:26 2012] [error] [client 188.99.178.170] File does not exist: C:/xampp/htdocs/template/default/images/nav_bg.jpg, referer: http://www.muhordesofchaos.com/index.php?page_id=user_cp&panel=reset_character
[Thu Oct 11 20:17:26 2012] [error] [client 188.99.178.170] File does not exist: C:/xampp/htdocs/template/default/images/nav_hover_bg.gif, referer: http://www.muhordesofchaos.com/index.php?page_id=user_cp&panel=reset_character
[Thu Oct 11 20:17:29 2012] [error] [client 188.99.178.170] File does not exist: C:/xampp/htdocs/template/default/images/nav_bg.jpg, referer: http://www.muhordesofchaos.com/index.php?page_id=user_cp&panel=reset_character&rid=9983
[Thu Oct 11 20:17:30 2012] [error] [client 188.99.178.170] File does not exist: C:/xampp/htdocs/template/default/images/nav_hover_bg.gif, referer: http://www.muhordesofchaos.com/index.php?page_id=user_cp&panel=reset_character&rid=9983
[Thu Oct 11 20:18:43 2012] [error] [client 200.111.225.202] File does not exist: C:/xampp/htdocs/foro/public/js/ips.recentTopicsHook.js, referer: http://foro.hordesofchaos.org/index.php
[Thu Oct 11 20:18:43 2012] [error] [client 200.111.225.202] script 'C:/xampp/htdocs/foro/error.php' not found or unable to stat, referer: http://foro.hordesofchaos.org/index.php
[Thu Oct 11 20:19:25 2012] [notice] Parent: child process exited with status 3221225725 -- Restarting.
[Thu Oct 11 20:19:25 2012] [notice] Digest: generating secret for digest authentication ...
[Thu Oct 11 20:19:25 2012] [notice] Digest: done


I have not changed anything in the last few hours, suddenly began to happen.

Help please and thank you very much.
Mosiah16
 
Posts: 1
Joined: 12. October 2012 00:10
XAMPP Version: 1.8.2-4
Operating System: Windows Server 2008

Re: Problem Apache HTTP Server has stopped working

Postby JonB » 15. October 2012 21:59

[Thu Oct 11 20:17:22 2012] [warn] (OS 64)El nombre de red especificado ya no está disponible. : winnt_accept: Asynchronous AcceptEx failed.

The above is likely at the heart of the issue -

you can try this -

The resolution to the above problem is to disable the use of AcceptEx by using Win32DisableAcceptEx directive. Win32DisableAcceptEx only available in Apache version 2.0.49 and later version though.

Win32DisableAcceptEx directive should be place in httpd.conf configuration file. If you are using distribution from apachefriend’s xampp, the directive should be placed at httpd.conf file too, and not the httpd-mpm configuration file. The directive can be placed together with the line of #EnableMMAP off and #EnableSendfile off in httpd.conf.

If you still facing issue after enable the Win32DisableAcceptEx directive, try to uncomment (disable) the EnableMMAP and EnableSendfile directive. The line should looks like this:

EnableMMAP off
EnableSendfile off
Win32DisableAcceptEx

http://www.mydigitallife.info/winnt_acc ... pache-log/

A. What version of XAMPP are you running?

B. Its possible your forum is incorrectly configured.
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests