localhost keeps on loading, how to fix it? [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

localhost keeps on loading, how to fix it? [Solved]

Postby SoundLightWaves » 22. September 2012 22:36

this happened for me yesterday

everything was running fine

( i had set all properly from Skype, etc. )

and suddenly the localhost just keeps on loading, and apache cannot start at all

i reinstalled xampp many times
i rebooted with apache & xampp as a service
i do not have any adobe apps in the startmenu
i uninstalled skype

and now with xampp 1.8 the very same thing

how can i get a tool, or a program that will know what needs to be fixed with apache?

i tried netstat already, and port 80 was used by windows 7 and that is all the info it would give me
SoundLightWaves
 
Posts: 4
Joined: 22. September 2012 20:37
XAMPP Version: 5.5.19
Operating System: Windows 7 64

Re: localhost keeps on loading, how to fix it?

Postby JonB » 23. September 2012 17:15

what is in the Apache error log?

\xampp\apache\logs\error.log
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: localhost keeps on loading, how to fix it?

Postby SoundLightWaves » 23. September 2012 22:05

JonB wrote:what is in the Apache error log?

\xampp\apache\logs\error.log


thank you

there is no error log
SoundLightWaves
 
Posts: 4
Joined: 22. September 2012 20:37
XAMPP Version: 5.5.19
Operating System: Windows 7 64

Re: localhost keeps on loading, how to fix it?

Postby JonB » 24. September 2012 00:00

there is no error log


That means that APache cannot launch at all - not that it 'almost' there. (so, by not being present, it is telling us something)

You should try using the Netstat button to see if both ports 80 & 443 are free.

In the same order of thinking there should be an exception in your firewall for httpd.exe in whatever folder your xampp\apache is installed in

For instance, on this machine that is : C:\xampp\apache\bin

Its also possible that an OS error is preventing it from running.

Check the Windows Event Viewer, Applications and System logs.

I'm betting on port-blocking by a firewall, but its just a guess.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: localhost keeps on loading, how to fix it?

Postby SoundLightWaves » 24. September 2012 01:58

JonB wrote:
there is no error log


That means that APache cannot launch at all - not that it 'almost' there. (so, by not being present, it is telling us something)

You should try using the Netstat button to see if both ports 80 & 443 are free.

In the same order of thinking there should be an exception in your firewall for httpd.exe in whatever folder your xampp\apache is installed in

For instance, on this machine that is : C:\xampp\apache\bin

Its also possible that an OS error is preventing it from running.

Check the Windows Event Viewer, Applications and System logs.

I'm betting on port-blocking by a firewall, but its just a guess.

Good Luck
8)


thank you,

i changed some of the settings, through following your guidance, and now it is working

your intuition on the firewall must have been right
SoundLightWaves
 
Posts: 4
Joined: 22. September 2012 20:37
XAMPP Version: 5.5.19
Operating System: Windows 7 64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests