XAMPP - 1.7.3 - Various issues

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP - 1.7.3 - Various issues

Postby loozx » 12. September 2012 10:21

Hi guys,

I'm currently hosting a website through Windows 2003 using XAMPP 1.7.3. I've never had to access Xampps settings until now as I'm in the process of migrating. If I go to XAMPP's control panel I get the following error:

Code: Select all
Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\xampp\index.php(1) : eval()'d code:7) in C:\xampp\htdocs\xampp\langsettings.php on line 13


Also when I go to PHPMyadmin to backup our wordpress database it gives another error, all it says is : '; var opendb_url = '

Does anyone have an idea where I'm going wrong?

Thanks
loozx
 
Posts: 7
Joined: 12. September 2012 10:18
Operating System: Windows 2003

Re: XAMPP - 1.7.3 - Various issues

Postby loozx » 13. September 2012 08:23

Bump :D
loozx
 
Posts: 7
Joined: 12. September 2012 10:18
Operating System: Windows 2003

Re: XAMPP - 1.7.3 - Various issues

Postby JJ_Tagy » 13. September 2012 11:31

Are you trying to access the page through Internet Explorer while logged in as the administrator? If so, double check the security settings aren't set too high to allow php file access.

What language are you using? What are the contents of /htdocs/xampp/lang.tmp? Do those two match?
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: XAMPP - 1.7.3 - Various issues

Postby loozx » 13. September 2012 11:41

Thanks for the reply,

I'm using EN and logging in as administrator with IE 8. I've check and couldnt find a lang.tmp but i found lang.php which directs itself to a notepad file in my install folder which justs says EN.

Thanks
loozx
 
Posts: 7
Joined: 12. September 2012 10:18
Operating System: Windows 2003

Re: XAMPP - 1.7.3 - Various issues

Postby JJ_Tagy » 13. September 2012 12:05

Not sure if Server 2k3 is the same as 2k8, but they inherently add high security to IE when logged on as the adminstrator. Most likely it is blocking php file access and javascript from running. That is probably why it never wrote a lang.tmp. Maybe log in as a user with admin rights instead of administrator - or you could drop the restrictions in IE for the adminstrator.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: XAMPP - 1.7.3 - Various issues

Postby loozx » 13. September 2012 13:40

Hmm I've checked that & it's still not working even though I'm letting everything through. The website is still being hosted & ran OK, I've used the phpmyadmin before and apache to setup the site originally but a year on it's not working & I can't work out why :/
loozx
 
Posts: 7
Joined: 12. September 2012 10:18
Operating System: Windows 2003

Re: XAMPP - 1.7.3 - Various issues

Postby JonB » 13. September 2012 19:11

Did you configure that folder with write in NTFS?
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: XAMPP - 1.7.3 - Various issues

Postby loozx » 17. September 2012 10:23

Yep :(, I really can't workout where I'm going wrong - Any more suggestions would be appreciated!
loozx
 
Posts: 7
Joined: 12. September 2012 10:18
Operating System: Windows 2003

Re: XAMPP - 1.7.3 - Various issues

Postby JJ_Tagy » 17. September 2012 12:30

Maybe in IE, add localhost to the trusted sites and intranet to see if it will bypass restrictions? Then I would clear cache/cookies and try again.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: XAMPP - 1.7.3 - Various issues

Postby loozx » 17. September 2012 13:27

Already done :(
loozx
 
Posts: 7
Joined: 12. September 2012 10:18
Operating System: Windows 2003

Re: XAMPP - 1.7.3 - Various issues

Postby JonB » 17. September 2012 18:38

I think you might have a problem with line endings. If the source files were edited or created on a Linux/unix station, they might EOL conversion in an editor to get them right. I just went through this with some Perl. :shock:

Just a guess.
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: XAMPP - 1.7.3 - Various issues

Postby loozx » 18. September 2012 07:51

No Linux or Unix station has touched the files so I can't see that being the problem :/. Out of sheer desperation I looked in the event viewer and saw this little gem!

Faulting application httpd.exe, version 2.2.1.4.0, fauling module php5ts.dll, version 5.3.1.0, fault address 0x000c08a.

I've googled the error but it's all over my head apart from the suggestions of updating php but isn't that included in xampp?

Thanks
loozx
 
Posts: 7
Joined: 12. September 2012 10:18
Operating System: Windows 2003


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests