Multi-curl not working in Xampp 1.8?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Multi-curl not working in Xampp 1.8?

Postby cpollett » 11. September 2012 07:05

Hi,

I have a php script (seekquarry.com to download) that makes use of both curl and multi-curl. I am trying to test to
get it to work under xampp 1.8 on Windows. It was working under xampp 1.7.7. It currently seems to be failing
because multi-curl requests are returning nothing. This script also makes use of curl requests which seem to work.
I was wondering if anyone had run into this?

Best,
Chris
cpollett
 
Posts: 2
Joined: 11. September 2012 06:52
Operating System: Windows

Re: Multi-curl not working in Xampp 1.8?

Postby cpollett » 15. September 2012 08:42

So looking at this again. I was able to modify my multi-curl code in a minor way to get things to work.
The php documentation on multi-curl is somewhat opaque, so I am still not sure what exactly
is going on. Here is a block that caused no headaches in Xampp 1.7.7:
Code: Select all
do {
            $mrc = curl_multi_exec($agent_handler, $running);
            $ready=curl_multi_select($agent_handler, 0.015);
        } while (time() - $start < PAGE_TIMEOUT &&  $running > 0 && $ready!=-1);

changing this to
Code: Select all
do {
            $mrc = curl_multi_exec($agent_handler, $running);
            $ready=curl_multi_select($agent_handler, 0.015);
        } while (time() - $start < PAGE_TIMEOUT &&  $running > 0 );

got it to work in Xampp 1.8. Removing the curl_multi_select() line through breaks
things. So maybe the issue is somehow curl_multi_select has changed in PHP 5.4?
cpollett
 
Posts: 2
Joined: 11. September 2012 06:52
Operating System: Windows


Return to XAMPP for Windows

Who is online

Users browsing this forum: Gharas and 65 guests