Administrator rights [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Administrator rights [Solved]

Postby xamppbill » 30. August 2012 14:28

I got an error on the XAMPP Control Panel that says "You are not running with administrator rights. This will work for most application stuff but whenever you do something with services there will be a security dialogue or things will break! So think about running this application with administrator rights!"
I uninstalled xampp and reinstalled, getting v1.8.0
I am logged into my computer with administrator rights. I am the only person who has ever logged into this computer. I have always had administrator rights.
I have been using phpmyadmin, MySql, and PHP for a couple of months without problem. Now I can start Apache, but not phpmyadmin.
When I type http://localhost into my browser I get the correct screen but when I click on phpmyadmin I get "#2002 An attempt was made to access a socket in a way forbidden by its access permissions. The server is not responding (or the local server's socket is not correctly configured). Connection for controluser as defined in your configuration failed."
Can anyone help please?
xamppbill
 
Posts: 5
Joined: 30. August 2012 14:07
Operating System: windows 7

Re: Administrator rights

Postby JonB » 30. August 2012 21:45

Hi xamppbill,
As Altrea would point out - its always polite to start with a salutation

I will deal with 'one issue' for now the matter of administrator: (which is probably not why you can't access phpmyadmin)

I have always had administrator rights.


Actually you are sort of wrong - On XP that would have been true in many cases, as you really had only two 'types' of users without getting into Policy control "Computer Administrator" and "Limited'. In Windows 7 (& Vista), there is a difference between the 'Administrators Group' (there are other User Groups also) and the actual account 'administrator' which is disabled by default. SOOO - unless when you go to login you see a Win 7 Welcome screen with a User named "Administrator' - and your 'installation name' - and you login as administrator - you need that 'run as' context option to do a variety of things.

Quick way to activate Administrator:

Command Prompt > (Run as administrator)
net user administrator /active:yes

http://www.petri.co.il/enable-the-windo ... ccount.htm

That is worth trying to see if it 'fixes' you, but I don't think its the issue. If it does fix it, please let me know. The we can add that to 'have you tried'.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Administrator rights

Postby xamppbill » 31. August 2012 09:08

Hi JonB,

Thanks for the technical and etiquette help. It is my first post so I'll improve!
I followed your advice and enabled the Administrator account. Then I logged in as Administrator. The first error message about not being administrator has now gone, however, it didn't fix the main problem. I still get error 2002 when I try to start phpmyadmin (as you predicted).

Any other suggestions?
Regards,
xamppbill
xamppbill
 
Posts: 5
Joined: 30. August 2012 14:07
Operating System: windows 7

Re: Administrator rights

Postby JonB » 31. August 2012 21:03

OK xamppbill -

It is likely a problem with config.inc.php

A. When you go to http://localhost/xampp, do all the examples (other than FreeType) work correctly?

B. have you made any changes to the installation, or install any scripts/applications?

C. Did you run the XAMPP Security script?

D. Where did you install XAMPP?

Thanks
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Administrator rights

Postby xamppbill » 01. September 2012 05:11

Hi JonB,

Thanks for the follow-up. In response to your questions:
A. When I go to http://localhost/xampp I can run everything ok except phpmyadmin.
B. No. I just did the standard installation.
C. No. I've looked at http://localhost/security/xamppsecurity.php but it says that I need to get the mysql server running first.
D. c:\xampp

I've just thought of something else. When activting Apache a dialog box always came up asking if it was ok for it to access the internet. I used to always click on "Allow". However, one time I clicked "Disallow" and it never asked again. Since then I have this problem running phpmyadmin. Perhaps this is not related??

Cheers,
xamppbill
xamppbill
 
Posts: 5
Joined: 30. August 2012 14:07
Operating System: windows 7

Re: Administrator rights

Postby xamppbill » 01. September 2012 06:30

....continued.......
I've just had another thought! The error message says that the problem is with socket 3306's access permissions. This is consistent with the fact that I totally uninstalled xampp from my compuiter, then reinstalled it, yet tthe problem remains.
How do I check / reconfigure the permissions on socket 3306 under Windows 7?

Thank-you,
xamppbill.
xamppbill
 
Posts: 5
Joined: 30. August 2012 14:07
Operating System: windows 7

Re: Administrator rights

Postby JonB » 01. September 2012 14:57

C. No. I've looked at http://localhost/security/xamppsecurity.php but it says that I need to get the mysql server running first.
...
I've just thought of something else. When activting Apache a dialog box always came up asking if it was ok for it to access the internet. I used to always click on "Allow". However, one time I clicked "Disallow" and it never asked again. Since then I have this problem running phpmyadmin. Perhaps this is not related??

The error message says that the problem is with socket 3306's access permissions.


all relevant.

I need to get the mysql server running first MySQL is not running, (or wasn't when you got the message)

When activting Apache a dialog box always came up asking if it was ok for it to access the internet.I used to always click on "Allow". However, one time I clicked "Disallow" and it never asked again.

It wouldn't, you told it to bar Apache - it took you at your word.

The error message says that the problem is with socket 3306's access permissions. Its probably blocked by your firewall

What shows in XAMPP Control Panel? Two green 'running' lights for Apache & MySQL, or nothing?

We also need a look in Windows Control Panel > Windows Firewall or whatever AV/Firewall tool you have - Make sure there are exceptions for these programs:
httpd
mysqd

or

c:\xampp\apache\bin\httpd.exe
c:\xampp\mysql\bin\mysqld,exe

You should be able to find their paths, through edit or properties. If they aren't there you can add them manually.

This is most likely the problem.

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Administrator rights

Postby xamppbill » 02. September 2012 06:24

Hello JonB,

I use a proprietory firewall. So I looked in its program permissions for Apache, and it was blocked, as you predicted. So I changed the setting to full access and everything works fine now.
Thank-you thank-you for your expertise and perseverence!
:D
Regards, xamppbill
xamppbill
 
Posts: 5
Joined: 30. August 2012 14:07
Operating System: windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 81 guests