xampp for Windows (re: vhosts)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp for Windows (re: vhosts)

Postby jimlequia » 28. August 2012 20:52

I have been attempting to set up my home server to accomodate 2 urls (www.name1.com) and (www.name2.com)
I have configured httpd.conf
Listen 80

Leaving the ServerRoot "C:/xampp/apache"
if I set up 1 eg;

ServerName www.name1.com

DocumentRoot "C:/jlnetwork"

<Directory "C:/jlnetwork">

The server finds the correct index.html and runs.

But if I try to setup multiple hosts it doesn't work

The second ServerName would be www.name2.com

DocumentRoot "C:/scnetwork"

<Directory "C:/scnetwork">

for httpd-vhosts.conf

NameVirtualHost *:80

<VirtualHost *:80>
ServerAdmin webmaster@localhost.com
DocumentRoot "C:/jlnetwork"
ServerName www.name1.com
ServerAlias www.name1.com
</VirtualHost>

<VirtualHost *80>
ServerAdmin webmaster@localhost.com
DocumentRoot "C:/scnetwork"
ServerName www.name2.com
ServerAlias www.name2.com
</VirtualHost>

is there something else that needs addressing ? After I get this save I can not get the server online.

I have a DNS for both of the URL which is identical. I have tried many variations but have not been able to resolve.

Any suggestions or direction would be appreciated
jimlequia
 
Posts: 1
Joined: 28. August 2012 18:40
Operating System: Windows XP Pro, Windows Vista

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 73 guests