MySQL and Apache not running

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQL and Apache not running

Postby Sculley » 23. August 2012 17:48

I'm trying to run WP locally on my machine. It used to work just fine but it has been several years since I've started it up.

When I open xampp-control.exe and click "start" for Apache and MySQL in the bottom it says "started" for both services but it doesn't say running at the top next to "Apache" and "MySQL". Then, when I go to localhost in my browser I get an error message (Oops! Google Chrome could not connect to localhost or Firefox can't establish a connection to the server at localhost.). What am I doing wrong?

I checked the xampp-portcheck.exe and all ports are free.

Thanks so much in advance.
Sculley
 
Posts: 6
Joined: 17. February 2009 00:59

Re: MySQL and Apache not running

Postby JonB » 23. August 2012 20:03

It surely would be useful to know the XAMPP version.

:?:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: MySQL and Apache not running

Postby Sculley » 24. August 2012 03:42

Sorry.....version 1.7.3
Sculley
 
Posts: 6
Joined: 17. February 2009 00:59

Re: MySQL and Apache not running

Postby JonB » 24. August 2012 11:34

You should look in the Apache error log for starters. \xampp\apache\logs\error_log.txt

Other considerations - did you install new AV/Firewall software?

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: MySQL and Apache not running

Postby Sculley » 24. August 2012 12:32

It's strange...the error log only has errors from 2010.

I turned off my AV program (BitDefender) but it still doesn't work.
Sculley
 
Posts: 6
Joined: 17. February 2009 00:59

Re: MySQL and Apache not running

Postby JonB » 24. August 2012 15:28

The 'empty' error log - That means Apache is not starting at all

What Windows version are you using?

Look in your Windows event viewer System log to see if anything is crashing.

You might want to DL the latest XAMPP Control Panel. AFAIK it should work with your version OK. It has much better diagnostics.

you can DL it here" http://xampp.statusnull.com/CPv3/CPv3.0.11.7z

Copy the files into your XAMPP folder & fire up. It may actually tell you what is wrong.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: MySQL and Apache not running

Postby Sculley » 24. August 2012 15:46

I'm using Windows 7.

I tried DLing the latest version the other day but it didn't install correctly. There was no control.exe so I tried the old one. The control at least starts up.

Okay, let me try copying the files into folder.
Sculley
 
Posts: 6
Joined: 17. February 2009 00:59

Re: MySQL and Apache not running

Postby Sculley » 24. August 2012 15:49

Just downloaded the files you suggested. Still not running. Both services say "Starting apache service..." but next to them it's not saying "running" and localhost in browser still an error.

Not sure where the Windows event viewer system log is?
Sculley
 
Posts: 6
Joined: 17. February 2009 00:59

Re: MySQL and Apache not running

Postby JonB » 24. August 2012 17:20

My computer > right click, manage > Event Viewer > WIndows logs

Good luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests