Dropbox setup - but not relative enough? - RESOLVED

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Dropbox setup - but not relative enough? - RESOLVED

Postby andrewc » 22. August 2012 20:42

Hi Guys,

Total Xampp newbie here but loving the setup, I have used it a bit a few years back and the easy setup for one computer is amazing.

What I set out to do today though was to get it working in dropbox with wordpress so I could do some local dev work. To do this I used the USB version hoping the preset relative paths would do the trick. I messed around with my computer at work and got it all up and running fine in a dropbox folder and was very excited. The only thing I had to change was to comment out ssl part that I found on here earlier as that was prevent MySQL working.

So all excited about my mobile dev platform I tried it at home, unfortunately when I tried it on my laptop I just couldn't get it working :x

I ran the setup_xampp and it said it was all fine and gave me the correct relative path which is different as my computer at work is on a domain so the user path is different to my home laptop.

When I tried to run apache_start I got an error saying:

httpd.exe: Syntax error on line 35 of C:/Users/Andrew/Dropbox/Private/DevTesting/xampp/apache/conf/httpd.conf: ServerRoot must be a valid directory

So I opened up the conf file in Notepad and edited this down from similar to

ServerRoot "/Users/username.domain/Dropbox/Private/DevTesting/xampp/apache"

to

ServerRoot "apache"

I also tried some other stuff but in the end I got a new error of:

AH00526: Syntax error on line 191 of C:/Users/Andrew/Dropbox/Private/DevTesting/xampp/apache/conf/httpd.conf: DocumentRoot must be a directory

Now I had changed the original directory path from:

DocumentRoot "/Users/username.domain/Dropbox/Private/DevTesting/xampp/htdocs"

to

DocumentRoot "htdocs"

And I also tried a few other varieties with a bit more of the path.

Not quite sure where I'm going wrong here and if anyone could offer anything to try that would be really appreciated.

Regards

Andrew


EDIT: I decided to start again with this but did a few things a little different.

I new folder in my dropbox folder called "dev" - the first time around I initially called the folder "Dev Testing" and then renamed it to "DevTesting" which may have caused some of the problems?

I then download the 7z lite/USB version, unzipped it and then copied it all into my dev folder - instead of using the .exe to 'install' to a the folder.

I made changes as mentioned above to the listen ports, server IP and commented out the bind to 443 thing.

On the first computer I ran the setup_xampp file and then ran using xampp_start and check it all worked fine, installed wordpress and checked that worked fine too. Once done I used xampp_stop to shut it all down.

Once dropbox has synced on the next computer I tried to run apache_start and got the same error as before so ran setup_xampp and was given the option to refresh references so did that then tried to run apache_start again and it worked fine.

Since then I've repeated on 4 different computers and providing I use setup_xampp each time to refresh references before running apache_start it all seems to work fine :D

How robust it is I'm not sure or whether I should create any alternative sets of config files or something like that I don't know :?:

For the time being though providing I follow the above steps it all works great - thanks to the xampp guys for making it so easy - even for a newbie :D
andrewc
 
Posts: 1
Joined: 22. August 2012 20:20
Operating System: Windows 7

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests