[solved]Second VHost no longer working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[solved]Second VHost no longer working

Postby cajn » 21. August 2012 22:50

I have an XAMPP server up and running. I am using VHOST with name based hosting. I had set up two websites initially with no issues. All of a sudden today, the second website will no longer resolve. I am unsure where to go from here but I get this error in Apache and in windows event viewer:

[Tue Aug 21 16:07:56 2012] [error] (OS 11004)The requested name is valid, but no data of the requested type was found. : Could not resolve host name http://www.cajncomputerservices.com -- ignoring!

Not sure how to troubleshoot this or where to look next.
I cannot ping that web address but I can ping the first web address and outside IP address with no issues.

Any help is appreciated.
cajn
 
Posts: 6
Joined: 21. August 2012 22:45
Operating System: Windows 7 Pro

Re: Second VHost no longer working

Postby JonB » 22. August 2012 13:38

Could not resolve host name http://www.cajncomputerservices.com -- ignoring!


Nameserver problem perhaps?
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Second VHost no longer working

Postby cajn » 22. August 2012 13:47

How would I go about discovering if this is the issue? My domain is through eNOM and I am using their name servers and pointing it to my web server.
cajn
 
Posts: 6
Joined: 21. August 2012 22:45
Operating System: Windows 7 Pro

Re: Second VHost no longer working

Postby JonB » 22. August 2012 14:43

I just did an nslookup - your domain is mis-configured in some fashion.

these pages should help you get things sorted. You probably need to contact your registrar's help desk and get your DNS fixed

http://who.is/whois/cajncomputerservices.com/

You do not appear to have an 'A' record set for your webhost (www)
http://who.is/dns/cajncomputerservices.com/

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Second VHost no longer working

Postby cajn » 22. August 2012 15:51

JonB wrote:I just did an nslookup - your domain is mis-configured in some fashion.

these pages should help you get things sorted. You probably need to contact your registrar's help desk and get your DNS fixed

http://who.is/whois/cajncomputerservices.com/

You do not appear to have an 'A' record set for your webhost (www)
http://who.is/dns/cajncomputerservices.com/

Good Luck
8)



Thank you for pointing me in the right direction. The DNS settings were indeed incorrect. How do we mark this as solved?
cajn
 
Posts: 6
Joined: 21. August 2012 22:45
Operating System: Windows 7 Pro

Re: Second VHost no longer working

Postby Altrea » 22. August 2012 16:49

cajn wrote:How do we mark this as solved?

done. Thank you for the feedback 8)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 28 guests