pear problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

pear problem

Postby helpcomm » 20. August 2012 07:55


Just installed xampp latest version for windows (win7, xampp control panel v3.0.12).

Whe i run pear list-all i have the following error message:
pear list-all
WARNING: channel "" has updated its protocols, use "pear channel-upd
ate" to update
SECURITY ERROR: Will not write to C:\Users\me\AppData\Local\Temp\pear\cache\e9b8
8593398eb69a9ff91042351d646arest.cacheid as it is symlinked to C:\Users\me\AppDa
ta\Local\Temp\pear\cache\e9b88593398eb69a9ff91042351d646arest.cacheid - Possible
symlink attack

I cannot install phpunit either.

Posts: 5
Joined: 03. September 2011 21:55

Re: pear problem

Postby mike_dowler » 20. August 2012 11:53

I think I am having a similar problem.

Running pear config-show gives:
Code: Select all
Auto-discover new Channels     auto_discover    <not set>
Default Channel                default_channel
HTTP Proxy Server Address      http_proxy       <not set>
PEAR server [DEPRECATED]       master_server
Default Channel Mirror         preferred_mirror
Remote Configuration File      remote_config    <not set>
PEAR executables directory     bin_dir          C:\xampp\php
PEAR documentation directory   doc_dir          C:\php\pear\docs
PHP extension directory        ext_dir          C:\xampp\php\ext
PEAR directory                 php_dir          C:\xampp\php\pear
PEAR Installer cache directory cache_dir        C:\Users\Mike\AppData\Local\Temp
PEAR configuration file        cfg_dir          C:\php\pear\cfg
PEAR data directory            data_dir         C:\php\pear\data
PEAR Installer download        download_dir     C:\Users\Mike\AppData\Local\Temp
PHP CLI/CGI binary             php_bin          C:\xampp\php\.\php.exe
php.ini location               php_ini          <not set>
--program-prefix passed to     php_prefix       <not set>
PHP's ./configure
--program-suffix passed to     php_suffix       <not set>
PHP's ./configure
PEAR Installer temp directory  temp_dir         C:\Users\Mike\AppData\Local\Temp
PEAR test directory            test_dir         C:\php\pear\tests
PEAR www files directory       www_dir          C:\php\pear\www
Cache TimeToLive               cache_ttl        3600
Preferred Package State        preferred_state  stable
Unix file mask                 umask            0
Debug Log Level                verbose          1
PEAR password (for             password         <not set>
Signature Handling Program     sig_bin          c:\gnupg\gpg.exe
Signature Key Directory        sig_keydir       C:\Windows\pearkeys
Signature Key Id               sig_keyid        <not set>
Package Signature Type         sig_type         gpg
PEAR username (for             username         <not set>
User Configuration File        Filename         C:\Windows\pear.ini
System Configuration File      Filename         C:\Windows\pearsys.ini

You can see that a number of folders are set to be located within C:\php (which doesn't exist). Also the configuration files are set to be located within C:\Windows, and therefore don't exist (Win7 won't allow writing in this folder). I can't change any of the settings, because the config files are not accessible, and I don't know how to set up a new config file in the correct location (i.e. within the XAMPP folder). Can anyone help?

Apologies if this is not the same issue, and I have just hijacked this thread!
Thx, Mike
Posts: 1
Joined: 20. August 2012 11:29
Operating System: Windows 7 x64

Re: pear problem

Postby JonB » 20. August 2012 17:35

Well sorta different -

Did you use the XAMPP-shell button in Control Panel? It creates a proper environment table. Try that. Nothing in XAMPP is 'really' installed, its all command line calls


Good Luck
User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 80 guests