Problem [Apparently Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem [Apparently Solved]

Postby xeNium » 13. August 2012 15:53

Condition on personal computer:
XAMPP 1.7.7 (Success - Apache and MySQL is working)
XAMPP 1.8.0 (Success - Apache and MySQL is working, but not with phpMyAdmin)

MySQL said: Documentation
#2002 - No connection could be made because the target machine actively refused it.

The server is not responding (or the local server's socket is not correctly configured).
Connection for controluser as defined in your configuration failed.

10:00:28 PM [main] Initializing Modules
10:00:28 PM [apache] XAMPP Apache is already running on port 80
10:00:28 PM [apache] XAMPP Apache is already running on port 443
10:00:28 PM [mysql] XAMPP MySQL Service is already running on port 3306
10:00:28 PM [main] Starting Check-Timer
10:00:28 PM [main] Control Panel Ready

Operation System: Windows XP Professional SP 3

Condition on server computer:
XAMPP 1.7.1 (Success - Apache and MySQL is working) - This after the server computer get corrupted and reinstalled.
XAMPP 1.7.7 (Success - Apache and MySQL is working) - This before the server computer get corrupted and reinstalled after reinstalled XAMPP 1.7.7 (Failed - Apache is not working but MySQL is working, and phpMyAdmin is not working too because Apache is not working)
XAMPP 1.8.0 (Failed - Apache is not working but MySQL is working, and phpMyAdmin is not working too because Apache is not working) - This after the server computer get corrupted and reinstalled.
10:04:22 PM [main] Initializing Control Panel
10:04:22 PM [main] Windows Version: Windows Server 2008 R2 SP1 64-bit
10:04:22 PM [main] XAMPP Version: 1.8.0
10:04:22 PM [main] Control Panel Version: 3.0.12 [ Compiled: June 24th 2012 ]
10:04:22 PM [main] Running with Administrator rights - good!
10:04:22 PM [main] XAMPP Installation Directory: "c:\xampp\"
10:04:22 PM [main] Initializing Modules
10:04:22 PM [mysql] XAMPP MySQL Service is already running on port 3306
10:04:22 PM [main] Enabling autostart for module "apache"
10:04:22 PM [main] Enabling autostart for module "mysql"
10:04:22 PM [main] Starting Check-Timer
10:04:22 PM [main] Control Panel Ready
10:04:22 PM [apache] Autostart active: starting...
10:04:22 PM [apache] Starting apache service...
10:04:23 PM [mysql] Autostart active: module is already running - aborted

Operation System: Windows Server 2008 R2 Enterprise

Image
xeNium
 
Posts: 7
Joined: 13. August 2012 15:46
XAMPP Version: 1.8.2-3
Operating System: Windows Server 2008 R2 Enterpr

Re: Problem

Postby hackattack142 » 13. August 2012 22:00

It appears you are missing the Visual C++ runtimes required to run it.

If you have 1.8.0, could I ask you to try something:

Try copying (not cutting) 'msvcr90.dll' from '/xampp/php' to '/xampp/apache/bin' and see if that fixes the issue. Report back if that works and I will convey that information to the devs for the next beta.

If not, you need these: www.microsoft.com/en-us/download/details.aspx?id=5582
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Problem

Postby xeNium » 14. August 2012 12:38

hackattack142 wrote:It appears you are missing the Visual C++ runtimes required to run it.

If you have 1.8.0, could I ask you to try something:

Try copying (not cutting) 'msvcr90.dll' from '/xampp/php' to '/xampp/apache/bin' and see if that fixes the issue. Report back if that works and I will convey that information to the devs for the next beta.

If not, you need these: http://www.microsoft.com/en-us/download/details.aspx?id=5582


Personal computer problem is fixed now but server problem is still not fixed.
'msvcr90.dll' is copied to '/xampp/apache/bin' from '/xampp/php' (Personal computer and server)

Miscrosoft Visual C++ 2010 Redistributable x64 and Miscrosoft Visual C++ 2008 Redistributable x64 is installed before the problem exist but there something weird, Miscrosoft Visual C++ 2008 Redistributable x64 Size only 700+ KB (Installer: 4+ MB)

I download it officialy from Microsoft.com, I think they are corrupted eh?

New problem

Strict Standards: Non-static method vB_Shutdown::instance() should not be called statically, assuming $this from incompatible context in D:\Elements - 2011\xampp\xampp\htdocs\forum\includes\class_core.php on line 3314

Strict Standards: Declaration of vB_Database_Alter_MySQL::drop_index() should be compatible with vB_Database_Alter::drop_index() in C:\xampp\htdocs\forum\includes\class_dbalter.php on line 882

Strict Standards: Declaration of vB_Database_Alter_MySQL::add_index() should be compatible with vB_Database_Alter::add_index() in C:\xampp\xampp\htdocs\forum\includes\class_dbalter.php on line 882

Strict Standards: Declaration of vB_Database_Alter_MySQL::add_field() should be compatible with vB_Database_Alter::add_field() in C:\xampp\xampp\htdocs\forum\includes\class_dbalter.php on line 882

Strict Standards: Declaration of vB_Database_Alter_MySQL::drop_field() should be compatible with vB_Database_Alter::drop_field() in C:\xampp\xampp\htdocs\forum\includes\class_dbalter.php on line 882

Strict Standards: Declaration of vB_Database_Alter_MySQL::query() should be compatible with vB_Database_Alter::query() in C:\xampp\xampp\htdocs\forum\includes\class_dbalter.php on line 882


I know vBulletin isn't part of Apachefriends but It all because I update it to 1.8.0 What happen !! Aaaa. Well it's not a problem the problem only come from personal computer (Server and server website are not in same server machines) I just use it on my personal computer for emergency problem to check what happen but well that not a big problem for me.
xeNium
 
Posts: 7
Joined: 13. August 2012 15:46
XAMPP Version: 1.8.2-3
Operating System: Windows Server 2008 R2 Enterpr

Re: Problem

Postby JonB » 14. August 2012 14:28

It is most likely a PHP version issue. It could also be a reporting level issue in php.ini. Check with vBulletin on their PHP compatibility.

You should always match PHP and MySQL as close as possible between local and live versions. For XAMPP, this means using a version that has roughly the same PHP major version - In my case I use XAMPP 1.7.7 with PHP 5.3.8 to match my VPS. Any new projects run on a VM that has 1.8.0 - which has many many changes in both packages, Apache (2.4.2 Major) & PHP (5.4.4 Major). Apache 2.4.2 is not widely installed yet on web services, as it has many many changes at fundamental levels, and webhosts don't want to 'break things'.

Good Luck with your project.
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Problem

Postby xeNium » 14. August 2012 17:39

JonB wrote:It is most likely a PHP version issue. It could also be a reporting level issue in php.ini. Check with vBulletin on their PHP compatibility.

You should always match PHP and MySQL as close as possible between local and live versions. For XAMPP, this means using a version that has roughly the same PHP major version - In my case I use XAMPP 1.7.7 with PHP 5.3.8 to match my VPS. Any new projects run on a VM that has 1.8.0 - which has many many changes in both packages, Apache (2.4.2 Major) & PHP (5.4.4 Major). Apache 2.4.2 is not widely installed yet on web services, as it has many many changes at fundamental levels, and webhosts don't want to 'break things'.

Good Luck with your project.
8)


Well, I am not a PHP or MySQL (Expert). I will try to do it then.
xeNium
 
Posts: 7
Joined: 13. August 2012 15:46
XAMPP Version: 1.8.2-3
Operating System: Windows Server 2008 R2 Enterpr

Re: Problem

Postby Altrea » 14. August 2012 19:32

xeNium wrote:Well, I am not a PHP or MySQL (Expert). I will try to do it then.

Sometimes Google will help too.

Searching for "vBulletin PHP 5.4" give me this result:
https://www.vbulletin.com/forum/showthr ... 86-Php-5-4

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6610
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Problem

Postby hackattack142 » 15. August 2012 01:47

If copying that file over did not fix your Apache starting on your server, you need to install the Visual C++ 2008 x86 runtimes from the link I provided earlier. The x64 runtimes will not fix your issue in this case.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Problem

Postby Ragnarok210 » 15. August 2012 07:19

I had a similar problem earlier, when I did a multiple installation with XAMPP 1.8.0. As I was doing the setting, I had to start and stop the services multiple time. For while there, the service can't stop or start, or atleast it didn't said it was starting or stopping. Then I was having some problem with the php, and had to reinstall again. Afterward, I am getting some of the errors you're getting.

To completely fix my problem, I had to fully uninstall the XAMPP, including the registry and all the remaining file in C drive (that's where i installed), and reinstall it again. It runs normal, phpmyadmin works fine, but my php script doesn't work, so I went back to 1.7.7 :D. Try again some where in the future.
Ragnarok210
 
Posts: 9
Joined: 15. August 2012 03:47
XAMPP Version: 5.5.19
Operating System: Window 7

Re: Problem

Postby xeNium » 15. August 2012 14:10

Altrea wrote:
xeNium wrote:Well, I am not a PHP or MySQL (Expert). I will try to do it then.

Sometimes Google will help too.

Searching for "vBulletin PHP 5.4" give me this result:
https://www.vbulletin.com/forum/showthread.php/405286-Php-5-4

best wishes,
Altrea


As (I) said before, I can't start the Apache.

hackattack142 wrote:If copying that file over did not fix your Apache starting on your server, you need to install the Visual C++ 2008 x86 runtimes from the link I provided earlier. The x64 runtimes will not fix your issue in this case.


Oh, really? Thanks for the information I will try it.
Bytheway Is that the latest version?

Ragnarok210 wrote:I had a similar problem earlier, when I did a multiple installation with XAMPP 1.8.0. As I was doing the setting, I had to start and stop the services multiple time. For while there, the service can't stop or start, or atleast it didn't said it was starting or stopping. Then I was having some problem with the php, and had to reinstall again. Afterward, I am getting some of the errors you're getting.

To completely fix my problem, I had to fully uninstall the XAMPP, including the registry and all the remaining file in C drive (that's where i installed), and reinstall it again. It runs normal, phpmyadmin works fine, but my php script doesn't work, so I went back to 1.7.7 :D. Try again some where in the future.


I think the solution is not that because the apache not want to be started from the beginning after (I) reinstall the computer Operation System. I think hackattack142 solution is seem to be true.
xeNium
 
Posts: 7
Joined: 13. August 2012 15:46
XAMPP Version: 1.8.2-3
Operating System: Windows Server 2008 R2 Enterpr

Re: Problem

Postby JonB » 15. August 2012 17:32

@ XeNium -

OK _ I am lost at this point -

A. If Apace is not running, how in the world did you get these errors?

Strict Standards: Non-static method vB_Shutdown::instance() should not be called statically, assuming $this from incompatible context in D:\Elements - 2011\xampp\xampp\htdocs\forum\includes\class_core.php on line 3314

Strict Standards: Declaration of vB_Database_Alter_MySQL::drop_index() should be compatible with vB_Database_Alter::drop_index() in C:\xampp\htdocs\forum\includes\class_dbalter.php on line 882

Strict Standards: Declaration of vB_Database_Alter_MySQL::add_index() should be compatible with vB_Database_Alter::add_index() in C:\xampp\xampp\htdocs\forum\includes\class_dbalter.php on line 882

Strict Standards: Declaration of vB_Database_Alter_MySQL::add_field() should be compatible with vB_Database_Alter::add_field() in C:\xampp\xampp\htdocs\forum\includes\class_dbalter.php on line 882


B - Yes, hackattack is right - only the 32 bit version will help (he is the one who figures these things out here) There is a 'sticky' that gives the right link
viewtopic.php?f=16&t=51021

So - at this time is Apache starting or not??

:?:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Problem

Postby xeNium » 16. August 2012 07:18

JonB wrote:@ XeNium -

OK _ I am lost at this point -

A. If Apace is not running, how in the world did you get these errors?

Strict Standards: Non-static method vB_Shutdown::instance() should not be called statically, assuming $this from incompatible context in D:\Elements - 2011\xampp\xampp\htdocs\forum\includes\class_core.php on line 3314

Strict Standards: Declaration of vB_Database_Alter_MySQL::drop_index() should be compatible with vB_Database_Alter::drop_index() in C:\xampp\htdocs\forum\includes\class_dbalter.php on line 882

Strict Standards: Declaration of vB_Database_Alter_MySQL::add_index() should be compatible with vB_Database_Alter::add_index() in C:\xampp\xampp\htdocs\forum\includes\class_dbalter.php on line 882

Strict Standards: Declaration of vB_Database_Alter_MySQL::add_field() should be compatible with vB_Database_Alter::add_field() in C:\xampp\xampp\htdocs\forum\includes\class_dbalter.php on line 882


B - Yes, hackattack is right - only the 32 bit version will help (he is the one who figures these things out here) There is a 'sticky' that gives the right link
http://community.apachefriends.org/f/viewtopic.php?f=16&t=51021

So - at this time is Apache starting or not??

:?:


A: It's my personal computer, the personal computer problem is solved in this case but server problem is not solved yet (Now the server problem is solved now) vBulletin problem is in my personal computer, it because the PHP they do not recommended PHP 5.5 but 5.4 thats why the problem exist.
B: Apache in this case cannot be activated (Now it can be activated) I already use my latest 32-bit Microsoft Visual C++ 2008 and 2010 and now the Apache can be started.
xeNium
 
Posts: 7
Joined: 13. August 2012 15:46
XAMPP Version: 1.8.2-3
Operating System: Windows Server 2008 R2 Enterpr

Re: Problem [Apparently Solved]

Postby SharpSabre » 27. September 2012 22:34

First Open "Config.php" and then Add this :
Code: Select all
ini_set("display_errors", "0");

then open "Class_Core.php" and edit Line 3314 :
Code: Select all
$this->shutdown = vB_Shutdown::instance();

Change to this :
Code: Select all
$this->shutdown =@ vB_Shutdown::instance();


Good Luck !
SharpSabre
 
Posts: 1
Joined: 27. September 2012 22:25
XAMPP Version: 5.6.3
Operating System: w8


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests