new install of xammp MYSQL starts then stops

Problems with the Windows version of XAMPP, questions, comments, and anything related.

new install of xammp MYSQL starts then stops

Postby jigmeurgyen » 08. August 2012 09:36

I just pulled down a new XAMP, put it on d:\ tried to start everything and msql errors. Here is the log ... any suggestions?

120808 14:17:19 [Note] Plugin 'FEDERATED' is disabled.
d:\xampp\mysql\bin\mysqld.exe: File '.\mysql\plugin.MYD' not found (Errcode: 2)
d:\xampp\mysql\bin\mysqld.exe: Can't find file: 'plugin' (errno: 2)
120808 14:17:19 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
120808 14:17:19 InnoDB: The InnoDB memory heap is disabled
120808 14:17:19 InnoDB: Mutexes and rw_locks use Windows interlocked functions
120808 14:17:19 InnoDB: Compressed tables use zlib 1.2.3
120808 14:17:20 InnoDB: Initializing buffer pool, size = 16.0M
120808 14:17:20 InnoDB: Completed initialization of buffer pool
120808 14:17:20 InnoDB: highest supported file format is Barracuda.
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
120808 14:17:20 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
120808 14:17:20 InnoDB: Waiting for the background threads to start
120808 14:17:21 InnoDB: 1.1.8 started; log sequence number 1595675
120808 14:17:21 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
120808 14:17:21 [Note] - '0.0.0.0' resolves to '0.0.0.0';
120808 14:17:21 [Note] Server socket created on IP: '0.0.0.0'.
120808 14:17:21 [ERROR] Fatal error: Can't open and lock privilege tables: File '.\mysql\host.MYD' not found (Errcode: 2)
jigmeurgyen
 
Posts: 2
Joined: 08. August 2012 09:34
Operating System: win7

Re: new install of xammp MYSQL starts then stops

Postby jigmeurgyen » 09. August 2012 07:03

So solve this, the mysql config file had the data directory set one level higher than it should have been xammp\mqsql\data should have been xammp\mqsql\data\mysql

I then copied another .MYD file, changed its name to host.MYD and delete any contents using notepad.

I think tried to start it and got another error 120809 11:38:24 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist

Go back an edit the config to poiint the data directory at xammp\mqsql\data save.

Now ok.
jigmeurgyen
 
Posts: 2
Joined: 08. August 2012 09:34
Operating System: win7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests