Taking lot of time to load or sometime not even load

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Taking lot of time to load or sometime not even load

Postby rameshd33 » 08. August 2012 09:18

hi,

I am using xamp 1.7.4 in windows server 2008 R2 standard. we are using xampp for 6 months without any problems.

Suddenly today, when i checked our server named ( www.sketchwfriends.com) taking lot of time load.

and sometimes its not loading.. Even http:\\localhost\phpmyadmin also takes lot of time..

So i checked error.log, i found following lines,

[Wed Aug 08 00:11:15 2012] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Wed Aug 08 00:11:15 2012] [notice] Server built: Oct 18 2010 01:58:12
[Wed Aug 08 00:11:15 2012] [notice] Parent: Created child process 9252
[Wed Aug 08 00:11:15 2012] [notice] Digest: generating secret for digest authentication ...
[Wed Aug 08 00:11:15 2012] [notice] Digest: done
[Wed Aug 08 00:11:17 2012] [notice] Child 9252: Child process is running
[Wed Aug 08 00:11:17 2012] [notice] Child 9252: Acquired the start mutex.
[Wed Aug 08 00:11:17 2012] [notice] Child 9252: Starting 150 worker threads.
[Wed Aug 08 00:11:17 2012] [notice] Child 9252: Starting thread to listen on port 443.
[Wed Aug 08 00:11:17 2012] [notice] Child 9252: Starting thread to listen on port 80.



And also the windows event viewer reported a crash. following is the report.

Faulting application name: httpd.exe, version: 2.2.17.0, time stamp: 0x4cbbe9e8
Faulting module name: php5ts.dll, version: 5.3.5.0, time stamp: 0x4d26013e
Exception code: 0xc0000005
Fault offset: 0x0000c5c6
Faulting process id: 0x140a8
Faulting application start time: 0x01cd753902cbb69b
Faulting application path: D:\xampp\apache\bin\httpd.exe
Faulting module path: D:\xampp\php\php5ts.dll
Report Id: 42a7a4dc-e12c-11e1-ba86-d067e5ecc52e


So please reply as soon as possible.. because our server was a live server.. where many people comes on line..

If it down for long.. we loose our product..


Thanks,
Ramesh
rameshd33
 
Posts: 2
Joined: 08. August 2012 09:07
Operating System: Windows server 2008 R2

Re: Taking lot of time to load or sometime not even load

Postby Altrea » 08. August 2012 12:59

Hi rameshd33,

rameshd33 wrote:please reply as soon as possible.. because our server was a live server.. where many people comes on line..

If it down for long.. we loose our product..

I just can tell you, that XAMPP is not made for production environments.
If you use it as a live server, it is your own fault.
Normally you are on your own now.

XAMPP 1.7.4 was a really buggy XAMPP release. I wouldn't recommend to use this version for any environments.

rameshd33 wrote:And also the windows event viewer reported a crash. following is the report.

Faulting application name: httpd.exe, version: 2.2.17.0, time stamp: 0x4cbbe9e8
Faulting module name: php5ts.dll, version: 5.3.5.0, time stamp: 0x4d26013e
Exception code: 0xc0000005
Fault offset: 0x0000c5c6
Faulting process id: 0x140a8
Faulting application start time: 0x01cd753902cbb69b
Faulting application path: D:\xampp\apache\bin\httpd.exe
Faulting module path: D:\xampp\php\php5ts.dll
Report Id: 42a7a4dc-e12c-11e1-ba86-d067e5ecc52e


Have you changed something in the php.ini? especially activating php modules?
A common problem of that version was, that the runtime libraries between apache and php can produce some incompatibilities.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Taking lot of time to load or sometime not even load

Postby rameshd33 » 08. August 2012 18:17

No i didnt activated any modules.. it run smoothly until yesterday.

Only From today onwards, this problem arised.. Any good solution ?
rameshd33
 
Posts: 2
Joined: 08. August 2012 09:07
Operating System: Windows server 2008 R2

Re: Taking lot of time to load or sometime not even load

Postby Altrea » 08. August 2012 18:31

rameshd33 wrote:Only From today onwards, this problem arised.. Any good solution ?

If there is no trigger / change it should still run smoothly.
So no, without knowing what has changed, there can't be a good solution for your problem.
You can try to google your error with your Fault offset value from the windows event message. Maybe you can find something.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 28 guests