Xampp used to work yesterday now i'm hopeless

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp used to work yesterday now i'm hopeless

Postby legas » 07. August 2012 16:33

Hi members!

I'm busy making a phpbb forum.
Before i would put it online i wanted to test it and complete it offline. On a 'home server'
So I used Xampp!

I made a new folder named 'forum' inside my htdocs, so i could go to the url: localhost/forum

I don't know much about Xampp so please help me, i came to this problem:
Yesterday everything went good, I installed the forum, made some major changes to it etc.
There was a database made in phpmyadmin etc. Inside phpmyadmin on the left side there were alot of maps, (databases I think)

Today I wanted to continue, i start Xampp, and when I typed localhost/forum I got this error:
SQL ERROR [ mysqli ]
Access denied for user ''@'localhost' to database 'forum' [1044]
An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

When I got to localhost/phpmyadmin i can only see 2 maps (databases) on the left side.
So there is something wrong, but I really can't figure out what could be wrong.
Can anybody please help me?

Posts: 2
Joined: 07. August 2012 16:31
Operating System: windows 7

Re: Xampp used to work yesterday now i'm hopeless

Postby JonB » 08. August 2012 03:01

XAMPP is still working - you have a script problem


That's NOT a quote before @'localhost' that's TWO single quotes wiht nothing in between i..e. a null username.

There is the issue - the username is not defined. I have no idea of exactly what is wrong but it is likely the config file for phpBB,

You should check on their support forum for help.

Good luck
User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 72 guests