can't read japanese messages from mysql( not all)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

can't read japanese messages from mysql( not all)

Postby july009 » 06. August 2012 07:07

Hi all.
I'm in a trouble with the japanese messages from mysql.

mysql outputs some unreadable japanese messages.

e.g.
<quote>
[root:rensyu](9) > create table todofuken4 select * from todofuken;
Query OK, 7 rows affected (0.05 sec)
繝ャ繧ウ繝シ繝画焚: 7 驥崎、・焚: 0 Warnings: 0
</quote>
->the last massage should be :
レコード数: 7 重複: 0 Warnings: 0

<quote>
[root:rensyu](4) > update todofuken5 set ken_name='新潟県';
Query OK, 7 rows affected (0.04 sec)
荳€閾エ謨ー(Rows matched): 8 螟画峩: 7 Warnings: 0
</quote>
->the last message should be:
一致数(Rows matched): 8 変更: 8 Warnings: 0


I think there are more.
these messages are output as UTF-8 while i'm using Shift-JIS.

someone please tell me how to fix this.

don't hesitate to ask information about my environment ,etc...

T.I.A.

below are my environments:
os:windows 7 professional sp 1 (32bit)
xamp:1.7.7

result of status command:
[root:db1](20) > status
--------------
mysql Ver 14.14 Distrib 5.5.16, for Win32 (x86)

Connection id: 1
Current database: db1
Current user: root@localhost
SSL: Not in use
Using delimiter: ;
Server version: 5.5.16 MySQL Community Server (GPL)
Protocol version: 10
Connection: localhost via TCP/IP
Server characterset: sjis
Db characterset: sjis
Client characterset: cp932
Conn. characterset: cp932
TCP port: 3306
Uptime: 1 hour 18 min 3 sec

Threads: 1 Questions: 26 Slow queries: 0 Opens: 45 Flush tables: 1 Open tab
les: 2 Queries per second avg: 0.005
--------------

result of 'show variables like 'char%';':
[root:db1](21) > show variables like 'char%';
+--------------------------+--------------------------------+
| Variable_name | Value |
+--------------------------+--------------------------------+
| character_set_client | cp932 |
| character_set_connection | cp932 |
| character_set_database | sjis |
| character_set_filesystem | binary |
| character_set_results | cp932 |
| character_set_server | sjis |
| character_set_system | utf8 |
| character_sets_dir | C:\xampp\mysql\share\charsets\ |
+--------------------------+--------------------------------+
8 rows in set (0.00 sec)


my.ini:
# Example MySQL config file for small systems.
#
# This is for a system with little memory (<= 64M) where MySQL is only used
# from time to time and it's important that the mysqld daemon
# doesn't use much resources.
#
# You can copy this file to
# C:/xampp/mysql/bin/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is C:/xampp/mysql/data) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
# password = your_password
port = 3306
socket = "C:/xampp/mysql/mysql.sock"
default-character-set = sjis

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port= 3306
socket= "C:/xampp/mysql/mysql.sock"
basedir="C:/xampp/mysql"
tmpdir="C:/xampp/tmp"
datadir="C:/xampp/mysql/data"
pid_file="mysql.pid"
skip-external-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M
log_error="mysql_error.log"
character-set-server = sjis
#skip-character-set-client-handshake
#append on aug.2.2012 please comment out below line if you want japanese error message.
language = "C:/xampp/mysql/share/japanese"



# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
#
# commented in by lampp security
#skip-networking
skip-federated

# Replication Master Server (default)
# binary logging is required for replication
# log-bin deactivated by default since XAMPP 1.4.11
#log-bin=mysql-bin

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id = 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
# the syntax is:
#
# CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
# MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
# where you replace <host>, <user>, <password> by quoted strings and
# <port> by the master's port number (3306 by default).
#
# Example:
#
# CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
# MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
# start replication for the first time (even unsuccessfully, for example
# if you mistyped the password in master-password and the slave fails to
# connect), the slave will create a master.info file, and any later
# change in this file to the variables' values below will be ignored and
# overridden by the content of the master.info file, unless you shutdown
# the slave server, delete master.info and restart the slaver server.
# For that reason, you may want to leave the lines below untouched
# (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id = 2
#
# The replication master for this slave - required
#master-host = <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user = <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password = <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port = <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin


# Point the following paths to different dedicated disks
#tmpdir = "C:/xampp/tmp"
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#bdb_cache_size = 4M
#bdb_max_lock = 10000

# Comment the following if you are using InnoDB tables
#skip-innodb
innodb_data_home_dir = "C:/xampp/mysql/data"
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = "C:/xampp/mysql/data"
#innodb_log_arch_dir = "C:/xampp/mysql/data"
## You can set .._buffer_pool_size up to 50 - 80 %
## of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 16M
innodb_additional_mem_pool_size = 2M
## Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M
default-character-set = sjis

[mysql]
no-auto-rehash
default-character-set = sjis
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout
july009
 
Posts: 2
Joined: 06. August 2012 06:36
Operating System: Windows 7 professional 32bit

Re: can't read japanese messages from mysql( not all)

Postby JonB » 06. August 2012 11:49

I hope someone may answer your question - However this is 100% a MySQL issue and has 0% to do with XAMPP.

MySQL has its own support community plus there are forums that cater to databases & programming like Daniweb

http://forums.mysql.com/

http://www.daniweb.com/

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: can't read japanese messages from mysql( not all)

Postby july009 » 08. August 2012 04:51

Thanks. I'll ask them ,too.
july009
 
Posts: 2
Joined: 06. August 2012 06:36
Operating System: Windows 7 professional 32bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests