New computer, old local websites starts with errors [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

New computer, old local websites starts with errors [Solved]

Postby chiefbum » 02. August 2012 13:23

hello gutten tag (good day),

my xampp version is 3.0.12
my windows is 7 64 bit

The problem is i have transferred my xampp files and htdocs to the new computer... xampp services such as apache, mysql, filezilla are running and started. But when i type into the web browser for example: website.localhost.com, My joomla local website (version 1.7, version 2.5) wont start properly and i get lots of error messages such as:


Strict Standards: Declaration of JParameter::loadSetupFile() should be compatible with JRegistry::loadSetupFile() in C:\xampp\htdocs\gem\libraries\joomla\html\parameter.php on line 512

Strict Standards: Only variables should be assigned by reference in C:\xampp\htdocs\gem\plugins\system\nonumberelements\nonumberelements.php on line 18

Strict Standards: Only variables should be assigned by reference in C:\xampp\htdocs\gem\plugins\system\nonumberelements\nonumberelements.php on line 21

Strict Standards: Only variables should be assigned by reference in C:\xampp\htdocs\gem\plugins\system\nonumberelements\nonumberelements.php on line 47

Strict Standards: Only variables should be assigned by reference in C:\xampp\htdocs\gem\plugins\system\jat3\jat3.php on line 41

Strict Standards: Only variables should be assigned by reference in C:\xampp\htdocs\gem\plugins\system\setgeneratortag\setgeneratortag.php on line 40

Strict Standards: Non-static method JAT3_AdminUtil::checkPermission() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\gem\plugins\system\jat3\jat3.php on line 166

Strict Standards: Only variables should be assigned by reference in C:\xampp\htdocs\gem\plugins\system\sh404sef\sh404sef.php on line 147

Strict Standards: Non-static method T3Common::detect() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\gem\plugins\system\jat3\jat3.php on line 85

Strict Standards: Non-static method T3Path::path() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\gem\plugins\system\jat3\jat3\core\common.php on line 69


it was running fine on the old computer but not on the new. Old version was also running the same os type (windows 7 64 bit) but not sure the xampp version but most probably version 3.0, at least.

I have updated the hosts file to include the 127.0.0.1 mywebsite.localhost.com

httpd-vhosts.conf also has:

NameVirtualHost *:80
<VirtualHost *:80>
DocumentRoot "c:/xampp/htdocs"
ServerName localhost
</VirtualHost>
<VirtualHost *:80>
DocumentRoot "c:/xampp/htdocs/website"
ServerName website.localhost.com
</VirtualHost>


but i'm not sure where the problem is...

Other local websites not running Jat3 2.0 is suffering similar fates. PLEASE help
chiefbum
 
Posts: 4
Joined: 02. August 2012 12:55
Operating System: Windows 7 64 bitts

Re: New computer, old local websites starts but with errors

Postby JonB » 02. August 2012 13:56

This is interesting -

my xampp version is 3.0.12


That is the XAMPP "CONTROL PANEL" version

Well its pretty simple actually -

You need to install the same version of XAMPP on your 'new' machine as was on your 'old' machine. The problem simply goes to the fact that your scripts (read Joomla) are not 'up-to-date' enough to run correctly with the current version of PHP included with XAMPP.

You can look in the root of your backup of your 'old' xampp and open the readme_de.txt or readme_en.txt files to see what version of XAMPP you had installed. Its probably 1.7.4 or 1.7.7

Good Luck.
8)



ytsfa
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: New computer, old local websites starts but with errors

Postby chiefbum » 03. August 2012 04:20

thanks jonb,

i tried both versions (1.7.4 win32 and 1.7.7 win32) and still gives out those error lines.

Before installation i made sure the services were inactive and stopped first then installed the files. But still not working.

I really wished it was as simple as we hoped
chiefbum
 
Posts: 4
Joined: 02. August 2012 12:55
Operating System: Windows 7 64 bitts

Re: New computer, old local websites starts but with errors

Postby JonB » 03. August 2012 07:28

Look in your old php.ini file and check the 'error_reporting =' values - compare with the defaults set in the new install's php.ini

You may have had to adjust them previously.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: New computer, old local websites starts but with errors

Postby chiefbum » 04. August 2012 05:27

I did do that but it didn't fix on some local websites but it did to others.

On the ones it didn't fix it gets even worse... if i use "none" or "minimal" reporting for example website will not load and no error warnings given like the one i mentioned above.

I wonder why JonB?
chiefbum
 
Posts: 4
Joined: 02. August 2012 12:55
Operating System: Windows 7 64 bitts

Re: New computer, old local websites starts but with errors

Postby JonB » 04. August 2012 11:07

Its impossible for me to guess what makes your 'local websites' unique form each other. That is particularly true if they are dynamic rather than static.

You should look in the error logs (I am assuming the errors in your first post were 'display errors'). Some third party scripts have custom error logs, I don't know if this is true of Joomla - so I would check with them.

The rules/syntax changes with each PHP release. You say 'websites' - but I don't know if they are all Joomla powered. If these are things you did not code, you should check with the authors/developers.

Apparently based on previous comments here and after doing some searching Joomla has some problems with PHP 5.4. Re-installing with XAMPP 1.7.7 (which has PHP 5.3.8) might be a good solution for you.

Good Luck
8)



Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: New computer, old local websites starts but with errors

Postby chiefbum » 05. August 2012 04:11

ok JonB thanks champion
chiefbum
 
Posts: 4
Joined: 02. August 2012 12:55
Operating System: Windows 7 64 bitts


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests