localhost won't load

Problems with the Windows version of XAMPP, questions, comments, and anything related.

localhost won't load

Postby TheCowl » 31. July 2012 18:37

Hello,

I'm having issues with localhost not loading anything. I've seen the issue posted elsewhere on the forum but the solution that worked for them did not for me. No error message appears, pages are just perpetually loading. I can't seem to figure this one out. I've posted Apache error logs below.

Code: Select all
[Tue Jul 31 17:35:20.421197 2012] [core:warn] [pid 5320:tid 472] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue Jul 31 17:35:21.110236 2012] [ssl:warn] [pid 5320:tid 472] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Tue Jul 31 17:35:22.514317 2012] [mpm_winnt:notice] [pid 5320:tid 472] AH00455: Apache/2.4.2 (Win32) OpenSSL/1.0.1c PHP/5.4.4 configured -- resuming normal operations
[Tue Jul 31 17:35:22.515317 2012] [mpm_winnt:notice] [pid 5320:tid 472] AH00456: Server built: May 13 2012 14:10:15
[Tue Jul 31 17:35:22.515317 2012] [core:notice] [pid 5320:tid 472] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Tue Jul 31 17:35:22.521317 2012] [mpm_winnt:notice] [pid 5320:tid 472] AH00418: Parent: Created child process 2064
[Tue Jul 31 17:35:24.580435 2012] [ssl:warn] [pid 2064:tid 552] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Tue Jul 31 17:35:24.640438 2012] [mpm_winnt:notice] [pid 2064:tid 552] AH00354: Child: Starting 150 worker threads.
[Tue Jul 31 17:35:24.657439 2012] [mpm_winnt:error] [pid 2064:tid 1932] (OS 10038)An operation was attempted on something that is not a socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Tue Jul 31 17:35:24.658439 2012] [mpm_winnt:error] [pid 2064:tid 1960] (OS 10038)An operation was attempted on something that is not a socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Tue Jul 31 17:35:24.657439 2012] [mpm_winnt:error] [pid 2064:tid 1944] (OS 10038)An operation was attempted on something that is not a socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Tue Jul 31 17:35:24.653439 2012] [mpm_winnt:error] [pid 2064:tid 1732] (OS 10038)An operation was attempted on something that is not a socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Tue Jul 31 17:45:01.958974 2012] [core:warn] [pid 4860:tid 476] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue Jul 31 17:45:02.504975 2012] [ssl:warn] [pid 4860:tid 476] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Tue Jul 31 17:45:05.125780 2012] [mpm_winnt:notice] [pid 4860:tid 476] AH00455: Apache/2.4.2 (Win32) OpenSSL/1.0.1c PHP/5.4.4 configured -- resuming normal operations
[Tue Jul 31 17:45:05.125780 2012] [mpm_winnt:notice] [pid 4860:tid 476] AH00456: Server built: May 13 2012 14:10:15
[Tue Jul 31 17:45:05.125780 2012] [core:notice] [pid 4860:tid 476] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Tue Jul 31 17:45:05.125780 2012] [mpm_winnt:notice] [pid 4860:tid 476] AH00418: Parent: Created child process 4284
[Tue Jul 31 17:45:06.982183 2012] [ssl:warn] [pid 4284:tid 556] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Tue Jul 31 17:45:07.013383 2012] [mpm_winnt:notice] [pid 4284:tid 556] AH00354: Child: Starting 150 worker threads.
[Tue Jul 31 17:45:07.028983 2012] [mpm_winnt:error] [pid 4284:tid 1936] (OS 10038)An operation was attempted on something that is not a socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Tue Jul 31 17:45:07.044583 2012] [mpm_winnt:error] [pid 4284:tid 1956] (OS 10038)An operation was attempted on something that is not a socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Tue Jul 31 17:45:07.028983 2012] [mpm_winnt:error] [pid 4284:tid 1928] (OS 10038)An operation was attempted on something that is not a socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Tue Jul 31 17:45:07.044583 2012] [mpm_winnt:error] [pid 4284:tid 1948] (OS 10038)An operation was attempted on something that is not a socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Tue Jul 31 18:32:36.130874 2012] [mpm_winnt:notice] [pid 4860:tid 476] AH00428: Parent: child process exited with status 4294967295 -- Restarting.
[Tue Jul 31 18:32:50.401690 2012] [core:warn] [pid 6124:tid 472] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue Jul 31 18:32:51.109731 2012] [ssl:warn] [pid 6124:tid 472] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Tue Jul 31 18:32:51.286741 2012] [mpm_winnt:notice] [pid 6124:tid 472] AH00455: Apache/2.4.2 (Win32) OpenSSL/1.0.1c PHP/5.4.4 configured -- resuming normal operations
[Tue Jul 31 18:32:51.286741 2012] [mpm_winnt:notice] [pid 6124:tid 472] AH00456: Server built: May 13 2012 14:10:15
[Tue Jul 31 18:32:51.286741 2012] [core:notice] [pid 6124:tid 472] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Tue Jul 31 18:32:51.293741 2012] [mpm_winnt:notice] [pid 6124:tid 472] AH00418: Parent: Created child process 5624
[Tue Jul 31 18:32:53.648876 2012] [ssl:warn] [pid 5624:tid 552] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Tue Jul 31 18:32:53.714880 2012] [mpm_winnt:notice] [pid 5624:tid 552] AH00354: Child: Starting 150 worker threads.
[Tue Jul 31 18:32:53.731881 2012] [mpm_winnt:error] [pid 5624:tid 1932] (OS 10038)An operation was attempted on something that is not a socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Tue Jul 31 18:32:53.731881 2012] [mpm_winnt:error] [pid 5624:tid 1944] (OS 10038)An operation was attempted on something that is not a socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Tue Jul 31 18:32:53.730881 2012] [mpm_winnt:error] [pid 5624:tid 1924] (OS 10038)An operation was attempted on something that is not a socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Tue Jul 31 18:32:53.731881 2012] [mpm_winnt:error] [pid 5624:tid 1952] (OS 10038)An operation was attempted on something that is not a socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?


Thank you for your help!
TheCowl
 
Posts: 3
Joined: 31. July 2012 18:11
Operating System: Windows 7 Home Premium 64-bit

Re: localhost won't load

Postby Altrea » 31. July 2012 19:51

Hi TheCowl,

Please try out the following fix:
viewtopic.php?f=16&t=51072&p=196699#p196740

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost won't load

Postby TheCowl » 01. August 2012 12:44

Hi Altrea,

Thank you for your reply. I've already tried that fix but unfortunately I receive the message:
Code: Select all
The following helper DLL cannot be loaded: WSHELPER.DLL
The following command was not found: winsock reset


I also tried the Windows fix it tool that was linked to in that post but that didn't solve the problem either.

Any ideas?

Thanks again!
TheCowl
 
Posts: 3
Joined: 31. July 2012 18:11
Operating System: Windows 7 Home Premium 64-bit

Re: localhost won't load

Postby JonB » 01. August 2012 15:07

Did you use the 'run as administrator' option?

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: localhost won't load

Postby TheCowl » 01. August 2012 16:57

Hi JonB,

Yes, I ran command as administrator and that was the error message I got.

Thanks.
TheCowl
 
Posts: 3
Joined: 31. July 2012 18:11
Operating System: Windows 7 Home Premium 64-bit

Re: localhost won't load

Postby JonB » 01. August 2012 21:55

OK -

The command you entered was "netsh winsock reset" correct???

If neither the MS Fixit or the command line netsh winsock reset worked (as you say) --
you have a windows OS problem.

Some Googling with the two errors returned a lot of 'non-solutions', but also some suggestions

- some folks found that disabling their firewall before applying the fix did the trick.

These are what I Googled -
The following helper DLL cannot be loaded: WSHELPER.DLL
The following command was not found: winsock reset

The second error was probably caused by the first - cascade failure

You should use explorer to search your C:\ drive for "WSHELPER.DLL"
there should be files with that name (different) in

C:\Windows\System32
and
C:\Windows\SysWOW64

If one or both are missing, that is the likely cause of both the MS Fixit and the manual failures. The Fixits are just automated vbs scripts to enter the commands for you in most cases.

Possible fixes -

Use Windows System Restore to roll back - it does not affect data - only "installed programs", (XAMPP itself is not installed as far as Windows is concerned) the Windows registry, and Windows OS components

Use Windows System File Scanner to restore missing Windows Systems files

Although this page is about winsock.dll (a related .dll file) it explains about missing Windows OS files quite well (and provides links for those tools):
http://pcsupport.about.com/od/findbyerr ... -error.htm

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: JJ_Tagy and 38 guests