phpMyAdmin access problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpMyAdmin access problem

Postby crapshoot » 30. July 2012 00:10

Okay, I am so confused that there is no specific or easy instructions on access myphpadmin from the computer I installed it on????

xampp 1.7.7 on vista enterprise ( i know not my prefered system)
I get the typical
New XAMPP security concept:

Access to the requested object is only available from the local network.

This setting can be configured in the file "httpd-xampp.conf".

If i comment out from LocationMatch
#Order deny, allow
#Deny from all
for both the security section and sites of the httpd-xampp.conf
from the extra folder it gives me
The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster
Error 404

I am running on a closed testing network and just want this to be easy like earlier versions.
Please help me with exact detailed steps in correcting this issue. I have been all over the forums and nothing is working

thanks
Greg
crapshoot
 
Posts: 1
Joined: 29. July 2012 23:57
Operating System: vista enterprise

Re: phpMyAdmin access problem

Postby JonB » 30. July 2012 09:35

Crapshoot - I split your post, as the topic you posted on was YEARS old -- generally, please don't post on a thread if it is not the same version of the software.

If i comment out from LocationMatch
#Order deny, allow
#Deny from all
for both the security section and sites of the httpd-xampp.conf
from the extra folder it gives me
The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.


that is because - effectively - by making those changes, you told Apache to not allow anyone. Don't concern yourself with that outcome.

Please put the httpd-xampp.conf file back to its original state.

For the record - you should be able to access phpMyAdmin from localhost after installation. (http://localhost/phpmyadmin)

What is happening, for better or worse, is that the machine you are on is failing the IP address test.

Code: Select all
Allow from ::1 127.0.0.0/8


You might try this: check your hosts file to see if it contains a line

Code: Select all
127.0.0.1    localhost


If not, try adding that line, restart and try XAMPP again
http://geekswithblogs.net/thibbard/arch ... vista.aspx

If that does not fix things - A few questions:

From what you said, you were trying to access XAMPP form the machine it is installed on - correct?

What was the exact URL you used to try to access phpMyAdmin?

Can you access the XAMPP Welcome Page at all? (http://localhost/xampp)

Did you happen to set the server IP to the LAN IP of the machine XAMPP is installed on (for example, something like 192.168.1.108)

Lastly - please open a command window and ping localhost...


Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 77 guests