Localhost don't want to load [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Localhost don't want to load [Solved]

Postby azath » 26. July 2012 09:41

Hi, yesterday after 2-3 weeks I tried to start xampp regularly, I turn on apache and mysql, everything ok, but when I try to access localhost through browser I cannot load the page, this happen with any browser.

I searched a bit online and I tried some solutions:
-Go through 127.0.0.1
-Check the file "hosts" of windows for "127.0.0.1 localhost"
-Disable ipv6 (I found people who solved it)
-Re-install Xampp, the new version (done 5 times more and restarting the PC)
Check-up port of apache (apache start without apparent problems, Main port 80, SSL 443)

None of these solutions worked.

OS Windows 7, Xampp version 1.8.0

Sorry for bad English :S
azath
 
Posts: 4
Joined: 26. July 2012 09:23
Operating System: Windows 7

Re: Localhost don't want to load

Postby JonB » 26. July 2012 15:51

well - knowing the actual error mesaage might be useful
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Localhost don't want to load

Postby azath » 26. July 2012 16:25

Problem is that there is no error displayed, just cannot load the page, browser keep try to load but nothing happens.
azath
 
Posts: 4
Joined: 26. July 2012 09:23
Operating System: Windows 7

Re: Localhost don't want to load

Postby JonB » 26. July 2012 17:48

If Apache shows as 'started' in the Control Panel, then there will be an Apache Error Log

\xampp\apache\logs\error.log

posting the parts from one or two attempts might give us a good clue.

You also might want to look in the Windows Event logs - check the Application and System logs to see if you are getting OS errors.

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Localhost don't want to load

Postby azath » 26. July 2012 18:33

Code: Select all
[Thu Jul 26 15:25:13.105052 2012] [ssl:warn] [pid 5032:tid 360] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Jul 26 15:25:13.198057 2012] [mpm_winnt:notice] [pid 5032:tid 360] AH00455: Apache/2.4.2 (Win32) OpenSSL/1.0.1c PHP/5.4.4 configured -- resuming normal operations
[Thu Jul 26 15:25:13.198057 2012] [mpm_winnt:notice] [pid 5032:tid 360] AH00456: Server built: May 13 2012 14:10:15
[Thu Jul 26 15:25:13.198057 2012] [core:notice] [pid 5032:tid 360] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Thu Jul 26 15:25:13.203057 2012] [mpm_winnt:notice] [pid 5032:tid 360] AH00418: Parent: Created child process 284
[Thu Jul 26 15:25:16.769261 2012] [ssl:warn] [pid 284:tid 372] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Jul 26 15:25:16.863267 2012] [mpm_winnt:notice] [pid 284:tid 372] AH00354: Child: Starting 150 worker threads.
[Thu Jul 26 15:25:16.870267 2012] [mpm_winnt:error] [pid 284:tid 1880] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 15:25:16.870267 2012] [mpm_winnt:error] [pid 284:tid 1884] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 15:25:16.870267 2012] [mpm_winnt:error] [pid 284:tid 1892] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 15:25:16.870267 2012] [mpm_winnt:error] [pid 284:tid 1888] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 15:42:59.801423 2012] [core:warn] [pid 3820:tid 240] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Thu Jul 26 15:43:00.191424 2012] [ssl:warn] [pid 3820:tid 240] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Jul 26 15:43:00.425424 2012] [mpm_winnt:notice] [pid 3820:tid 240] AH00455: Apache/2.4.2 (Win32) OpenSSL/1.0.1c PHP/5.4.4 configured -- resuming normal operations
[Thu Jul 26 15:43:00.425424 2012] [mpm_winnt:notice] [pid 3820:tid 240] AH00456: Server built: May 13 2012 14:10:15
[Thu Jul 26 15:43:00.425424 2012] [core:notice] [pid 3820:tid 240] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Thu Jul 26 15:43:00.425424 2012] [mpm_winnt:notice] [pid 3820:tid 240] AH00418: Parent: Created child process 996
[Thu Jul 26 15:43:01.634227 2012] [ssl:warn] [pid 996:tid 252] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Jul 26 15:43:01.664227 2012] [mpm_winnt:notice] [pid 996:tid 252] AH00354: Child: Starting 150 worker threads.
[Thu Jul 26 15:43:01.664227 2012] [mpm_winnt:error] [pid 996:tid 1760] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 15:43:01.664227 2012] [mpm_winnt:error] [pid 996:tid 1768] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 15:43:01.664227 2012] [mpm_winnt:error] [pid 996:tid 1772] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 15:43:01.664227 2012] [mpm_winnt:error] [pid 996:tid 1764] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 15:48:37.680413 2012] [mpm_winnt:notice] [pid 3820:tid 240] AH00428: Parent: child process exited with status 4294967295 -- Restarting.
[Thu Jul 26 18:42:56.291517 2012] [core:warn] [pid 3416:tid 240] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Thu Jul 26 18:42:56.759518 2012] [ssl:warn] [pid 3416:tid 240] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Jul 26 18:42:56.884318 2012] [mpm_winnt:notice] [pid 3416:tid 240] AH00455: Apache/2.4.2 (Win32) OpenSSL/1.0.1c PHP/5.4.4 configured -- resuming normal operations
[Thu Jul 26 18:42:56.884318 2012] [mpm_winnt:notice] [pid 3416:tid 240] AH00456: Server built: May 13 2012 14:10:15
[Thu Jul 26 18:42:56.884318 2012] [core:notice] [pid 3416:tid 240] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Thu Jul 26 18:42:56.931118 2012] [mpm_winnt:notice] [pid 3416:tid 240] AH00418: Parent: Created child process 2320
[Thu Jul 26 18:42:57.773520 2012] [ssl:warn] [pid 2320:tid 252] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Jul 26 18:42:57.804720 2012] [mpm_winnt:notice] [pid 2320:tid 252] AH00354: Child: Starting 150 worker threads.
[Thu Jul 26 18:42:57.820320 2012] [mpm_winnt:error] [pid 2320:tid 1768] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 18:42:57.820320 2012] [mpm_winnt:error] [pid 2320:tid 1772] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 18:42:57.820320 2012] [mpm_winnt:error] [pid 2320:tid 1764] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 18:42:57.820320 2012] [mpm_winnt:error] [pid 2320:tid 1760] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 19:31:23.949030 2012] [core:warn] [pid 5512:tid 240] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Thu Jul 26 19:31:24.198044 2012] [ssl:warn] [pid 5512:tid 240] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Jul 26 19:31:24.230046 2012] [mpm_winnt:notice] [pid 5512:tid 240] AH00455: Apache/2.4.2 (Win32) OpenSSL/1.0.1c PHP/5.4.4 configured -- resuming normal operations
[Thu Jul 26 19:31:24.230046 2012] [mpm_winnt:notice] [pid 5512:tid 240] AH00456: Server built: May 13 2012 14:10:15
[Thu Jul 26 19:31:24.230046 2012] [core:notice] [pid 5512:tid 240] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Thu Jul 26 19:31:24.231046 2012] [mpm_winnt:notice] [pid 5512:tid 240] AH00418: Parent: Created child process 6060
[Thu Jul 26 19:31:25.128097 2012] [ssl:warn] [pid 6060:tid 252] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Jul 26 19:31:25.160099 2012] [mpm_winnt:notice] [pid 6060:tid 252] AH00354: Child: Starting 150 worker threads.[Thu Jul 26 19:31:25.165099 2012] [mpm_winnt:error] [pid 6060:tid 1756] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 19:31:25.165099 2012] [mpm_winnt:error] [pid 6060:tid 1728] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 19:31:25.165099 2012] [mpm_winnt:error] [pid 6060:tid 1764] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Jul 26 19:31:25.165099 2012] [mpm_winnt:error] [pid 6060:tid 1760] (OS 10038)Tentativo di operazione su un elemento diverso dal socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?


This is a part of error log, ipv6 is enabled.
azath
 
Posts: 4
Joined: 26. July 2012 09:23
Operating System: Windows 7

Re: Localhost don't want to load

Postby JonB » 27. July 2012 15:08

OK

It 'did' work originally, is that correct?

It was the same version of XAMPP???

[mpm_winnt:error] [pid 2320:tid 1768] (OS 10038) <-- I think its a Windows issue with the TCP/IP stack

Command Window > Run As Administrator

Code: Select all
 netsh winsock reset


http://support.microsoft.com/kb/299357

Restart and try XAMPP again

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Localhost don't want to load

Postby azath » 29. July 2012 12:53

Thank you so much :)
azath
 
Posts: 4
Joined: 26. July 2012 09:23
Operating System: Windows 7

Re: Localhost don't want to load [Solved]

Postby JonB » 29. July 2012 16:47

OK, glad it worked -

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests