Cannot access security page!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cannot access security page!

Postby cray » 22. July 2012 14:51

Hey guys,

I installed XAMPP 1.8.0 today. The issue i'm having is, whenever I visit the security page to try to secure my xampp directory and phpmyadmin links, only the security status is being shown. I'm not being provided with a link to set passwords for the same. Also it say s maximum execution time of 30s exceeded. I've attached a SS of what i'm seeing below. Please help me out someone. Thanks ;)

Image
cray
 
Posts: 3
Joined: 22. July 2012 14:46
Operating System: Windows 7

Re: Cannot access security page!

Postby JonB » 22. July 2012 15:00

If you have not down this already - I suggest you shut everything down and restart your machine. Before you try again to set security, clear your browsers' cache.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Cannot access security page!

Postby cray » 22. July 2012 15:08

Thanks JonB. I tried doing all that. Tried different browsers too. Tried to access via 'localhost' as well as 127.0.0.1. Nothing works :'(
cray
 
Posts: 3
Joined: 22. July 2012 14:46
Operating System: Windows 7

Re: Cannot access security page!

Postby JonB » 22. July 2012 15:37

Do you have anything, other than XAMPP itself, set up or installed into this installation?
Was this 'an upgrade' of any sort???

IF not, I would do a fresh download & install from either the .zip or 7z downloads.

If you made any of the components into a service, be sure to remove them as services with the Control Panel or the 'sc delete' command line tool, before un-installing/removing XAMPP.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Cannot access security page!

Postby JonB » 29. July 2012 01:41

I think this may have been due to cookies being disabled. Just an 'intuit' moment

:shock:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Cannot access security page!

Postby cray » 29. July 2012 19:02

Thanks JonB for all the help. But finally managed to figure out the problem. As the page shows, navigate to your C:\Xampp\security\htdocs\security.php file. Edit it and scroll to the line 100, or search for,

Code: Select all
$conn_id = ftp_connect("127.0.0.1");


Just comment this section out. That is, change the above line to,

Code: Select all
//$conn_id = ftp_connect("127.0.0.1");


Save the file, and go back to the security page. Would work now!.The above fix is for all those who're facing the same problem as mine ;)
cray
 
Posts: 3
Joined: 22. July 2012 14:46
Operating System: Windows 7

Re: Cannot access security page!

Postby JonB » 29. July 2012 21:16

Well, thanks for posting that info.

There is likely a bug there, although I am unsure how it is being triggered. Yours is apparently the only report of the problem.

OK, when you ran the security script were you on http://localhost???

or were you on a different IP, a hostname or ::1?

Thanks again.
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests