1.8.0 Access to phpMyAdmin [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

1.8.0 Access to phpMyAdmin [Solved]

Postby ChrisJakarta » 21. July 2012 07:22

I'm having all sorts of problems trying to get phpMyAdmin to work in Xampp 1.8.0 in Windows XP SP3. For information, I seem to have three version of Microsoft C++ 2008 runtime libraries installed.

First, I tried installing the installer verion. Then, having set a root password for MySQL, when trying to access phpMyAdmin, I got the following message:
Welcome to phpMyAdmin

Error

MySQL said:
Cannot connect: invalid settings.
phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

I could find no way to correct this. So I finally removed this version (totally!) and I tried with the zip version. With this, after running Setup and changing the root password in MySQL, nothing happened when I entered this into the phpMyAdmin login page, it just cleared the entries in the boxes and waited...

I then tried to edit config.inc.php as suggested in the documentation. After adding the password (in clear!) and changing 'auth_type' to 'config', I was able to get into the phpMyAdmin home page. However, after selecting Users, and clicking 'Add User', I got a message 'Loading' but it then hung.

I am not an expert, just a user. Is this behaviour normal? What am I missing? Any assistance would be appreciated...

Chris
ChrisJakarta
 
Posts: 10
Joined: 26. August 2009 03:31

Re: 1.8.0 Access to phpMyAdmin

Postby JonB » 22. July 2012 15:51

How are you setting the MySQL 'root' password?

:?:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: 1.8.0 Access to phpMyAdmin

Postby ChrisJakarta » 24. July 2012 04:25

JonB wrote:How are you setting the MySQL 'root' password?

:?:

JonB,

I set the password by going to http://localhost/security/index.php, as described in the instructions at http://www.apachefriends.org/en/xampp-windows.html#1221

Chris
ChrisJakarta
 
Posts: 10
Joined: 26. August 2009 03:31

Re: 1.8.0 Access to phpMyAdmin

Postby JonB » 24. July 2012 11:52

OK -

Referring to your first post - I'm not aware of any reasons that should not work correctly using the 'built-in' tool/script.

The fact you are gaining access to phpMyAdmin - presuming your login is 'root' - means the settings are now correct.

1. We should probably see what is in the MySQL error log. The file is \xampp\mysql\data\mysql_error.log That might tell us what is happening when it goes to 'endlessly loading'. The Apache error log should also be checked (it could be that its Apache that is 'choking') \xampp\apache\logs\error.log

2. It might also be a good idea to look in the Windows Event Viewer Computer > Manage > Event Viewer. You should probably look in both the System and Application logs. The problem might be OS related or some thing(s) is not working as it should.

3. One other possibility is that the DL itself was corrupt. Whichever source you used, the MD5 checksum should be validated against the checksum given on the DL page.

4. In the realm of 'speak no evil', if this is an older machine -- its always a good idea to run a checkdisk (chkdsk) on the drive that has the problematic application.

Those are the things that come to mind.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: 1.8.0 Access to phpMyAdmin

Postby ChrisJakarta » 25. July 2012 10:34

JonB wrote:OK -

Referring to your first post - I'm not aware of any reasons that should not work correctly using the 'built-in' tool/script.

The fact you are gaining access to phpMyAdmin - presuming your login is 'root' - means the settings are now correct.

Thanks, Jon

JonB wrote:1. We should probably see what is in the MySQL error log. The file is \xampp\mysql\data\mysql_error.log That might tell us what is happening when it goes to 'endlessly loading'. The Apache error log should also be checked (it could be that its Apache that is 'choking') \xampp\apache\logs\error.log


Here ya go:
Code: Select all
120725 15:58:31 [Note] Plugin 'FEDERATED' is disabled.
120725 15:58:31 InnoDB: The InnoDB memory heap is disabled
120725 15:58:31 InnoDB: Mutexes and rw_locks use Windows interlocked functions
120725 15:58:31 InnoDB: Compressed tables use zlib 1.2.3
120725 15:58:31 InnoDB: Initializing buffer pool, size = 16.0M
120725 15:58:31 InnoDB: Completed initialization of buffer pool
InnoDB: The first specified data file D:\xampp\mysql\data\ibdata1 did not exist:
InnoDB: a new database to be created!
120725 15:58:31  InnoDB: Setting file D:\xampp\mysql\data\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
120725 15:58:31  InnoDB: Log file D:\xampp\mysql\data\ib_logfile0 did not exist: new to be created
InnoDB: Setting log file D:\xampp\mysql\data\ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
120725 15:58:32  InnoDB: Log file D:\xampp\mysql\data\ib_logfile1 did not exist: new to be created
InnoDB: Setting log file D:\xampp\mysql\data\ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: 127 rollback segment(s) active.
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
120725 15:58:33  InnoDB: Waiting for the background threads to start
120725 15:58:34 InnoDB: 1.1.8 started; log sequence number 0
120725 15:58:34 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
120725 15:58:34 [Note]   - '0.0.0.0' resolves to '0.0.0.0';
120725 15:58:34 [Note] Server socket created on IP: '0.0.0.0'.
120725 15:58:34 [Note] Event Scheduler: Loaded 0 events
120725 15:58:34 [Note] d:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.25a'  socket: ''  port: 3306  MySQL Community Server (GPL)
120725 16:03:05 [Note] Plugin 'FEDERATED' is disabled.
120725 16:03:05 InnoDB: The InnoDB memory heap is disabled
120725 16:03:05 InnoDB: Mutexes and rw_locks use Windows interlocked functions
120725 16:03:05 InnoDB: Compressed tables use zlib 1.2.3
120725 16:03:05 InnoDB: Initializing buffer pool, size = 16.0M
120725 16:03:05 InnoDB: Completed initialization of buffer pool
120725 16:03:05 InnoDB: highest supported file format is Barracuda.
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
120725 16:03:06  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
120725 16:03:14  InnoDB: Waiting for the background threads to start
120725 16:03:15 InnoDB: 1.1.8 started; log sequence number 1595675
120725 16:03:15 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
120725 16:03:15 [Note]   - '0.0.0.0' resolves to '0.0.0.0';
120725 16:03:15 [Note] Server socket created on IP: '0.0.0.0'.
120725 16:03:15 [Note] Event Scheduler: Loaded 0 events
120725 16:03:15 [Note] d:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.25a'  socket: ''  port: 3306  MySQL Community Server (GPL)


JonB wrote:2. It might also be a good idea to look in the Windows Event Viewer Computer > Manage > Event Viewer. You should probably look in both the System and Application logs. The problem might be OS related or some thing(s) is not working as it should.c

I don't see any errors. There are several Information reports in the Application log, as follows:
Code: Select all
The description for Event ID ( 100 ) in Source ( MySQL ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: d:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.25a'  socket: ''  port: 3306  MySQL Community Server (GPL)

I don't understand this. Is it relevant?

JonB wrote:3. One other possibility is that the DL itself was corrupt. Whichever source you used, the MD5 checksum should be validated against the checksum given on the DL page.

Download is correct... I also tried installing on another XP machine, and this gave no problems.

JonB wrote:4. In the realm of 'speak no evil', if this is an older machine -- its always a good idea to run a checkdisk (chkdsk) on the drive that has the problematic application.

Tried this. No improvement. Also tried using both Firefox and IE8.

JonB wrote:Those are the things that come to mind.

Oh dear! I'm lost. Luckily v1.7.3 continues to work OK.

Again, thanks for your help...

Chris
ChrisJakarta
 
Posts: 10
Joined: 26. August 2009 03:31

Re: 1.8.0 Access to phpMyAdmin

Postby JonB » 25. July 2012 22:59

Did you try the bind-address fix recommended by hackattack142?

Re: Error 2002 phpmyadmin

Postby hackattack142 » 24. July 2012 17:29
You might try opening your "/xampp/mysql/bin/my.ini" file, and finding this line:

Code: Select all
#bind-address="127.0.0.1"

, remove the "#" in front of it, save the file, and restart MySQL. When you visit the phpMyAdmin page http://localhost/phpmyadmin make sure you manually refresh the page in your browser so you do not get a cached error page.


Its quite odd you are only having problems on one machine, that seems like an environment/machine issue.

By any chance - is 1.7.3 still installed on that machine???

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: 1.8.0 Access to phpMyAdmin [solved]

Postby ChrisJakarta » 26. July 2012 05:31

Jon,

Again, thanks for your patience.

JonB wrote:Did you try the bind-address fix recommended by hackattack142?.


Tried, but no change

JonB wrote:Its quite odd you are only having problems on one machine, that seems like an environment/machine issue.


I thought I'd try with other browsers, and surprise, surprise, no problems with Chrome, Opera, or even SeaMonkey. Then I noticed the following message only appeared in the problem browsers:
Cookies must be enabled past this point.

(I suppose that should have clicked before, but I assumed this was a standard message)

And... In Firefox, for some unknown reason, local host and 127.0.0.1 were both blocked. Removed this block, and everything OK in Firefox. Had more difficulty clearing the blocks in IE, but in the end managed to get this working.

Hope this might assist others with this problem.

And yes, I do still have 1.7.3 installed on this machine, albeit in a different directory. Never had problems with this, and since xampp does write to the registry, I assume there should be no interactions.

So again, thanks for your patience. Glad we got the problem solved. Might be worthwhile making the cookies message a bit more specific ('Cookies are NOT enabled. They must be enabled...')

Chris
ChrisJakarta
 
Posts: 10
Joined: 26. August 2009 03:31


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests