pear for xampp question

Problems with the Windows version of XAMPP, questions, comments, and anything related.

pear for xampp question

Postby newbie10 » 19. July 2012 20:33

Hi,
I have the 1.8 usb version of xampp on windows 7. Typed in pear to the dos prompt. Get the following message:

PHP_PEAR_INSTALL_DIR is not set correctly. Please fix it using your environmental variable or modify the default value in pear.bat. The current value is: \xampp\php\pear.

Any help is appreciated.
newbie10
 
Posts: 5
Joined: 19. July 2012 20:20
Operating System: windows 7

Re: pear for xampp question

Postby JonB » 19. July 2012 21:22

it probably needs an absolute path i.e "driveletter:\xampp\php\pear"

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: pear for xampp question

Postby newbie10 » 19. July 2012 21:48

Thanks jonb,

Sorry ... so exactly how do I fix this? Is there a "how to" doc with step-by-step instructions somewhere that I might have missed? I believe I am using the latest, current stable version (e.g. 1.8).

P.S. There is no pear directory under PHP out of the box -even if there were a drive letter.
newbie10
 
Posts: 5
Joined: 19. July 2012 20:20
Operating System: windows 7

Re: pear for xampp question

Postby JonB » 19. July 2012 22:48

Sorry - no there isn't.

However - try it by launching your Control Panel and using the 'XAMPP Shell"

Let me know if that works.
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: pear for xampp question

Postby newbie10 » 19. July 2012 23:24

Thanks Jonb,

I am using the usb version. There is no regular control panel shell that I can see ... maybe I am missing something. There is an xampp_start.exe and a .bat but they do not seem to help.

P.S. Just installed the full version and it seems to work fine. I think there is an issue with pear and usb/lite version 1.8.0 . Perhaps someone knows more about that.
newbie10
 
Posts: 5
Joined: 19. July 2012 20:20
Operating System: windows 7

Re: pear for xampp question

Postby JonB » 20. July 2012 00:14

A. - As long as you can control the drive letter assignment, you can install the Full version on a stick (I have done that with several versions)

B. - I "think" you can just copy the control panel in (and its files).

C. - The Lite version is missing a lot of stuff. The problem you alluded to has to do with the need for a fully configured path/environment (as I tried to point out in the first post.) The devlopers didn't consult with me on their decision how to configure it (USB version).

"XAMPP Lite" s an additional extra small XAMPP edition. Configured with relative paths you can use it on usb devices.

Perhaps Altrea will have some other insight, and I'll send a link to the "chief wiz"...

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: pear for xampp question

Postby JonB » 20. July 2012 01:02

I have sent a note to 'those who matter' on these two posts as I think they reflect the same design choices. It may well be that some things just won't work with relative paths and the developers knew that when they decided on the 'design feature set'. (my working theory)

So your concerns have been heard. There may be nothing to be done with the current version other than hand configuring or running the full version.

Besides the above I will do some research on my own. However, as I am a full time developer and an Admin/Leader on another Open Source project, I cannot say when I will be able to do 'my thing' on this topic.

Good Luck on your projects.
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: pear for xampp question

Postby newbie10 » 20. July 2012 05:39

Thanks Jonb.

In the meanwhile, I did the following with the usb version:

1) As per pear website instructions downloaded go-pear.phar
2) php go-pear.phar
In the interactive prompt changed 11 to c:\xampp\php\pear.ini from c:\windows\pear.ini
3) followed interactive directions including double click on .reg file to update my windows env variables

Seems to work fine. (Installed phpunit for example w/o problems.) However, I did notice that a pear config-show prints User Configuration File as C:\windows\pear.ini. Not sure why. This causes a permissions issue if I try to do pear channel-update pear.php.net.
newbie10
 
Posts: 5
Joined: 19. July 2012 20:20
Operating System: windows 7

Re: pear for xampp question

Postby JonB » 20. July 2012 14:45

The c:\windows folder is an OS protected folder, so that might be the source of that issue. You could try running everything as Administrator (or activating Administrator and using that login to update), not too sure how that would work. I'm thinking that the pear process wants to update pear.ini (which is now in a restricted folder) and Windows is saying 'not so fast buddy'.

Just a guess.

Thanks for posting an update.
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: pear for xampp question

Postby newbie10 » 20. July 2012 17:20

Jonb,

Noticed a machine reboot solved my pear config-show (User Configuration File) problem. pear documentation said to reboot apache (which I had done) but that was not enough - a machine reboot worked for me though.
newbie10
 
Posts: 5
Joined: 19. July 2012 20:20
Operating System: windows 7

Re: pear for xampp question

Postby JonB » 21. July 2012 00:12

OK -

Thanks for the update

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 31 guests