Unrendered php code in browser on preview. [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Unrendered php code in browser on preview. [Solved]

Postby inspiration1312 » 16. July 2012 12:35

I am using xampp v1.7.7,and tried many methods but no success. Also googled a lot but no straight answer. I read about httpd.conf but I have no knowledge about it. I thought restarting apache server would solve problem, clicking on stop button shows error:
BUSY...
Error: -1

Please suggest!

Thanks.
inspiration1312
 
Posts: 10
Joined: 13. July 2012 19:56
Operating System: windows vista

Re: Showing unrendered php code in browser on preview.

Postby JonB » 16. July 2012 14:21

What is in the Apache error log?

:?:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Showing unrendered php code in browser on preview.

Postby inspiration1312 » 16. July 2012 20:04

BUSY...
Error: -1
inspiration1312
 
Posts: 10
Joined: 13. July 2012 19:56
Operating System: windows vista

Re: Showing unrendered php code in browser on preview.

Postby JonB » 16. July 2012 20:56

That is not the Apache error log (afaik)

\xampp\apache\logs\error.log

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Showing unrendered php code in browser on preview.

Postby inspiration1312 » 17. July 2012 16:09

oh so sorry, my bad!
The error first occurred on 15 july.
here it is:

Sun Jul 15 10:23:35 2012] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Jul 15 10:23:35 2012] [notice] Digest: generating secret for digest authentication ...
[Sun Jul 15 10:23:35 2012] [notice] Digest: done
[Sun Jul 15 10:23:40 2012] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Jul 15 10:23:40 2012] [notice] Server built: Sep 10 2011 11:34:11
[Sun Jul 15 10:23:40 2012] [notice] Parent: Created child process 2964
[Sun Jul 15 10:23:42 2012] [notice] Digest: generating secret for digest authentication ...
[Sun Jul 15 10:23:42 2012] [notice] Digest: done
[Sun Jul 15 10:23:43 2012] [notice] Child 2964: Child process is running
[Sun Jul 15 10:23:43 2012] [notice] Child 2964: Acquired the start mutex.
[Sun Jul 15 10:23:43 2012] [notice] Child 2964: Starting 150 worker threads.
[Sun Jul 15 10:23:43 2012] [notice] Child 2964: Starting thread to listen on port 443.
[Sun Jul 15 10:23:43 2012] [notice] Child 2964: Starting thread to listen on port 443.
[Sun Jul 15 10:23:43 2012] [notice] Child 2964: Starting thread to listen on port 80.
[Sun Jul 15 10:23:43 2012] [notice] Child 2964: Starting thread to listen on port 80.
Terminating on signal SIGTERM(15)
[Sun Jul 15 13:26:38 2012] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Jul 15 13:26:38 2012] [notice] Digest: generating secret for digest authentication ...
[Sun Jul 15 13:26:38 2012] [notice] Digest: done
[Sun Jul 15 13:26:42 2012] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Jul 15 13:26:42 2012] [notice] Server built: Sep 10 2011 11:34:11
[Sun Jul 15 13:26:42 2012] [notice] Parent: Created child process 2264
[Sun Jul 15 13:26:44 2012] [notice] Digest: generating secret for digest authentication ...
[Sun Jul 15 13:26:44 2012] [notice] Digest: done
[Sun Jul 15 13:26:45 2012] [notice] Child 2264: Child process is running
[Sun Jul 15 13:26:45 2012] [notice] Child 2264: Acquired the start mutex.
[Sun Jul 15 13:26:45 2012] [notice] Child 2264: Starting 150 worker threads.
[Sun Jul 15 13:26:45 2012] [notice] Child 2264: Starting thread to listen on port 443.
[Sun Jul 15 13:26:45 2012] [notice] Child 2264: Starting thread to listen on port 80.
[Sun Jul 15 13:26:45 2012] [notice] Child 2264: Starting thread to listen on port 443.
[Sun Jul 15 13:26:45 2012] [notice] Child 2264: Starting thread to listen on port 80.
Terminating on signal SIGTERM(15)
[Mon Jul 16 10:59:51 2012] [notice] Digest: generating secret for digest authentication ...
[Mon Jul 16 10:59:51 2012] [notice] Digest: done
[Mon Jul 16 10:59:56 2012] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Jul 16 10:59:56 2012] [notice] Server built: Sep 10 2011 11:34:11
[Mon Jul 16 10:59:56 2012] [notice] Parent: Created child process 2916
[Mon Jul 16 11:00:07 2012] [notice] Digest: generating secret for digest authentication ...
[Mon Jul 16 11:00:07 2012] [notice] Digest: done
[Mon Jul 16 11:00:09 2012] [notice] Child 2916: Child process is running
[Mon Jul 16 11:00:09 2012] [notice] Child 2916: Acquired the start mutex.
[Mon Jul 16 11:00:09 2012] [notice] Child 2916: Starting 150 worker threads.
[Mon Jul 16 11:00:09 2012] [notice] Child 2916: Starting thread to listen on port 443.
[Mon Jul 16 11:00:09 2012] [notice] Child 2916: Starting thread to listen on port 443.
[Mon Jul 16 11:00:09 2012] [notice] Child 2916: Starting thread to listen on port 80.
[Mon Jul 16 11:00:09 2012] [notice] Child 2916: Starting thread to listen on port 80.
[Mon Jul 16 22:24:34 2012] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/announce

Thanks
inspiration1312
 
Posts: 10
Joined: 13. July 2012 19:56
Operating System: windows vista

Re: Showing unrendered php code in browser on preview.

Postby JonB » 18. July 2012 14:41

It looks like XAMPP is starting correctly

A. what happens when you go to http://localhost/xampp in your browser?

B. 1 -I expect you are trying to access your PHP pages by opening them in a browser?
2. or by 'preview' do you mean using "dreamweaver'?
"if the answer is 2 - it is a Dreamweaver issue"

C. You should use the new XAMPP Control Panel - either use xampp-control-3-beta.exe in the root of \xampp (1.7.7) or DL the latest version by following this Control Panel thread:
viewtopic.php?f=16&t=46743
(its also included in the 1.8.0 package as xampp-control.exe)

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Showing unrendered php code in browser on preview.

Postby inspiration1312 » 18. July 2012 14:58

A. It shows no problem when started, opens up welcome screen.

B.Yes, coding in editor and then previewing in browser.

C.I thought of restating the xampp server in the control panel, but it doesn't stop.

Thanks
inspiration1312
 
Posts: 10
Joined: 13. July 2012 19:56
Operating System: windows vista

Re: Showing unrendered php code in browser on preview.

Postby inspiration1312 » 18. July 2012 14:59

Is it the same as xampp version 1.8.0 control panel??
inspiration1312
 
Posts: 10
Joined: 13. July 2012 19:56
Operating System: windows vista

Re: Showing unrendered php code in browser on preview.

Postby JonB » 18. July 2012 15:13

OK -

A. - means XAMPP is working right

B. - I thought that might be the case, best place for an answer is Adobe Forums.

C. - What 'doesn't stop' ? (the error message???) Its probably a 'cosmetic error' meaning a incorrect indicator.

D. - The latest Control Panel version is 3.0.12, which is included with XAMPP 1.8.0 or can be DL'ed by following the New Control Panel topic.
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Unrendered php code in browser on preview. [Solved]

Postby JonB » 18. July 2012 15:45

OK, glad its working -

Good Luck with your projects -
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Unrendered php code in browser on preview. [Solved]

Postby JonB » 18. July 2012 22:45

@ inspiration -

Your problem with Control Panel is here now - hackattack142 would like to see if he can help you with it :)

viewtopic.php?f=16&t=46743&start=105#p196353

good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests