Apache Will Not Start on Windows XP [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Will Not Start on Windows XP [Solved]

Postby cmb » 15. July 2012 00:18

I have installed XAMPP 1.8.0 on Windows XP as follows:

    Renamed the old (working) XAMPP 1.7.7 directory from C:/XAMPP to C:/XAMPP_1_7_7 to preserve it as a backup.
    Installed the XAMPP 1.8.0 to C:/XAMPP using the xampp-win32-1.8.0-VC9-installer.exe file.
    Restarted the computer.
    Opened the XAMPP Control Panel v3.0.12.
    Clicked the Start button for Apache.
The Windows error message received is: "Apache HTTP Server has encountered a problem and needs to close." I dismiss the error message with a Don't Send. The error messages continue to appear until I click the Apache Stop button.

Here's a piece of the error log:
[Sat Jul 14 16:09:07.203125 2012] [ssl:warn] [pid 6044:tid 204] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sat Jul 14 16:09:07.359375 2012] [mpm_winnt:notice] [pid 6044:tid 204] AH00455: Apache/2.4.2 (Win32) OpenSSL/1.0.1c PHP/5.4.4 configured -- resuming normal operations
[Sat Jul 14 16:09:07.359375 2012] [mpm_winnt:notice] [pid 6044:tid 204] AH00456: Server built: May 13 2012 14:10:15
[Sat Jul 14 16:09:07.359375 2012] [core:notice] [pid 6044:tid 204] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sat Jul 14 16:09:07.359375 2012] [mpm_winnt:notice] [pid 6044:tid 204] AH00418: Parent: Created child process 5412
[Sat Jul 14 16:09:08.734375 2012] [ssl:warn] [pid 5412:tid 1864] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sat Jul 14 16:09:08.890625 2012] [mpm_winnt:notice] [pid 5412:tid 1864] AH00354: Child: Starting 150 worker threads.
[Sat Jul 14 16:09:11.281250 2012] [mpm_winnt:notice] [pid 6044:tid 204] AH00428: Parent: child process exited with status 3221225725 -- Restarting.


Can this installation be saved?
Charles
cmb
 
Posts: 4
Joined: 14. July 2012 23:24
Operating System: Windows XP

Re: Apache Will Not Start on Windows XP

Postby WilliL » 15. July 2012 12:45

did you configured 177 as service? did you stopped it?
did you install 180 by zip or installer version?

an opinon:
delete 180 and make new install using new folder c:\xampp180 (installer version) - works for me on my win xp fine
Rename your elder version back and have a look.

If you are using different xampp versiones, you shouldn't use services.
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: Apache Will Not Start on Windows XP

Postby cmb » 15. July 2012 17:07

WilliL wrote:did you configured 177 as service?

No.
did you stopped it?

Yes.
did you install 180 by zip or installer version?

cmb wrote:Installed the XAMPP 1.8.0 to C:/XAMPP using the xampp-win32-1.8.0-VC9-installer.exe file.
Charles
cmb
 
Posts: 4
Joined: 14. July 2012 23:24
Operating System: Windows XP

Re: Apache Will Not Start on Windows XP

Postby hackattack142 » 15. July 2012 17:37

The output in your error log is normal (mine looks like that as well). It is primarily just notices and a few warnings but no errors in what you posted. You should check your Windows Event Viewer as well to see if there is additional information on how it is crashing (Start > Run > eventvwr, look under the Application section).
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache Will Not Start on Windows XP

Postby cmb » 15. July 2012 18:03

hackattack142 wrote:...check your Windows Event Viewer as well...

I cleared my Event Viewer logs to remove the clutter. Then I tried to start Apache from the XAMPP control panel. Lo and behold, the Event Viewer Application area shows this error:
Event Type: Error, Event Source: Application Error, Event Category: None
Description: Faulting application httpd.exe, version 2.4.2.0, faulting module nvlsp.dll, version 2.2.0.6796, fault address 0x0000e0a7.
Charles
cmb
 
Posts: 4
Joined: 14. July 2012 23:24
Operating System: Windows XP

Re: Apache Will Not Start on Windows XP

Postby hackattack142 » 15. July 2012 18:48

The faulting module appears to be related to nVidia. Do you by chance have the nVidia Forceware Network Manager and/or the nVidia Application Filter installed?
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache Will Not Start on Windows XP

Postby cmb » 15. July 2012 19:15

In addition to the nVidia video drivers I have version 1.00.6796 of nVidia Forceware Network Manager installed. It probably came in with a video driver update. I removed the Forceware Network Manager and now Apache starts correctly. Thank you. :D
Charles
cmb
 
Posts: 4
Joined: 14. July 2012 23:24
Operating System: Windows XP


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 32 guests